Преминаване към основното съдържание
Поддръжка
Влизане с Microsoft
Влезте или създайте акаунт.
Здравейте,
Изберете друг акаунт.
Имате няколко акаунта
Изберете акаунта, с който искате да влезете.

Симптоми

Получавате едно от следните съобщения за грешки при автоматизация, когато се опитате да създадете нова интеграция с помощта на диспечера за интегриране заедно с Microsoft Dynamics GP или с Microsoft Business Solutions – чудесни равнини:

Съобщение за грешка 1

Елемент '-8' Not in Collection

Съобщение за грешка 2

Класът не поддържа автоматизация

Когато се опитате да отворите диспечера за интеграция, може също да получите следното съобщение за грешка:

Грешка при автоматизация: Операционната система не е налична

Когато инсталирате Диспечер за интегриране на работна станция на клиент, получавате следното съобщение за грешка:

Вътрешна грешка в TTGErrors: Грешка при автоматизация. Операционната система не може да изпълни %1.

Когато щракнете върху Подробни данни, получавате следния отчет за грешка:

Не можа да се създаде обект IMProvider.ODBCProvider.

Когато щракнете върху Помощ в лентата с менюта на диспечера за интеграция и след това щракнете върху Задиспечера заинтеграция , получавате следното съобщение за грешка:

Класът не поддържа автоматизация или не поддържа очакван номер на
интерфейса: 430 Стека

за повикване:

frmAbout.Form_Load

Тази грешка възниква, ако имате инсталиран Microsoft Office 2003.

Причина

Тази грешка се дължи на конфликт, който възниква, Business Contact Manager 2003 и диспечера за интеграция са на един и същ компютър. Business Contact Manager споделя едни и същи файлове и някои ключове от системния регистър катоIntegration Manager 9.0, 8.0 и 7.50. Компонентите на Integration Manager 7.0 са използвани за Business Contact Manager. Обаче възниква проблем, когато Business Contact Manager и Integration Manager 9.0, 8.0 или 7.50 са инсталирани на същия компютър. Проблемът е, че Windows COM двигателя на ниво операционна система търси в системния регистър, за да намери местоположението на COM сървър.

NoteBusiness Contact Manager е наличен само в Microsoft Office Small Business Edition 2003 и в Microsoft Office Professional Edition 2003.

Решение

За да разрешите този проблем, използвайте решение 1 или 2 в зависимост от това дали използвате Business Contact Manager. Ако не използвате Business Contact Manager, можете да премахнете компонента с помощта на разделителна способност 1. Ако използвате Business Contact Manager, трябва да използвате разделителна способност 2.

Разделителна способност 1: Премахване Business Contact Manager

Ако не използвате Business Contact Manager, можете да решите този проблем, като премахнете компонента. За да направите това, трябва да използвате Добавяне или премахване на програми. След като компонентът бъде премахнат, трябва да поправите диспечера за интегриране. За да изтриете BusinessContactManager и да поправите диспечера за интеграция, изпълнете следните стъпки:

  1. Щракнете върху Старт, посочете Програми, щракнете върху Контролен панел, щракнете двукратно върху Добавянеилипремахване на програми, щракнете върху Business Contact Managerи след това щракнете върху Премахни.

  2. В Добавяне илиОтстраняне напрограми изберете Диспечер заинтегриране, щракнетевърху Промяна/премахванеи след това щракнете върху Поправи.

  3. Ако продължите да получавате съобщението за грешка, повторете тази процедура, като щракнете върху Промяна в стъпка 2, а не върху Поправи. След това изберете, за да инсталирате alladapters.

Разделителна способност 2: Принуждаване на системния регистър да използва правилните COM файлове на двигателя

Ако използвате Business Contact Manager, можете да решите този проблем, като създадете IM.EXE. LOCAL файл, за да накарате системния регистър да използва правилните Windows com engine files for Integration Manager. За да направите това, изпълнете следните стъпки:

  1. Започнете Notepad и оставете подложката празна.

  2. Щракнете върху Файли след това щракнете върху Запиши като.

  3. Променете стойността на полето Запиши като тип на Всички файлове.

  4. В полето Име на файл въведете IM.EXE. ЛОКАЛНО. След това запишете файла в същата папка, в която е инсталиран диспечерът за интегриране (IM.exe) .

    Забележка Ако файлът има същото име като клиентското приложение и ако името на файла има . ЛОКАЛНО разширение COM ядрото проверява дали COM сървърът е в локалния указател, вместо да го зарежда от папката в системния регистър.

  5. Копирайте CBOMLib.dll файловете CBOMLibX.dll файлове в същата папка като IM.exe и IM.EXE. ЛОКАЛНИ файлове. Когато файлът IM.exe е отворен от тази папка, файлът на IM.exe използва локалните копия на файловете CBOMLib.dll и CBOMLibX.dll вместо файловете, които са идентифицирани в системния регистър.

    Забележка Тъй Business Contact Manager инсталиран след диспечера за интегриране, системният регистър сочи към Business Contact Manager копия на тези файлове. Тези копия са същите като тези за Integration Manager 7.0.

Повече информация

Тази статия е TechKnowledge Document ID:34103 Проблемът, описан в раздела Симптоми, не се отнася


за Microsoft Dynamics GP 10.0.

Нуждаете ли се от още помощ?

Искате ли още опции?

Разгледайте ползите от абонамента, прегледайте курсовете за обучение, научете как да защитите устройството си и още.

Общностите ви помагат да задавате и отговаряте на въпроси, да давате обратна връзка и да получавате информация от експерти с богати знания.

Беше ли полезна тази информация?

Доколко сте доволни от качеството на езика?
Какво е повлияло на вашия потребителски опит?
Като натиснете „Подаване“, вашата обратна връзка ще се използва за подобряване на продуктите и услугите на Microsoft. Вашият ИТ администратор ще може да събира тези данни. Декларация за поверителност.

Благодарим ви за обратната връзка!

×