Симптоми
Може да се сблъскате със следните симптоми, когато осъществявате достъп или да изтегляте от сайта за актуализиране на Windows чрез прокси сървър или защитна стена:
-
Получавате съобщение за грешка "не може да се покаже страницата" при опит за достъп до актуализации на продукти.
-
Получавате съобщение за грешка "изтеглянето и инсталирането е неуспешно", когато се опитвате да изтеглите компоненти. Изтеглянето може да не показва никакъв напредък, преди да спре да работи.
-
Сайтът спира да отговаря, след като "Моля, изчакайте..." Появява се прозорецът и Сайтът се опитва да инициализира продуктовия каталог.
Причина
Този проблем може да възникне, ако използвате една или повече от следните софтуерни програми:
-
WinProxy-отит софтуерИма по-малко конфликти с WinProxy 3,0, отколкото с по-ранните версии на WinProxy. Има дори по-малко конфликти с прозрачния прокси сървър вместо с класическия прокси сървър (важи само за версия 3,0). За допълнителна информация посетете следния уеб сайт на WinProxy:
-
Уингейт-Deerfield.com Повечето конфликти възникват при версии, по-стари от 3,0. за допълнителна информация посетете следния уеб сайт на Уингейт:
-
Internet Gate – MaccaSoftMaccaSoft разпространява софтуер за интернет портал чрез BMT Micro, Inc. и неизтриваем син, но поддръжката се предлага чрез MaccaSoft.
Този проблем може да възникне поради една или повече от следните причини:
-
Прокси сървърът кешира страницата за актуализиране на Windows и свързаните с тях файлове. Това поведение предотвратява правилната инсталация и инициализация на ActiveX контролата, която се използва от продуктовия каталог на Windows Update, за да се създаде на клиентските компютри.
-
Порт 80 или 443 се затваря. Windows Update изисква и HTTP, и HTTPS връзки.
-
Клиентските компютри не са конфигурирани да разрешават активните скриптове или изтеглянето и инициализирането на ActiveX контролите.
Решение
За да отстраните този проблем, изпълнете следните стъпки:
-
Изчистете кеша на прокси сървъра и го конфигурирайте, за да изключите сайта на Windows Update. Забележка Вижте документацията към софтуера или се обърнете към производителя на софтуера, ако искате помощ за конфигурацията на сървъра за прокси сървър или защитната стена.
-
Отворете порт 80.
-
Добавете Windows Update към зоната надеждни сайтове.
Трябва да зададете настройките за защита в Microsoft Internet Explorer до средни или по-малки за ActiveX файлове, за да прехвърлите правилно на компютъра си. Когато намалите настройките за защита, засягате само уеб сайтовете, които са посочени в зоната за надеждни сайтове на Internet Explorer. Вашите текущи настройки за защита за всички останали уеб сайтове остават, тъй като те са конфигурирани в момента. За да зададете настройките за защита в Internet Explorer, изпълнете следните стъпки:
-
В Internet Explorer щракнете върху инструменти, щракнете върху Опции за интернети след това щракнете върху защита.
-
Щракнете върху зона надеждни сайтовеи след това щракнете върху сайтове.
-
Изчистете отметката от квадратчето Изисквай проверка на сървъра (HTTPS:) квадратчето за отметка за всички сайтове в тази зона .
-
В полето Добавяне на този уеб сайт към зоната: текстово поле въведете http://*. Microsoft. comи след това щракнете върху Добави.
-
Щракнете върху ОК.
-
Щракнете върху ниво по избори след това щракнете върху Разреши за следните елементи:
-
Изтегляне на подписани ActiveX контроли.
-
Изтегляне на неподписани ActiveX контроли.
-
Тези ActiveX контроли не се маркират като безопасни.
-
Изпълнение на ActiveX контроли и добавки.
-
Скриптове ActiveX контроли, маркирани като безопасни за скриптове.
-
-
Щракнете върху OK два пъти, за да излезете от интернет свойствата.
За повече информация за конфигурирането на защитата в Internet Explorer щракнете върху следния номер на статия, за да видите статията в базата знания на Microsoft:
174360 Как да използвате зоните за защита в Internet Explorer