Преминаване към основното съдържание
Поддръжка
Влизане с Microsoft
Влезте или създайте акаунт.
Здравейте,
Изберете друг акаунт.
Имате няколко акаунта
Изберете акаунта, с който искате да влезете.

Симптоми

Да разгледаме следния сценарий:

  • Инсталирате Microsoft Exchange Server 2010 Service Pack 1 (SP1) или по-нова версия.

  • Разполагане на масив клиентски достъп сървър, който използва балансиране на натоварването.

  • Стартирате кратката команда New-MailboxExportRequest или MailboxImportRequest на нова команда.

В този случай заявката може да изтече и не завърши по очаквания начин. Освен това можете да получите следното съобщение за грешка:

Повикване до "net.tcp://SERVERNAME/Microsoft.Exchange.MailboxReplicationService SERVERNAME (14.1.218.11 caps: 07)" изтече. Съобщение за грешка: тази заявка за операция, изпратени net.tcp://SERVERNAME/Microsoft.Exchange.MailboxReplicationService не получи отговор в рамките на конфигурираното време на изчакване (00: 01:00). Времето отделено за тази операция е част от по-дълго време. Това може да е защото услугата все още обработва операция или услугата не можа да изпрати съобщението отговор. Моля, Увеличете операция изчакване (като Кастинг канал/прокси сървър, за да IContextChannel и свойството OperationTimeout) и гарантира, че услугата може да се свърже към клиента.
+ CategoryInfo: NotSpecified: (0:Int32) [нов MailboxExportRequest], TimeoutErrorTransientException
+ FullyQualifiedErrorId: 59EDFA88,Microsoft.Exchange.Management.RecipientTasks.NewMailboxExportRequest

Причина

Този проблем може да възникне, ако натоварване балансиране устройство не е конфигуриран правилно. Например този проблем може да възникне, ако балансатор на натоварването не позволява на Exchange Server, когато искането е създадена връзка към виртуална IP (ВИП) CAS масива.

Решение

За да разрешите този проблем, уверете се, че са налице следните условия:

  • Exchange Server може да се свърже с балансатор на клиент.

  • ВИП CAS масива може да се свърже с Exchange Server.


Заобикаляне на проблема

За да заобиколите този проблем, използвайте един от следните методи.

Метод 1

Конфигурирайте стойността RPCClientAccessServer в базата данни на пощенската кутия да сочи към конкретен сървър CAS.

Забележка: Тази настройка е четене динамично.

Метод 2

Създаване на запис във файла Hosts на CAS сървъра, разрешаваща CAS масив името на "localhost".

Допълнителна информация

При създаване на пощенска кутия за импортиране или експортиране заявка, процесът е както следва.

Забележка: Стъпките за импортиране или експортиране заявка вид искане за преместване.

  1. Заявката е създадена в Exchange Server, на който е свързан сесията на Windows PowerShell.

  2. Като част от проверката на искането Exchange Server се свързва с MAPI на крайна точка на средно ниво. След това с Exchange Server се опитва да влезете в пощенската кутия, която искате да импортирате или експортирате.

  3. Ако проверката премине успешно, папка свързани елементи (FAI) съобщение се създава и се добавя към опашка в пощенската кутия на системата на базата данни.

    Забележка: Проблемът, описан в раздела "Симптоми" обикновено се появява след тази стъпка. В този проблем заявката не се създава нормално и FAI съобщението не е създаден.

  4. Всички екземпляри на услугата за репликация поща (MRS) проверявайте пощенската кутия на системата. Ако г-жа сървър не е зададен в команда, г-жа сървър е произволно избрани.

  5. Г-жа завърши заявка за импортиране или експортиране и след това променя състоянието на заявката "Завършен".

  6. Администратор изчиства заявка за импортиране или експортиране.

    Забележка: Тази стъпка не е задължително

Препратки

За повече информация за импортиране и експортиране на заявки в Exchange Server 2010 посетете следния уеб сайт на TechNet:

http://technet.microsoft.com/en-us/library/ee633455.aspx
За повече информация относно заявките за преместване в Exchange Server 2010 посетете следния уеб сайт на TechNet:

http://technet.microsoft.com/en-us/library/dd298174.aspx

За повече информация как да конфигурирате стойност RPCClientAccessServer в база данни посетете следния уеб сайт на TechNet:

http://technet.microsoft.com/en-us/library/ee332317.aspx

Нуждаете ли се от още помощ?

Искате ли още опции?

Разгледайте ползите от абонамента, прегледайте курсовете за обучение, научете как да защитите устройството си и още.

Общностите ви помагат да задавате и отговаряте на въпроси, да давате обратна връзка и да получавате информация от експерти с богати знания.

Беше ли полезна тази информация?

Доколко сте доволни от качеството на езика?
Какво е повлияло на вашия потребителски опит?
Като натиснете „Подаване“, вашата обратна връзка ще се използва за подобряване на продуктите и услугите на Microsoft. Вашият ИТ администратор ще може да събира тези данни. Декларация за поверителност.

Благодарим ви за обратната връзка!

×