Проблем

Когато се опитвате да инсталирате пакета R на Linux получавате следното съобщение за грешка:

"Предупреждение: не може да получите достъп до индекс за хранилище - http://www.revolutionanalytics.com./repositories/cran/2.15/stable/s..."

Решение

Решение на този проблем е да редактирате файла:
/usr/lib64/Revo-6.2/R-2.15.3/lib64/R/etc/Rprofile.site

и промяна на линия: r < - c (REVO = Revobase::getRevoRepos())

в този блок:

Ако (. Platform$OS.Type == "windows") {
r["CRAN"] <- Revobase::getRevoRepos(CRANmirror=TRUE) 
} else {
r < - c (REVO = Revobase::getRevoRepos())
}

за:

r < - c (REVO = "http://packages.revolutionanalytics.com/cran/2.15/stable")

След това трябва да се рестартира Revolution R предприятие за промените да влязат в сила.

Нуждаете се от още помощ?

Разширете уменията си
Преглед на обучението
Получавайте първи новите функции
Присъединете се към Microsoft приобщени

Беше ли полезна тази информация?

Доколко сте доволни от качеството на езика?
Какво е повлияло на вашия потребителски опит?

Благодарим ви за обратната връзка!

×