Преминаване към основното съдържание
Поддръжка
Влизане с Microsoft
Влезте или създайте акаунт.
Здравейте,
Изберете друг акаунт.
Имате няколко акаунта
Изберете акаунта, с който искате да влезете.

Симптоми

При опит за актуализиране на ресурс в Microsoft Azure ни правителство облак, може да получите следните грешки, защото инсталации, които се стартират чрез издания на Team Foundation сървъри може да се провали.

Не може да се извлече маркер за Azure.

Грешка при получаване на Json уеб маркери (JWT) за основните ИД на услугата "ServicePrincipalID". Съобщение за изключение: AADSTS90038: поверителна клиент не се поддържа в различни облак заявка.

Причина

ЗСУ орган URL за Azure ни правителство е сменена от вход-us.microsoftonline.comlogin.microsoftonline.us. По време на инсталирането освобождаването се опитва да извлече маркер за достъп за удостоверяване на актуализацията. Вграден разполагане задачи за търсене стария URL за маркер за достъп и не.

Решение

За да решите този проблем, изпълнете следните стъпки:

  1. Изтеглете файла Azure разширение VSIX съответно:

  2. Изпълни команден прозорец с администраторски права с TFS администраторския акаунт, след което качите разширение на Team Foundation сървъри с помощта на командата съответно:

    • За TFS 2017

      "C:\Program Files\Microsoft Team Foundation Server 15.0\Tools\TfsConfig.exe" publishextension /vsixfilepath: "< Azure VSIX път >"

    • За TFS 2018

      "C:\Program Files\Microsoft Team Foundation Server 2018\Tools\TfsConfig.exe" publishextension /vsixfilepath: "< Azure VSIX път >"

ЗабележкаНе е необходимо да рестартирате всички Team Foundation server или компютъра след прилагането на разширението. 

Нуждаете ли се от още помощ?

Искате ли още опции?

Разгледайте ползите от абонамента, прегледайте курсовете за обучение, научете как да защитите устройството си и още.

Общностите ви помагат да задавате и отговаряте на въпроси, да давате обратна връзка и да получавате информация от експерти с богати знания.

Беше ли полезна тази информация?

Доколко сте доволни от качеството на езика?
Какво е повлияло на вашия потребителски опит?
Като натиснете „Подаване“, вашата обратна връзка ще се използва за подобряване на продуктите и услугите на Microsoft. Вашият ИТ администратор ще може да събира тези данни. Декларация за поверителност.

Благодарим ви за обратната връзка!

×