Преминаване към основното съдържание
Поддръжка
Влизане с Microsoft
Влезте или създайте акаунт.
Здравейте,
Изберете друг акаунт.
Имате няколко акаунта
Изберете акаунта, с който искате да влезете.

Симптоми

Когато завършите инсталирането на бизнес портал в Microsoft Dynamics GP или в MICROSOFT Dynamics SL и след това стартирате бизнес портала, получавате следното съобщение за грешка в различните уеб части, които се показват:

Грешка в сървъра в "/" приложение. Достъпът е отказан на "Microsoft Dynamics". Неуспешно стартиране на проследяването на промените във файловете. Описание: Възникна необработено изключение по време на изпълнението на текущата уеб заявка. Прегледайте проследяването на стека за повече информация за грешката и къде е възникнала в кода. Подробности за изключението: System.web.HttpException: Access е отказан на "Microsoft Dynamics". Неуспешно стартиране на проследяването на промените във файловете.

Причина

Microsoft ASP.NET изисква следните разрешения за акаунта за ASP.NET на процеса и за акаунта на мрежовата услуга. Тези разрешения са необходими в главната папка на уеб сайта и във всяка папка във виртуалния указател:

  • Четене

  • Изпълнение

  • Списък

ASP.NET тези разрешения за достъп до файловете и за наблюдение на промените във файловете.

Решение

За да разрешите този проблем, използвайте един от следните методи:

Метод 1

  1. Дайте необходимите разрешения на акаунта ASP.NET процеса. За да направите това, изпълнете следните стъпки:

    1. В Windows Explorer намерете папката за инсталиране на приложението. Или намерете папката за виртуалния указател. По-долу е местоположението по подразбиране на виртуалния указател на business Portal:

      C:\Програмни файлове\Microsoft Dynamics\Business Portal

    2. Щракнете с десния бутон върху папката и след това щракнете върху Свойства.

    3. В раздела Защита щракнете върху Добави.

    4. В полето Въведете имената на обектите, за да изберете, въведете следното и след това щракнете върху OK:

      Име накомпютър \ASPNET Забележка Заместете контейнера ComputerName с името на компютъра, на който се изпълнява бизнес портал.

    5. В областта Разрешения разрешете следните опции в списъка Позволи и след това щракнете върху OK:

      • Четене & изпълнение

      • Съдържание на папката "Списък"

      • Четене

    6. Щракнете върху Запиши, за да затворите прозореца, и след това рестартирайте интернет информационните услуги (IIS).

  2. Дайте необходимите разрешения за акаунта за мрежовата услуга. За да направите това, изпълнете следните стъпки:

    1. В Windows Explorer намерете папката на приложението за уеб сайта. Или намерете папката за виртуалния указател. По-долу е местоположението по подразбиране на виртуалния указател на business Portal:

      C:\Програмни файлове\Microsoft Dynamics\Business Portal

    2. Щракнете с десния бутон върху папката и след това щракнете върху Свойства.

    3. В раздела Защита щракнете върху Добави.

    4. В полето Въведете имената на обектите, за да изберете, въведете Мрежова услуга.

      Забележка Този потребителски акаунт е локален потребителски акаунт.

    5. В областта Разрешения разрешете следните опции в списъка Позволи и след това щракнете върху OK:

      • Четене & изпълнение

      • Съдържание на папката "Списък"

      • Четене

    6. Щракнете върху Запиши, за да затворите прозореца, и след това рестартирайте IIS.

Метод 2

Уверете се, че имената на папките в пътя на уеб сайта съдържат по-малко от девет знака.

Бележки

  • За да определите имената на папките в пътя, изпълнете следните стъпки:

    1. В IIS Manager щракнете с десния бутон върху уеб сайта, в който е инсталиран бизнес порталът, и след това щракнете върху Свойства.

    2. Щракнете върху раздела Начало указател и след това обърнете внимание на имената на папките на пътя в полето Локален път.

  • Ако преименувате папка, така че името на папката да съдържа по-малко от девет знака, трябва да направите същата промяна в IIS за уеб сайта. След като направите промяната, спрете и след това стартирайте IIS.

Повече информация

За повече информация щракнете върху следните номера на статии в базата знания на Microsoft:

317955 съобщение за грешка "Неуспешно стартиране на проследяването на промените в справочната директория", когато отидете на ASP.NET страница

316721 съобщение за грешка "Неуспешно стартиране на промените в указателя" при преглед на ASP.NET страница

Нуждаете ли се от още помощ?

Искате ли още опции?

Разгледайте ползите от абонамента, прегледайте курсовете за обучение, научете как да защитите устройството си и още.

Общностите ви помагат да задавате и отговаряте на въпроси, да давате обратна връзка и да получавате информация от експерти с богати знания.

Беше ли полезна тази информация?

Доколко сте доволни от качеството на езика?
Какво е повлияло на вашия потребителски опит?
Като натиснете „Подаване“, вашата обратна връзка ще се използва за подобряване на продуктите и услугите на Microsoft. Вашият ИТ администратор ще може да събира тези данни. Декларация за поверителност.

Благодарим ви за обратната връзка!

×