Преминаване към основното съдържание
Поддръжка
Влизане с Microsoft
Влезте или създайте акаунт.
Здравейте,
Изберете друг акаунт.
Имате няколко акаунта
Изберете акаунта, с който искате да влезете.

Симптоми

Когато се опитате да отворите страницата Настройка на управлението на поръчки в бизнес портала в Microsoft Dynamics GP 10.0 или в Microsoft Dynamics GP 9.0, получавате следното съобщение за грешка:

Грешка в сървъра в "/" Достъп до приложението до

пътя "c:\inetpub\wwwroot\bin\~privatefile.dbauthentication.config" е отказана. Подробности за изключението:
ASP.NET не е упълномощен за достъп до искания ресурс. Обмислете предоставянето на права за достъп до ресурса на ASP.NET на заявката. ASP.NET има самоличност на базов процес, която се използва, ако приложението не се представя. Ако приложението се представя чрез <самоличност imprersonate="true"/>, самоличността ще бъде анонимният потребител или удостоверен потребител на заявката.

Причина

Този проблем възниква, защото GPReg.dll файл липсва или не е регистриран.

Решение

За да разрешите този проблем, изпълнете следните стъпки:

  1. Уверете се, GPReg.dll файлът е в папката на главния указател на уеб сайта, който сте използвали за инсталиране на бизнес портал.

    Забележка По подразбиране папката на кошчето е в следното местоположение:

    C:\Inetpub\wwwroot\bin

  2. Ръчно регистрирайте GPReg.dll файл. За да направите това, използвайте един от следните методи:

    • Използвайте командния прозорец:

      1. Щракнете върху Старт, щракнете върхуИзпълнение , въведете cmd в полето Отвори и след това щракнете върху OK.

      2. Променете на указателя, който съдържа GPReg.dll файл.


        Забележка За да промените местоположението по подразбиране, въведете cd inetpub\wwwroot\bin в командния прозорец и след това натиснете КЛАВИША ENTER.

      3. В командния прозорец въведете Regsvr32 GPReg.dll и след това натиснете КЛАВИША ENTER.

    • Използване на Microsoft Windows Explorer:

      1. Щракнете с десния бутон върху Старти след това щракнете върху Преглед.

      2. Намерете и след това щракнете с десния бутон върхуGPReg.dll файл, посочете Отвори си след това щракнете върху Избор на програма.

      3. В диалоговия прозорец Отвори с щракнете върху Преглед.

      4. В списъка Търси в щракнете върху папката C:\Windows\System32, щракнете върхуRegsvr32.exe файл и след това щракнете върху Отвори.

Повече информация

Стъпки за възпроизвеждане на проблема

  1. В бизнес портал щракнете върху Сайт Настройки, щракнете върху Приложение Настройкии след това щракнете върху Настройка на управлението на поръчките.

  2. Ако получите подкана за потребителско име и парола, въведете потребителското име и паролата.

  3. Щракнете върху ОК.

Нуждаете ли се от още помощ?

Искате ли още опции?

Разгледайте ползите от абонамента, прегледайте курсовете за обучение, научете как да защитите устройството си и още.

Общностите ви помагат да задавате и отговаряте на въпроси, да давате обратна връзка и да получавате информация от експерти с богати знания.

Беше ли полезна тази информация?

Доколко сте доволни от качеството на езика?
Какво е повлияло на вашия потребителски опит?
Като натиснете „Подаване“, вашата обратна връзка ще се използва за подобряване на продуктите и услугите на Microsoft. Вашият ИТ администратор ще може да събира тези данни. Декларация за поверителност.

Благодарим ви за обратната връзка!

×