Симптоми
Помислете за следния сценарий:
-
Инсталирате пълната версия на Microsoft SQL Server 2005 на компютъра.
-
Можете да Microsoft SQL Server Express 2005, когато инсталирате Microsoft Office Accounting Professional или Microsoft Office Accounting Express.
-
След като инсталирате Microsoft SQL Server Express 2005, премахвате пълната версия на Microsoft SQL Server 2005.
В този случай получавате следното съобщение за грешка, когато стартирате Accounting Professional или Accounting Express:
Microsoft Office Счетоводството се натъкна на проблем и трябва да се затвори. Съжаляваме за неудобството. За да видите какви данни съдържа този отчет за грешка, щракнете тук.
Също така получавате това съобщение за грешка, когато отпечатвате отчет в Accounting Professional или в Accounting Express.
След като щракнете, за да видите данните от отчета, получавате съобщение за грешка, подобно на следното съобщение:
Класът не е регистриран (Изключение от HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))
Когато получите второто съобщение за грешка, Accounting Professional или Accounting Express престава да отговаря.
Причина
Този проблем възниква, тъй като ключовите компоненти, които се използват от Accounting Professional или Accounting Express, се премахват, когато премахнете пълната версия на Microsoft SQL Server 2005. Някои ключови компоненти, които са премахнати, са Microsoft Office 2003 уеб компоненти.
Решение
За да разрешите този проблем, преинсталирайте уеб компонентите Microsoft Office 2003. За да направите това, изпълнете следните стъпки:
-
Щракнете върху Старт, щракнете върху Контролен панели след това щракнете върху Добавяне или премахване на програми.
Забележка Ако използвате операционна система Windows Vista, щракнете върху Контролен панели след това щракнете върху Програми и компоненти. -
Щракнете Microsoft Office 2003 уеб компоненти ислед това щракнете върху Премахни.
Забележка Ако Microsoft Office 2003 уеб компоненти не се показват в списъка, преминете към стъпка 3. -
Получете и инсталирайте уеб компонентите Microsoft Office 2003. За повече информация как да направите това, посетете следния уеб сайт на Microsoft:
-
Стартирайте "Счетоводен професионалист" или "Счетоводен експрес".
Ако проблемът продължава, премахнете "Счетоводен професионалист" или "Счетоводен експрес". След това преинсталирайте Accounting Professional или Accounting Express.
Състояние
Microsoft потвърди, че това е проблем в продуктите на Microsoft, които са изброени в раздела "Отнася се за".