Симптоми
Active Directory контакт не се показва, но телефонния номер се показва в Microsoft на Skype за бизнес 2015 (Lync 2013). Този проблем възниква, когато са налице следните условия:
-
Контакт в Active Directory съдържа телефонен номер, имейл адрес и пълно име.
-
Имате задайте EnableExchangeContactSync параметър False или изчиства Синхронизиране на контакти между Skype за фирми и Exchange опция в раздела лични Опции.
Причина
Това е причинено от пропуснати сценарий за извличане на контакт показвано име.
Решение
За да решите този проблем, инсталирайте на 7 ноември 2017, актуализирайте (KB4011255) за Skype за бизнес 2015 (Lync 2013) и използвайте един от следните настройки за да разрешите актуализацията.
Забележка Lync 2013 надграждането на Skype за бизнес през април 2015 г.
В групата настройка за осигуряване
Изпълнете следната команда f rom Lync PowerShell команден ред:
$a = New-CsClientPolicyEntry -Name EnableContactResolutionWithTelUriAndEmailOnly -Value "true"
Set-CsClientPolicy -IdentityGlobal -PolicyEntry @{Add=$a}
Настройка на GPO
-
В правилата за управление на група cСъздайте обект с групови правила.
Забележка Когато създавате GPO, Задайте име и Оставете източник като няма. -
В раздела Настройки rнощта върху Компютърна конфигурация или Конфигурация на потребители след това изберете Редактиране.
-
Щракнете с десния бутон на системния регистър, изберете новои след това изберете Елемента на системния регистър.
-
В диалоговия прозорец Нови свойства на системния регистър Задайте следната информация и изберете OK:
Действие: създаване
Кошер: HKEY_CURRENT_USER
Ключ път: Software\Policies\Microsoft\Office\15.0\Lync
Име на стойност: EnableContactResolutionWithTelUriAndEmailOnly
Тип на стойността: REG_DWORD
Стойността на данните: 1
База: десетичен