Преминаване към основното съдържание
Поддръжка
Влизане с Microsoft
Влезте или създайте акаунт.
Здравейте,
Изберете друг акаунт.
Имате няколко акаунта
Изберете акаунта, с който искате да влезете.

Симптоми

Приемете, че архивирате опашката от регистрационния файл на базата данни, която използва опцията Norecovery в Microsoft SQL Server 2014 или SQL Server 2012 и базата данни е въведена за възстановяване на състоянието. Когато архивирането приключи, не можете да рестартирате услугата SQL Server и получавате следното съобщение за грешка в регистрационния файл за грешки на SQL Server:

<дата> <време> spid10s на базата данни "модел" е маркирано като възстановяване и е в състояние, което не позволява възстановяване да се изпълни. <Дата> <час> spid10s грешка: 927, тежест: 14, състояние: 2. <Дата> <време> spid10s база данни "модел" не може да се отвори. Той е в средата на възстановяване. <дата> <час> spid10s не можа да създаде tempdb. Възможно е да нямате достатъчно свободно дисково пространство. Освободете допълнително дисково пространство, като изтриете други файлове на tempdb диск и след това рестартирайте SQL Server. Проверете за допълнителни грешки в регистъра на събитията, които може да указват защо файловете на tempdb не могат да се инициализират. <дата> <време> spid10s SQL Трейс е спряно поради изключване на сървъра. Трейс ИД = "1". Това е само информативно съобщение; не се изисква действие от потребителя.

Причина

Този проблем възниква, защото базата данни модел се използва като шаблон за всички бази данни, които са създадени в ЕКЗЕМПЛЯР на SQL Server. Ако базата данни за модела е маркирана като непозволяваща състоянието на възстановяване, tempdb не може да се създаде и услугата SQL Server не може да се стартира.

Решение

Информация за сервизния пакет

За да отстраните този проблем, Получете Service Pack 1 за SQL Server 2014.

За повече информация относно SQL Server 2014 Service Pack 1 (SP1) вижте грешки, които са коригирани в SQL Server 2014 Service Pack 1.

Заобиколно решение

За да заобиколите този проблем, използвайте следния метод:

  • Забраняване на всички връзки от приложението към SQL Server

  • Стартиране на услугата SQL Server заедно с флаг за проследяване 3608

  • Командата "възстановяване на модел на база данни"

  • Премествам следа флаг 3608 и рестартирайте SQL Server

Състоянието

Microsoft потвърди, че това е проблем в продуктите на Microsoft, които са посочени в секцията "важи за".

Нуждаете ли се от още помощ?

Искате ли още опции?

Разгледайте ползите от абонамента, прегледайте курсовете за обучение, научете как да защитите устройството си и още.

Общностите ви помагат да задавате и отговаряте на въпроси, да давате обратна връзка и да получавате информация от експерти с богати знания.

Беше ли полезна тази информация?

Доколко сте доволни от качеството на езика?
Какво е повлияло на вашия потребителски опит?
Като натиснете „Подаване“, вашата обратна връзка ще се използва за подобряване на продуктите и услугите на Microsoft. Вашият ИТ администратор ще може да събира тези данни. Декларация за поверителност.

Благодарим ви за обратната връзка!

×