Преминаване към основното съдържание
Поддръжка
Влизане с Microsoft
Влезте или създайте акаунт.
Здравейте,
Изберете друг акаунт.
Имате няколко акаунта
Изберете акаунта, с който искате да влезете.

Симптоми

Да предположим, че имате изображение на контейнер за SQL Server 2017 на докинг станция за Windows. Когато за осигуряването на контейнери се използват изображения за закачване и можете да използвате местоположението за монтиране на обем (местоположение по подразбиране на/var/opt/MSSQL) или някой от родителските директории, SQL Server няма да се стартира. Освен това,получавате съобщение за грешка , подобно на следното:

грешка дата час spid6s: 17053, тежест: 16; щат: 1. дата час spid6s/var/opt/MSSQL/Data/mastlog.ldf: операционна система грешка 31 (устройство, прикачено към системата не функционира.) е възникнало. date time грешка "дата и час spid6s: 9002, тежест: 17; щат: 0. дата час spid6s на регистрационния файл за транзакция за базата данни "Master" е пълен, защото "нищо". грешка дата час spid6s: 928, тежест: 20; щат: 1.

Причина

Този проблем възниква, тъй като директорията от Windows е монтирана като често срещана система за интернет файлове (CIFS) в контейнера на докинг станцията. CIFS не се поддържа официално като файлова система от SQL Server в Linux.

Решение

Корекцията за този проблем е включена в следната актуализация за SQL Server:

Сборна актуализация 7 за SQL Server 2017

За компилациите на SQL Server

Всяка нова компилация за SQL Server съдържа всички поправки и корекции на защитата, които са били в предишната компилация. Препоръчваме ви да инсталирате най-новата компилация за вашата версия на SQL Server:

Най-новата компилация за SQL Server 2017

Състоянието

Microsoft потвърди, че това е проблем в продуктите на Microsoft, които са посочени в секцията "важи за".

Препратки

Запознайте се с стандартната терминология , която Microsoft използва, за да опише софтуерни актуализации.

Продуктите на други производители, които се обсъждат в тази статия, са произведени от фирми, независими от Microsoft. Microsoft не дава никакви гаранции – подразбиращи се,или други – за работата или надеждността на тези продукти.

Нуждаете ли се от още помощ?

Искате ли още опции?

Разгледайте ползите от абонамента, прегледайте курсовете за обучение, научете как да защитите устройството си и още.

Общностите ви помагат да задавате и отговаряте на въпроси, да давате обратна връзка и да получавате информация от експерти с богати знания.

Беше ли полезна тази информация?

Доколко сте доволни от качеството на езика?
Какво е повлияло на вашия потребителски опит?
Като натиснете „Подаване“, вашата обратна връзка ще се използва за подобряване на продуктите и услугите на Microsoft. Вашият ИТ администратор ще може да събира тези данни. Декларация за поверителност.

Благодарим ви за обратната връзка!

×