Преминаване към основното съдържание
Поддръжка
Влизане с Microsoft
Влезте или създайте акаунт.
Здравейте,
Изберете друг акаунт.
Имате няколко акаунта
Изберете акаунта, с който искате да влезете.

Симптоми

Помислете за този сценарий:

  • Можете да инсталирате принтер с помощта на вграден драйвер за принтер на компютър, на който се изпълнява Windows 7 или Windows Server 2008 R2.

  • Можете да инсталирате нов или актуализиран драйвер за принтер, който съдържа актуализация за Unidrv.dll файла.

  • Опитвате се да промените свойствата на опашката за печат, която използва драйвера за принтер в Box.

В този случай Windows Explorer се срива и получавате следното съобщение за грешка:

Windows Explorer е спрял

да работи Windows може да провери онлайн за решение на проблема и да се опита да рестартира програмата.


Забележка този проблем може да възникне при някои ситуации, при които Unidrv.dll за процеса се актуализира. Например инсталиране на сервизен пакет на Windows, пакет за актуализиране или драйвер за принтер на друг разработчик.

Причина

Този проблем възниква, тъй като по-новите версии на Unidrv.dll активират актуализация на съществуващите опашки за печат. Този процес за актуализиране инициира надстройка на драйвер, който добавя стойност на системния регистър към опашката за печат, която използва драйвера за вътре.

Решение

Важно
следвайте стъпките в този раздел внимателно. При неправилна промяна на регистъра е възможно да възникнат сериозни проблеми. Преди да я промените, архивирайте системния регистър за възстановяване , в случай че възникнат проблеми.

За да отстраним този проблем вместо вас, отидете на раздела "Решете ми". Ако предпочитате сами да решите този проблем, отидете на секцията "Нека реша проблема сам".


Поправи моя проблем

За да коригирате този проблем, щракнете върху бутона " Fix It " или връзката. След това щракнете върху изпълнение в диалоговия прозорец изтегляне на файл и следвайте стъпките в съветника за коригиране на проблема.



  • Възможно е този съветник да е само на английски език. Автоматичната корекция обаче работи и за други езикови версии на Windows.

  • Ако не сте на компютъра, който има този проблем, можете да го запишете на флаш устройство или КОМПАКТДИСК и след това да го изпълните на компютъра, който има проблема.

  • Бихме оценили вашата обратна връзка. За да дадете обратна връзка или да съобщите за проблеми с това решение, оставете коментар на блога "Решете моя проблем" или ни изпратете имейл съобщение.



За да отстраните този проблем, изтрийте записа в системния регистър, добавен от надстройката на драйвера. За да направите това, изпълнете следните стъпки:

  1. Отворете устройства и принтери и след това определете името на принтера на опашката за печат на проблема.

    В този пример определяме, че "HP Laser Jet 4100 Series PCL6" е принтерът за проблеми.

    алтернативен текст

  2. Отворете редактора на системния регистър. За да направите това, щракнете върху Старт, въведете regedit.exe в полето за търсене и след това натиснете клавиша ENTER.

  3. Намерете и след това разгънете следния ключ от системния регистър:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers

  4. Разгънете подключа на системния регистър, който има същото име като проблемния принтер, който е посочен в стъпка 1, и след това щракнете върху PrinterDriverData.

    алтернативен текст

  5. Архивиране на подключа на PrinterDriverData в системния регистър. За да направите това, изпълнете следните стъпки:

    • Щракнете с десния бутон върху PrinterDriverDataи след това щракнете върху експортиране.

    • В полето име на файл въведете името, което искате да използвате за експортирания ключ от системния регистър.

    • Щракнете върху Запиши , за да експортирате и запишете избрания ключ от системния регистър.

  6. Щракнете с десния бутон върху стойността от системния регистър на DMCExist в десния екран и след това щракнете върху Изтрий. Щракнете върху да , когато бъдете подканени да потвърдите изтриването.

    Забележка Ако има един и същ проблем с повече от една опашка за печат, повторете същите процедури за тези принтери.

  7. Затворете редактора на системния регистър.

  8. Спрете и след това рестартирайте услугата за Спулер за печат. За да направите това, използвайте един от методите по-долу.

    Метод 1: Използвайте конзолата за услуги:

    1. Щракнете върху Старт, въведете Services. msc в полето за търсене и след това натиснете клавиша ENTER.

    2. Отворете Спулер за печат, щракнете върху Сприи след това щракнете върху Старт.

    Метод 2: използвайте команден ред:

    1. Отворете команден прозорец с администраторски права.

    2. Изпълнете следната команда, за да спрете услугата за Спулер за печат:

      мрежов стоп

    3. Изпълнете следната команда, за да стартирате услугата за Спулер за печат:

      net start Спулер

  9. Тест, за да потвърдите, че проблемът е разрешен.


Продуктите на други производители, които се обсъждат в тази статия, са произведени от фирми, независими от Microsoft. Microsoft не дава никакви гаранции – подразбиращи се,или други – за работата или надеждността на тези продукти.

Нуждаете ли се от още помощ?

Искате ли още опции?

Разгледайте ползите от абонамента, прегледайте курсовете за обучение, научете как да защитите устройството си и още.

Общностите ви помагат да задавате и отговаряте на въпроси, да давате обратна връзка и да получавате информация от експерти с богати знания.

Беше ли полезна тази информация?

Доколко сте доволни от качеството на езика?
Какво е повлияло на вашия потребителски опит?
Като натиснете „Подаване“, вашата обратна връзка ще се използва за подобряване на продуктите и услугите на Microsoft. Вашият ИТ администратор ще може да събира тези данни. Декларация за поверителност.

Благодарим ви за обратната връзка!

×