Brug af HVIS til at kontrollere, om en celle er tom

Nogle gange skal du kontrollere, om en celle er tom, fordi du måske ikke ønsker, at en formel viser et resultat uden input.

Formlen i celle E2 er =HVIS(D2=1,"Ja",IF(D2=2,"Nej","Måske"))

I dette tilfælde bruger vi HVIS med funktionen ER.TOM:

  • = HVIS(ER.TOM(D2),"Tom","Ikke tom")

Det betyder, at HVIS(D2 er tom, returneres "Tom", ellers returneres "Ikke tom"). Du kan også nemt bruge din egen formel for betingelsen "Ikke tom". I det næste eksempel bruger vi "" i stedet for ER.TOM. Anførselstegnene "" betyder "intet".

Kontrollér, om en celle er tom – formlen i celle E2 er =HVIS(ER.TOM(D2),"Tom","ikke tom")

= HVIS(D3="","Tom","Ikke tom")

Denne formel siger, at HVIS(D3 er intet, så returneres "Tom", ellers returneres "Ikke tom"). Her er et eksempel på en meget almindelig metode med brug af "" til at forhindre, at en formel beregnes, hvis en relateret celle er tom:

  • =HVIS(D3="","",Din formel())

    HVIS (D3 er intet, så returneres intet, ellers beregnes formlen).

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×