SUM.HVIS, funktionen

Du kan bruge funktionen SUM.HVIS til at summere værdierne i et område, der opfylder kriterier, du angiver. Antag f.eks, at du kun vil summere de værdier, der er større end 5, i en kolonne, der indeholder tal. Du kan bruge følgende formel: =SUM.HVIS(B2:B25,">5")

Skab stor effekt med Meddelelser

Denne video er en del af et kursus med titlen Lægge tal sammen i Excel.

Tip!: 

  • Hvis du vil, kan du anvende kriteriet på ét område og summere de tilhørende værdier i et andet område. F.eks. summerer formlen =SUM.HVIS(B2:B5, "John", C2:C5) kun værdierne i området C2:C5, hvor de tilsvarende celler i området B2:B5 er lig med "John".

  • Hvis du vil sammentælle celler på basis af flere kriterier, skal du se Funktionen SUM.HVISER.

Vigtigt!: Funktionen SUM returnerer forkerte resultater, når du bruger den til at matche strenge på mere end 255 tegn eller til strengen #VALUE!.

Syntaks

SUM.HVIS(område, kriterium, [sumområde])

Syntaksen for funktionen SUM.HVIS har følgende argumenter:

  • område   Påkrævet. Det område af celler, der skal evalueres af kriterier. Cellerne i hvert område skal være tal eller navne, matrixer eller referencer, der indeholder tal. Tomme værdier og tekstværdier ignoreres. Det valgte område kan indeholde datoer i Excels standardformat (eksempler nedenfor).

  • kriterie   Påkrævet. Kriteriet i form af et tal, et udtryk, en cellereference, tekst eller funktion, der definerer, hvilke celler der vil blive adderet. Jokertegn kan medtages – et spørgsmålstegn (?), så det svarer til et enkelt tegn, en stjerne (*), der svarer til en vilkårlig tegnsekvens. Hvis du ønsker at søge efter et reelt spørgsmålstegn eller en stjerne, skal du skrive en tilde (~) foran tegnet.

    For eksempel kan kriterier udtrykkes som 32, ">32", B5, "3?", "Apple *", "* ~?" eller i dag ().

    Vigtigt!: Alle tekstkriterier eller alle kriterier, som indeholder logiske eller matematiske symboler, skal være omsluttet af dobbelte anførselstegn ("). Hvis kriterierne er numeriske, er dobbelte anførselstegn ikke påkrævet.

  • sumområde   Valgfrit. De faktiske celler, der skal tilføjes, hvis du vil tilføje andre celler end dem, der er angivet i argumentet område . Hvis argumentet sumområde er udeladt, tilføjer Excel de celler, der er angivet i argumentet område (de samme celler, som kriteriet er anvendt på).

    Sum_range skal have samme størrelse og form som område. Hvis den ikke er, kan ydeevnen bevares, og formlen vil sammentælle et celleområde, der starter med den første celle i sum_range men har de samme mål som område. Eksempel:

    område

    sumområde

    Faktiske summerede celler

    A1:A5

    B1:B5

    B1:B5

    A1:A5

    B1: K5

    B1:B5

Eksempler

Eksempel 1

Kopiér eksempeldataene i følgende tabel, og sæt dem ind i celle A1 i et nyt Excel-regneark. For at få formlerne til at vise resultater skal du markere dem, trykke på F2 og derefter trykke på Enter. Hvis der er brug for det, kan du justere bredden på kolonnerne, så du kan se alle dataene.

Egenskabsværdi

Provision

Data

DKK 100.000

DKK 7.000

DKK 250.000

DKK 200.000

DKK 14.000

DKK 300.000

DKK 21.000

DKK 400.000

DKK 28.000

Formel

Beskrivelse

Resultat

=SUM.HVIS(A2:A5;">160000";B2:B5)

Summen af provisioner for egenskabsværdier over DKK 160.000.

DKK 63.000

=SUM.HVIS(A2:A5;">160000")

Summen af egenskabsværdier over DKK 160.000.

DKK 900.000

=SUM.HVIS(A2:A5,300000,B2:B5)

Summen af provisioner for egenskabsværdier lig med DKK 300.000.

DKK 21.000

=SUM.HVIS(A2:A5;">" & C2,B2:B5)

Summen af provisioner for egenskabsværdier større end værdien i C2.

DKK 49.000

Eksempel 2

Kopiér eksempeldataene i følgende tabel, og sæt dem ind i celle A1 i et nyt Excel-regneark. For at få formlerne til at vise resultater skal du markere dem, trykke på F2 og derefter trykke på Enter. Hvis der er brug for det, kan du justere bredden på kolonnerne, så du kan se alle dataene.

Kategori

Fødevarer

Salg

Grøntsager

Tomater

DKK 2.300

Grøntsager

Selleri

DKK 5.500

Frugt

Appelsiner

DKK 800

Smør

DKK 400

Grøntsager

Gulerødder

DKK 4.200

Frugt

æbler

DKK 1.200

Formel

Beskrivelse

Resultat

=SUM.HVIS(A2:A7,"Frugt",C2:C7)

Summen af salget af alle fødevarer i kategorien "Frugt".

DKK 2.000

=SUM.HVIS(A2:A7,"Grøntsager",C2:C7)

Summen af salget af alle fødevarer i kategorien "Grøntsager".

DKK 12.000

=SUM.HVIS(B2:B7,"*er",C2:C7)

Summen af salget af alle fødevarer, der slutter med "er" (tomater, appelsiner og æbler).

DKK 4.300

=SUM.HVIS(A2:A7,"",C2:C7)

Summen af salget af alle fødevarer, der ikke har en kategori angivet.

DKK 400

Toppen af siden

Har du brug for mere hjælp?

Du kan altid spørge en ekspert i Excel Tech Community, få support i Answers community eller foreslå en ny funktion eller forbedring i Excel User Voice.

Se også

Funktionen SUM.HVISER tilføjer alle argumenter, der lever op flere kriterier

Funktionen SUMKV opsummerer flere værdier efter at have udført en matematisk kvadratisk operation på hver af dem

Funktionen TÆL.HVIS tæller kun de værdier, der lever op til et enkelt kriterium

Funktionen TÆL.HVISER tæller kun de værdier, der lever op til flere kriterier

HVISER-funktionen (Office 365, Excel 2016 og nyere)

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Find fejl i formler

Matematiske og trigonometriske funktioner

Excel-funktioner (alfabetisk)

Excel-funktioner (efter kategori)

Bemærk!:  Denne side er oversat ved hjælp af automatisering og kan indeholde grammatiske fejl og unøjagtigheder. Det er vores hensigt, at dette indhold skal være nyttigt for dig. Var disse oplysninger nyttige? Her er artiklen på engelsk, så du kan sammenligne.

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×