Symptomer
Overvej følgende scenarie:
-
Du kører Microsoft System Center Configuration Manager version 1511.
-
Du opretter et stort antal pakker (f.eks. flere hundrede) og distribuerer dem til mange pull-distributionspunkter (f.eks. tusindvis af dem).
Når DistMgr behandler .pul-filer fra pull-distributionspunkter (DP'er) i dette scenarie, kører DistMgr følgende forespørgsel, som tager 3-4 sekunder at køre, når der er mange rækker i tabellen PkgStatus:
select s.ID, s.PkgServer, s.SiteCode, p.StoredPkgVersion, s.Status, r.PkgVersion, r.ActionState, r.ActionData, p.PkgFlags, p.ShareType
from PullDPResponse r join PkgStatus s on r.PkgStatusID = s.PKID AND r.PkgStatusID = PUL_ID join SMSPackages p on s.ID = p.PkgID
Årsag
Dette problem opstår, fordi PkgStatus-visningen bruger en ISNULL-sætning, og det medfører, at SQL udfører en indeksscanning i stedet for en indekssøgning.
Løsning
Når du har anvendt dette hotfix, og DistMgr behandler .pul-filer fra pull-DP'erne, kører DistMgr følgende forespørgsel, som tager ca. 28 millisekunder at køre:
select s.ID, s.PkgServer, s.SiteCode, p.StoredPkgVersion, s.Status, r.PkgVersion, r.ActionState, r.ActionData, p.PkgFlags, p.ShareType
from PkgStatus2 s join PullDPResponse r on r.PkgStatusID = s.PKID AND s.PKID = 72057594038363660 join SMSPackages p on s.ID = p.PkgID
Oplysninger om hotfix
Et understøttet hotfix er tilgængeligt fra Microsoft Support. Dette hotfix er dog kun beregnet til at rette det problem, der er beskrevet i denne artikel. Anvend kun dette hotfix på systemer, der oplever det problem, der er beskrevet i denne artikel. Dette hotfix kan blive testet yderligere. Hvis du ikke er alvorligt berørt af dette problem, anbefaler vi derfor, at du venter på den næste softwareopdatering, der indeholder dette hotfix.
Hvis hotfixet kan downloades, er afsnittet "Hotfixdownload tilgængeligt" øverst i denne Knowledge Base-artikel. Hvis dette afsnit ikke vises, skal du kontakte Microsofts kundeservice og support for at få hotfixet. Bemærk! Hvis der opstår yderligere problemer, eller hvis der kræves fejlfinding, kan det være nødvendigt at oprette en separat serviceanmodning. De sædvanlige supportomkostninger gælder for yderligere supportspørgsmål og -problemer, der ikke er berettiget til dette specifikke hotfix. Du kan finde en komplet liste over telefonnumre til Microsofts kundeservice og support eller oprette en separat serviceanmodning på følgende Microsoft-websted:http://support.microsoft.com/contactus/?ws=supportBemærk! Formularen "Tilgængelig hotfixdownload" viser de sprog, som hotfixet er tilgængeligt for. Hvis du ikke kan se dit sprog, skyldes det, at et hotfix ikke er tilgængeligt for det pågældende sprog.
Forudsætninger
Hvis du vil anvende dette hotfix, skal du have System Center Configuration Manager version 1511 installeret.
Oplysninger om genstart
Du behøver ikke at genstarte computeren, når du har installeret dette hotfix.
Oplysninger om hotfixerstatning
Dette hotfix erstatter ikke tidligere udsendte hotfix.
Den engelske version af dette hotfix har de filattributter (eller nyere filattributter), der er angivet i følgende tabel. Datoerne og klokkeslættene for disse filer er angivet i Coordinated Universal Time (UTC). Når du får vist filoplysningerne, konverteres de til lokal tid. Du kan finde forskellen mellem UTC og lokal tid ved at bruge fanen Tidszone i elementet Dato og klokkeslæt i Kontrolpanel.
Filnavn |
Filversion |
Filstørrelse |
Dato |
Tid |
Platform |
---|---|---|---|---|---|
Update.sql |
Ikke relevant |
2,046 |
24. november 2015 |
01:00 |
Ikke relevant |
Status
Microsoft har bekræftet, at problemet findes i de Microsoft-produkter, der er angivet i afsnittet "Gælder for".
Referencer
Få mere at vide om den terminologi , som Microsoft bruger til at beskrive softwareopdateringer.