Dieser Artikel gilt für Windows 2000. Der Support für Windows 2000 endet am 13. Juli 2010. Das Windows 2000 End-of-Support Solution Center ist ein Ausgangspunkt für die Planung Ihrer Migrationsstrategie von Windows 2000. Weitere Informationen finden Sie unter Microsoft-Support Lifecycle-Richtlinie.
Symptome
Wenn Sie den Computer neu starten, nachdem ein Programm, das die Funktion InitiateSystemShutdownEx verwendet, diesen automatisch heruntergefahren hat, wird möglicherweise das folgende Ereignis im Systemereignisprotokoll protokolliert:
Hinweis
Ereignis-ID: 6008
Quelle: Ereignisprotokoll
Typ: Fehler
Beschreibung:
Das vorherige System wird zur Zeit heruntergefahren.
Das Datum war unerwartet.
Ursache
Dieses Problem kann auftreten, wenn die beiden folgenden Bedingungen zutreffen:
Der Computer ist gesperrt oder mit einem kennwortgeschützten Bildschirmschoner konfiguriert.
Der Vorgang zum Herunterfahren wird automatisch von einem Programm initiiert, das die Funktion InitiateSystemShutdownEx mit dem Force-Flag verwendet.
Beispielsweise verwenden Sie das Tool remote shutdown (Shutdown.exe) aus dem Microsoft Windows 2000 Resource Kit, um ein Herunterfahren des Computers von einem Remotecomputer zu erzwingen, oder Sie planen das Herunterfahren des lokalen Computers mithilfe von Shutdown.exe in Kombination mit dem at-Befehl oder dem Taskplaner.
In diesem Fall wird der Ereignisprotokolldienst nicht über das Herunterfahren benachrichtigt, und daher wird der Vorgang zum Herunterfahren vom Ereignisprotokolldienst fälschlicherweise als unerwartetes Ereignis betrachtet.
Lösung
Hotfixinformationen
Ein unterstütztes Feature, das das Standardverhalten des Produkts ändert, ist von Microsoft verfügbar. Dieses Feature soll jedoch nur das Verhalten ändern, das in diesem Artikel beschrieben wird. Wenden Sie dieses Feature nur auf Systeme an, die es speziell benötigen.
Wenn das Feature zum Download verfügbar ist, finden Sie oben in diesem Knowledge Base-Artikel den Abschnitt "Hotfixdownload verfügbar". Wenn dieser Abschnitt nicht angezeigt wird, wenden Sie sich an den Microsoft-Kundendienst und -Support, um das Feature zu erhalten.
Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die üblichen Supportkosten gelten für zusätzliche Supportfragen und -probleme, die nicht für dieses spezifische Feature geeignet sind. Eine vollständige Liste der Telefonnummern für Den Microsoft-Kundendienst und -Support oder zum Erstellen einer separaten Serviceanfrage finden Sie auf der folgenden Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support Hinweis Im Formular "Hotfixdownload verfügbar" werden die Sprachen angezeigt, für die das Feature verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, liegt dies daran, dass das Feature für diese Sprache nicht verfügbar ist. Die englische Version dieses Hotfixes enthält die Dateiattribute (oder höhere Dateiattribute), die in der folgenden Tabelle aufgeführt sind. Datums- und Uhrzeitangaben für diese Dateien sind in der "Universal Time Coordinated" (UTC) angegeben. Wenn Sie die Dateiinformationen anzeigen, werden diese Angaben in die Ortszeit umgewandelt. Um den Unterschied zwischen UTC und Ortszeit zu ermitteln, verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in Systemsteuerung. Datum/Uhrzeit Versionsgröße Dateiname
15-Aug-2002 08:34 5.0.2195.5265 42,256 Basesrv.dll
15-Aug-2002 08:34 5.0.2195.5907 222,992 Gdi32.dll
15-Aug-2002 08:34 5.0.2195.6011 708.880 Kernel32.dll
15-Aug-2002 08:34 5.0.2195.4733 332.560 Msgina.dll
15-Aug-2002 08:34 5.0.2195.6000 379.664 User32.dll
15-Aug-2002 08:34 5.0.2195.5968 369,936 Userenv.dll
08-Aug-2002 15:23 5.0.2195.6003 1.642.416 Win32k.sys
15-Aug-2002 08:30 5.0.2195.6013 179.472 Winlogon.exe
15-Aug-2002 08:34 5.0.2195.5935 243,472 Winsrv.dll
Status
Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.
Weitere Informationen
Weitere Informationen zur Verwendung des Remote Shutdown-Tools (Shutdown.exe) zum Herunterfahren und Neustarten eines lokalen oder remote windows 2000-basierten Computers finden Sie in der folgenden Artikelnummer, um den Artikel in der Microsoft Knowledge Base anzuzeigen:
317371 Verwenden des Remote shutdown-Tools zum Herunterfahren und Neustarten eines Computers in Windows 2000
Weitere Informationen zum Installieren mehrerer Hotfixes beim einmaligen Neustart finden Sie in der folgenden Artikelnummer, um den Artikel in der Microsoft Knowledge Base anzuzeigen:
296861 Installieren von mehreren Windows-Updates oder Hotfixes mit nur einem Neustart