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WinStoreUI.admx conflict when Central Store is updated with Windows 10 Version 1511 ADMX files

Dieser Artikel enthält Hilfe zum Lösen eines WinStoreUI.admx-Konflikts, der auftritt, wenn der zentrale Store mithilfe von ADMX-Dateien von Windows 10, Version 1511, aktualisiert wird.

Gilt für: Windows Server (alle unterstützten Versionen)
Ursprüngliche KB-Nummer: 3190327

Symptome

Die Datei "WinStoreUI.admx" ist in Windows Server 2012 R2 verfügbar, ist jedoch nicht in der ersten Version von Windows 10 enthalten. Nachdem Sie den zentralen Speicher jedoch mithilfe der ADMX-Dateien von Windows 10 Version 1511 aktualisiert haben, wird der folgende Fehler angezeigt, sobald Sie mit der Bearbeitung eines Gruppenrichtlinienobjekts (GPO) beginnen:

Der Namespace "Microsoft.Policies.WindowsStore" ist bereits als Zielnamespace für eine andere Datei im Speicher definiert.

Screenshot des Fensters

Der Vergleich der ADMX-Dateien von Windows Server 2012 R2 und Windows 10 Version 1511 zeigt, dass WindowsStore.admx dieselben Informationen wie WinStoreUI.admx und einige zusätzliche Richtlinieneinstellungen enthält. Nachdem Sie WinStoreUI.admx gelöscht haben, tritt dieser Fehler nicht mehr auf. Der Ergebnissatz von Richtlinien auf einem 2012 R2-basierten Computer enthält jedoch den folgenden Fehler:

Screenshot der Fehlermeldung, bei der es sich um einen Fehler beim Sammeln von Daten für administrative Vorlagen handelt.

Fehler beim Sammeln von Daten für administrative Vorlagen. Die folgenden Fehler sind aufgetreten.

Eine entsprechende Ressourcendatei wurde für \\<domain>\sysvol\<domain.dns>policies\PolicyDefinitions\WinStoreUI.admx(error = 2) nicht gefunden: Das System kann die angegebene Datei nicht finden.

Ursache

In Windows 10, Version 1507, wurde die Store-ADMX-Datei entfernt. Ein Fix hat die ADMX-Datei wiederhergestellt. Diese Datei hat jedoch jetzt einen neuen Namen. Nachdem Version 1511 installiert wurde, verfügen Kunden beim Aktualisieren des zentralen Stores jetzt über zwei ADMX-Dateien mit identischen Einstellungen. Da dies nicht zulässig ist, tritt der im Abschnitt "Symptome" beschriebene Fehler auf.

Die ADMX-Dateien sind die folgenden:

  • Name der ursprünglichen Store-Gruppenrichtlinie: winstoreui.admx
  • Dateiname der neuen Store-Gruppenrichtlinie: "windowsstore.admx"

Lösung

Dieses Problem wurde in Windows 10, Version 1511 und durch das neueste kumulative Update behoben. Betroffene Kunden sollten nach Möglichkeit ein Upgrade auf diese Version durchführen. Führen Sie die folgenden Schritte aus, um zu verhindern, dass der Fehler auftritt, wenn Sie "Gpedit.msc" öffnen und wenn Sie Gpresult.exe ausführen:

  1. Stellen Sie sicher, dass Sie sowohl "winstoreui.admx" als auch "windowsstore.admx" im zentralen Store haben.
  2. Löschen Sie die Dateien "winstoreui.admx" und "winstoreui.adml" aus dem zentralen Speicher.
  3. Stellen Sie sicher, dass sowohl das Öffnen von Gpedit.msc als auch das Ausführen Gpresults.exe ohne Fehler funktionieren.