Es kann nützlich sein, die Anzahl der in einem Bericht enthaltenen Datensätze zu zählen. In gruppierten oder zusammenfassenden Berichten können Sie die Anzahl der Datensätze in jeder Gruppe anzeigen. Oder Sie können jedem Datensatz eine Zeilennummer hinzufügen, um das Verweisen auf jeden einzelnen zu vereinfachen. In diesem Artikel wird Schritt für Schritt erläutert, wie Sie Anzahlen und Zeilennummern zu Ihrem Bericht hinzufügen.
Inhalt dieses Artikels
- Zählen der Anzahl von Datensätzen in einem Bericht oder einer Gruppe
- Fügen Sie für jeden Datensatz in einem Bericht oder einer Gruppe eine Zeilennummer hinzu
Zählen der Anzahl von Datensätzen in einem Bericht oder einer Gruppe
Die Layoutansicht bietet Ihnen die schnellste Möglichkeit, dem Bericht Zähler hinzuzufügen.
Zählen von Datensätzen mithilfe der Layoutansicht
Klicken Sie im Navigationsbereich mit der rechten Maustaste auf den Bericht, und klicken Sie dann im Kontextmenü auf Layoutansicht .
Klicken Sie auf ein Feld, das Sie zählen möchten. Um sicherzustellen, dass alle Datensätze gezählt werden, klicken Sie auf ein Feld, von dem Sie wissen, dass es keine Nullwerte enthält, z. B. ein ID-Feld.
Klicken Sie dann auf der Registerkarte Entwurf in der Gruppe Gruppierung und Summen auf Summen.
Führen Sie eine der folgenden Aktionen aus:
Wenn Sie alle Datensätze im Bericht zählen möchten, unabhängig davon, ob im ausgewählten Feld ein Wert vorhanden ist, klicken Sie auf Datensätze zählen.
Wenn Sie nur Datensätze zählen möchten, für die im ausgewählten Feld ein Wert vorhanden ist, klicken Sie auf Werte zählen.
Hinweis
Die Funktion "Werte zählen" ist für Felder mit den folgenden Datentypen nicht verfügbar:
- Langer Text (Memo)
- OLE-Objekt
- Hyperlink
- Anlage
Access fügt dem Abschnitt "Berichtsfuß" ein Textfeld hinzu und legt seine Eigenschaft "Steuerelementquelle" auf einen Ausdruck fest, der die Anzahlfunktion ausführt. Wenn der Bericht Gruppierungsebenen enthält, fügt Access außerdem jedem Gruppenfuß, der dieselbe Berechnung ausführt, ein Textfeld hinzu.
Hinweis
Wenn Sie die Zählung für ein bestimmtes Feld mithilfe der Layoutansicht erstellen, erstellt Access einen Ausdruck, der nur die Datensätze zählt, bei denen das Feld nicht Null ist. Wenn der Bericht beispielsweise zehn Datensätze enthält und Sie die Anzahl einem Feld hinzufügen, das drei Nullwerte enthält, wird im Textfeld "Anzahl" der Wert "7 " angezeigt, die Anzahl der Datensätze mit Nicht-NULL-Werten. Sie können dies vermeiden, indem Sie nur Felder mit Zählungen versehen, die keine Null-Werte zulassen (z. B. ID-Felder), oder Sie können die Steuerelementquelle des Textfelds so bearbeiten, dass immer alle Datensätze gezählt werden, unabhängig davon, ob sie Nullwerte enthalten oder nicht. Gehen Sie dazu wie folgt vor:
Wählen Sie das Textfeld aus, in dem die Anzahl angezeigt wird. Wenn das Eigenschaftenblatt noch nicht angezeigt wird, drücken Sie F4, um es anzuzeigen.
Klicken Sie auf die Registerkarte Daten.
Löschen Sie im Eigenschaftenfeld "Steuerelementquelle " den Ausdruck, und geben Sie =Count(*) ein.
Speichern Sie den Bericht, und wechseln Sie zur Berichtsansicht, um die Ergebnisse anzuzeigen.
Zählen von Datensätzen mithilfe der Entwurfsansicht
Klicken Sie im Navigationsbereich mit der rechten Maustaste auf den Bericht, und klicken Sie dann im Kontextmenü auf Entwurfsansicht .
Klicken Sie auf der Registerkarte Entwurf in der Gruppe Steuerelemente auf Textfeld.
Führen Sie eine der folgenden Aktionen aus:
- Wenn Sie alle Datensätze im Bericht zählen möchten, klicken Sie auf den Abschnitt Berichtskopfzeile oder Berichtsfuß, in dem Sie das Textfeld platzieren möchten.
- Wenn Sie alle Datensätze in jeder Gruppe eines gruppierten Berichts zählen möchten, klicken Sie auf den Abschnitt Gruppenkopfzeile oder Gruppenfuß, in dem Sie das Textfeld platzieren möchten.
Wählen Sie das Textfeld aus, und drücken Sie F4, um das Eigenschaftenblatt anzuzeigen.
Klicken Sie auf die Registerkarte Daten.
Geben Sie im Eigenschaftenfeld "Steuerelementquelle " den Wert =Anzahl(*) ein.
Dieser Ausdruck verwendet die Anzahl-Funktion , um alle Datensätze im Bericht oder in der Gruppe zu zählen, auch wenn einige Felder in einigen Datensätzen NULL sind. Wenn Sie nur Datensätze zählen möchten, bei denen ein bestimmtes Feld nicht Null ist (z. B. Lieferantname), verwenden Sie stattdessen den folgenden Ausdruck: =CDbl(Nz(Anzahl([Lieferantenname]);0))).
Fügen Sie für jeden Datensatz in einem Bericht oder einer Gruppe eine Zeilennummer hinzu
Sie können Elemente in Ihrem Bericht nummerieren. In einem Bericht zu "Umsatz nach Produkt" soll beispielsweise "1" vor dem ersten Element in einer Produktgruppe stehen, "2" vor dem zweiten Element usw. Wenn die nächste Produktgruppe beginnt, beginnt die Zählung von vorn, und "1" steht vor dem ersten Artikel.
Sie können die Elemente im Bericht nummerieren, indem Sie ein berechnetes Steuerelement verwenden und dessen Eigenschaft Running Sum-Eigenschaft festlegen.
- Klicken Sie im Navigationsbereich mit der rechten Maustaste auf den Bericht, und klicken Sie dann im Kontextmenü auf Entwurfsansicht .
- Klicken Sie auf der Registerkarte Entwurf in der Gruppe Steuerelemente auf Textfeld.
- Ziehen Sie im Abschnitt "Details" des Berichts den Mauszeiger, um das Textfeld zu erstellen. Achten Sie darauf, dass er breit genug ist, um die größte Artikelnummer aufzunehmen.
Wenn Sie beispielsweise voraussichtlich hundert Bestellungen haben, benötigen Sie Platz für mindestens drei Zeichen (100). Wenn neben dem Textfeld eine Beschriftung angezeigt wird, löschen Sie die Beschriftung, indem Sie darauf klicken und dann ENTF drücken. Wenn Sie das Textfeld in der Nähe des linken Rands platziert haben, ist die Beschriftung möglicherweise unter dem Textfeld ausgeblendet. Ziehen Sie das Textfeld mit dem Verschiebepunkt in der oberen linken Ecke des Textfelds nach rechts, sodass Sie die Beschriftung sehen können. Klicken Sie dann auf die Beschriftung, und drücken Sie ENTF. - Markieren Sie das Textfeld. Wenn das Eigenschaftenblatt noch nicht angezeigt wird, drücken Sie F4, um es anzuzeigen.
- Klicken Sie auf die Registerkarte "Alle ". Geben Sie im Eigenschaftenfeld Name einen Namen ein, z. B. txtItemNumber.
- Klicken Sie auf die Registerkarte Daten.
- Wählen Sie im Eigenschaftenfeld "Laufende Summe " die Option "Über Gruppe" aus.
- Geben Sie in das Eigenschaftenfeld "Steuerelementquelle " den Wert "=1" ein.
- Klicken Sie auf die Registerkarte Format.
- Geben Sie im Eigenschaftenfeld Formatdie Zeichenfolge #. (ein Nummernzeichen, gefolgt von einem Punkt) ein.
Dadurch wird die Zeilennummer mit einem Punkt nach der Zahl formatiert. - Speichern Sie den Bericht, und wechseln Sie zur Berichtsansicht, um die Ergebnisse anzuzeigen.