KB2765331 – Kumulatives Updatepaket 1 für SQL Server 2012 Service Pack 1

Gilt für
SQL Server 2012 Standard SQL Server 2012 Web SQL Server 2012 Developer SQL Server 2012 Enterprise

EINFÜHRUNG

Dieser Artikel beschreibt das kumulative Updatepaket 1 für Microsoft SQL Server 2012. Dieses Update enthält Hotfixes für Probleme, die nach der Veröffentlichung von SQL Server 2012 Service Pack 1 (SP1) behoben wurden.

Hinweis: Diese Buildnummer dieses kumulativen Updatepakets lautet 11.0.3321.0.

Es wird empfohlen, Hotfixes zu testen, bevor Sie diese in einer Produktionsumgebung bereitstellen. Da die Builds kumulativ sind, enthält jede neue Fixversion alle Hotfixes und Sicherheitsfixes, die in der vorherigen Updateversion von SQL Server 2012 SP1 enthalten waren. Es wird empfohlen, die Anwendung des neuesten Fixrelease in Betracht zu ziehen, das diesen Hotfix enthält.

  Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:

2772858 SQL Server 2012-Builds, die nach der Freigabe von SQL Server 2012 Service Pack 1 veröffentlicht wurden

Wichtige Hinweise zum kumulativen Updatepaket

  • SQL Server 2012 SP1-Hotfixes sind jetzt mehrsprachig. Daher gibt es nur ein kumulatives Hotfixpaket für alle Sprachen.
  • Ein kumulatives Hotfixpaket enthält alle Komponentenpakete. Mit dem kumulativen Updatepaket werden nur die Komponenten aktualisiert, die auf dem System installiert sind.

Weitere Informationen

Bezug des kumulativen Updates 1 für SQL Server 2012 SP1

Ein unterstütztes kumulatives Updatepaket ist jetzt von Microsoft erhältlich. Es sollen jedoch nur die in diesem Artikel beschriebenen Probleme behoben werden. Wenden Sie sie nur auf Systeme an, bei denen diese spezifischen Probleme auftreten. Dieses kumulative Updatepaket wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch keines dieser Probleme schwerwiegend beeinträchtigt ist, empfehlen wir, auf das nächste SQL Server 2012 Service Pack zu warten, das die Hotfixes in diesem kumulativen Updatepaket enthält.

Wenn das kumulative Update zum Download zur Verfügung steht, finden Sie einen Abschnitt "Hotfixdownload verfügbar" oben in diesem Knowledge Base-Artikel. Ist dies nicht der Fall, wenden Sie sich an die Kundenbetreuung bzw. den Support von Microsoft, um das kumulative Updatepaket zu beziehen.

Hinweis: Falls weitere Probleme auftreten oder eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Für zusätzliche Supportanfragen und -belange, die sich nicht auf dieses spezielle kumulative Updatepaket beziehen, fallen die üblichen Supportgebühren an. Besuchen Sie die folgende Microsoft-Website, um eine vollständige Liste der Telefonnummern von Microsoft-Kundendienst und -Support (CSS) anzuzeigen oder eine separate Serviceanfrage zu erstellen:

/contactus/?ws=support

Hotfixes, die in diesem kumulativen Updatepaket enthalten sind

  Microsoft Knowledge Base-Artikel, in denen diese Hotfixes behandelt werden, werden veröffentlicht, sobald sie verfügbar sind.

  Weitere Informationen zu den Fehlern in SQL Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

VSTS-Fehlernummer KB-Artikelnummer Beschreibung
1086784 2406666 FEHLERBEHEBUNG: Fehler "[Teradata Database] [3737]" beim Klicken auf "Anzahl" im Aggregationsentwurfs-Assistenten in SSAS 2008, SSAS 2012 oder SSAS 2008 R2
1078523 2445812 FIX: Eine Spalte, die den Datentyp DATETIME verwendet, wird nicht mithilfe einer Transaktionsreplikation in SQL Server 2008, SQL Server 2008 R2 oder SQL Server 2012 an einen Oracle-Abonnenten repliziert
1078647 2644794 FIX: fFalse-Assertionsfehler beim Versuch, den Wert aus einer XML-Spalte in eine XML-Variable in SQL Server 2008, SQL Server 2008 R2 oder SQL Server 2012 zu konvertieren
1078655 2645648 FIX: Der Exportvorgang schlägt fehl, wenn Sie einen 64-Bit-SSRS 2008 R2-Bericht, SSRS 2012-Bericht oder einen SSRS 2008-Bericht, der mehrere Ebenen einer Dokumentzuordnung enthält, in das PDF-Format exportieren
1078512 2651629 FEHLERBEHEBUNG: Fehlermeldung, wenn Sie mithilfe von DTA eine oder mehrere Abfragen für eine Datenbank abstimmen, die viele Objekte in SQL Server 2008, SQL Server 2008 R2 oder SQL Server 2012 enthält
1086762 2661644 FIX: Zugriffsverletzung im Sqlservr! ReplicaToPrimaryPageCopier::ReadIoCompletionRoutine Funktion in SQL Server 2008 R2 oder SQL Server 2012
1078579 2667037 FIX: Fehler "Das Format der Verbindungszeichenfolge ist ungültig", wenn Sie versuchen, einen Wartungsplan für einen SQL Server 2008 R2- oder SQL Server 2012-Server zu erstellen
1078631 2667742 FIX: Fehler "Nicht genügend Arbeitsspeicher" bei Verwendung von ODBC mit SQL Server 2012, SQL Server 2008 R2 oder SQL Server 2008
1078541 2671078 FIX: Fehlermeldung "Es wird versucht, den Wert einer nicht NULL-fähigen Spalte auf NULL festzulegen" bei Verwendung einer MERGE-Anweisung in SQL Server 2008, SQL Server 2008 R2 oder SQL Server 2012
1086761 2671318 FIX: Die erste Ausführung der xp_cmdshell gespeicherten Prozedur wird erst abgeschlossen, wenn die letzte Ausführung im SQL Server 2012 abgeschlossen ist
1078538 2680799 FIX: Fehlermeldung, wenn Sie eine vollständige Auffüllung eines Volltextindexes mithilfe von Worttrennungen für Chinesisch in SQL Server 2008, SQL Server 2008 R2 oder SQL Server 2012 durchführen
1078582 2697983 FIX: In der TIME_ZONE Spalte der BACKUPSET-Tabelle wird in SQL Server 2008 R2 oder in SQL Server 2012 ein falscher Wert gespeichert
1078535 2698639 FIX: Die Leistung einer SELECT-Anweisung, die einen LIKE-Operator und eine ESCAPE-Klausel enthält, ist in SQL Server 2008 R2 oder in SQL Server 2012 niedrig
1078588 2699013 BEHEBUNG: SQL Server 2012, SQL Server 2008 R2 oder SQL Server 2008 reagiert nicht mehr, und der Fehler "Planer ohne Ergebnis" wird protokolliert
1078516 2703193 FIX: Falsche Ergebnisse beim Ausführen einer parallelen Abfrage, die einen Columnstore-Index in SQL Server 2012 verwendet
1078593 2706601 FEHLERBEHEBUNG: Reihengruppen in einem Bericht fehlen, wenn der Bericht in SQL Server 2008 Reporting Services oder in späteren Versionen von Reporting Services gerendert wird
1078597 2708027 FIX: Fehlermeldung "Während der Berichtsverarbeitung ist ein Fehler aufgetreten", wenn Sie versuchen, einen SSRS 2008 R2- oder SSRS 2012-Bericht in der Vorschau anzuzeigen, nachdem Sie die Sortierung des Datasets auf Griechisch oder Greek_100 festgelegt haben
1078527 2708786 FIX: Zugriffsverletzung beim Erstellen eines Columnstore-Indexes für eine Tabelle in SQL Server 2012
1078530 2709075 Fehler "Schwerwiegender Fehler beim Ausführen einer Volltextabfrage mit dem CONTAINS-Prädikat in SQL Server 2012"
1078649 2713151 FEHLERBEHEBUNG: Zugriffsverletzung beim Verwenden des Datenbankoptimierungsratgebers zum Optimieren einer Tabelle in SQL Server 2008, SQL Server 2008 R2 oder SQL Server 2012, wenn das Kontrollkästchen "Gefilterte Indizes einschließen" aktiviert ist
1078547 2713827 FIX: Fehler "Dataflow -" beim Versuch, ein SSIS-Paket in SSIS 2012 zu öffnen
1078603, 1086774 2714634 BEHEBUNG: Das Generieren von Skripts für eine partitionierte Tabelle, die das Datenkomprimierungsfeature verwendet, dauert sehr lange, wenn SQL Server 2008 R2 oder SQL Server 2012 generiert werden
1078544 2714937 FIX: Fehlermeldung "Kein Objekt mit einer Abstammungs-ID vorhanden" beim Ausführen eines SSIS 2012-Pakets
1078573 2720171 FIX: Fehlermeldung beim Ausführen eines SSIS-Pakets, wenn die sys.xp_regread gespeicherte Prozedur im SQL Server 2012 widerrufen wird: "Die EXECUTE-Berechtigung wurde für das Objekt 'xp_regread' verweigert"
1086770 2723979 FIX: Zugriffsverletzung im internen Deadlock-Monitor von SQL Server, wenn Sie mehrere Anwendungen zusammen mit mehreren aktiven Resultsets in SQL Server 2008 R2 oder in SQL Server 2012 ausführen
1078613, 1078616 2725950 FEHLERBEHEBUNG: Geringe Leistung oder Deadlock beim Wiederherstellen einer Datenbank und gleichzeitigem Ausführen von Anweisungen in SQL Server 2012
1078658 2727322 BEHEBUNG: Beim Ausführen einer Abfrage, die Parallelität im Abfrageausführungsplan in SQL Server 2008, SQL Server 2008 R2 oder SQL Server 2012 verwendet, werden falsche Ergebnisse zurückgegeben
1086769 2728419 FIX: Fehlermeldung "Optimierungsprozess wurde unerwartet beendet", wenn Sie Datenbankoptimierungsratgeber unter der db_owner Rolle in SQL Server 2008 R2 oder in SQL Server 2012 ausführen
1086771 2728534 UPDATE: Fehler "Eine Systemassertionsprüfung ist fehlgeschlagen", wenn Sie einen nicht gruppierten Index für eine Spalte in SQL Server 2008 R2 oder in SQL Server 2012 neu erstellen
1086773 2731068 FIX: Beim Abfragen von Berechnungsdaten eines tabellarischen SSAS-Modells mit SQL Server 2008 R2 PowerPivot für Excel 2010 oder SQL Server 2008 R2 ist ein unerwarteter Fehler aufgetreten PowerPivot für SharePoint 2010
1086772 2737499 FIX: Die KeepTogether-Eigenschaft funktioniert nicht, wenn Sie in SSRS 2008 R2 oder in SSRS 2012 einen Bericht generieren, der eine Tablix enthält
1078575 2737580 FIX: Interner Fehler beim Ausführen von Abfragen für ein nicht rechteckiges Miningmodell mithilfe von DMX oder MDX in SQL Server 2012 Analysis Services
1086766 2738197 FIX: Arbeitsthreads werden nicht sofort aktiviert, wenn mehrere E/A-intensive Aufgaben in SQL Server 2012 gleichzeitig ausgeführt werden
1086767 2739940 FIX: Die Datenbank ist offline und befindet sich im Status "In Wiederherstellung", wenn Sie einen Index in SQL Server 2012 neu erstellen, wenn das Transaktionsprotokoll voll ist
1086780 2752511 FIX: Meldung "Arithmetischer Überlauffehler" beim Ausführen der gespeicherten Systemprozedur sys.sp_tables_info_90_rowset_64 auf einem verknüpften Server in SQL Server 2012
1086781 2754444 FIX: Fehlermeldung "Index und Länge müssen sich auf eine Stelle innerhalb der Zeichenfolge beziehen", wenn eine große Datenmenge aus SAP BW in einem SSIS 2012-Paket extrahiert wird
1086782 2754939 FIX: Zugriffsverletzung tritt auf, wenn Sie eine Volltextabfrage in SQL Server 2012 ausführen
1086785 2755079 FIX: Änderungen werden für Abonnenten nicht synchronisiert, nachdem Sie einen Artikelfilter in einer Transaktionsreplikationspublikation in SQL Server 2008, SQL Server 2012 oder SQL Server 2008 R2 geändert haben
1086763 2756097 FIX: Im Installations- oder Deinstallations-Assistenten eines Updates für SQL Server 2012 wird "Community Technology Preview (August CTP)" angezeigt
1086765 2762557 FIX: Fehlermeldung "Prozess scheint auf Scheduler nicht nachzugeben" beim Ausführen einer Abfrage in SQL Server 2012
1086783 2762559 FIX: Fehler von SQL Server 2012 werden im Dialogfeld Taskstatusbenachrichtigungen in System Center Operations Manager 2012 angezeigt
1086786 2762593 FIX: Das Dienstprogramm Tablediff meldet falsche Ergebnisse, wenn eine Tabelle einen Primärschlüssel in einer UniqueIdentifier-Spalte in SQL Server 2012 enthält
1115973 2780716 FIX: Datenverlust beim Exportieren von Microsoft Azure SQL-Datenbank in ein BACPAC-Paket mit Datenebenenanwendung
1116032 2780719 FIX: Datenverlust beim Importieren einer Datenebenenanwendung aus einer BACPAC-Paketdatei in Microsoft Azure SQL-Datenbank

Informationen zum kumulativen Updatepaket

Informationen zum Neustart

  Sie müssen den Computer nach der Installation dieses kumulativen Updates möglicherweise neu starten.

Registrierungsinformationen

  Sie müssen keine Änderungen an der Registrierung vornehmen, um die Hotfixes aus dem Paket verwenden zu können.

Deinstallieren dieses kumulativen Updatepakets

Gehen Sie wie folgt vor, um dieses kumulative Updatepaket zu deinstallieren:

  1. Öffnen Sie in der Systemsteuerung die Option Software
      Element.

    Hinweis Wenn Sie Windows 7 ausführen, öffnen Sie den Eintrag Programme und Features in der Systemsteuerung.

  2. Suchen Sie den Eintrag, der von diesem kumulativen Updatepaket installiert wurde.

  3. Klicken Sie mit der rechten Maustaste auf den Eintrag, und wählen Sie dann Deinstallieren aus, um das kumulative Updatepaket zu entfernen.

Referenzmaterial

  Weitere Informationen zum inkrementellen Wartungsmodell für SQL Server finden Sie im folgenden Artikel der Microsoft Knowledge Base:

935897
  Zur Bereitstellung von Hotfixes für gemeldete Probleme ist ein inkrementelles Wartungsmodell vom SQL Server-Team verfügbar

  Weitere Informationen zum Benennungsschema für SQL Server-Updates finden Sie im folgenden Artikel der Microsoft Knowledge Base:

822499
  Benennungsschema für Softwareupdatepakete für Microsoft SQL Server
   Weitere Informationen zur Terminologie für Softwareupdates von Microsoft finden Sie im folgenden Artikel der Microsoft Knowledge Base:

824684
  Erläuterung von Standardbegriffen bei Microsoft-Softwareupdates