Drittanbieter-Transport-Agents können nicht korrekt in Exchange Server 2013 geladen werden.

Gilt für: Exchange Server 2013 Service Pack 1Exchange Server 2013 EnterpriseExchange Server 2013 Standard Edition

Problembeschreibung


Nach der Installation von Microsoft Exchange Server 2013 Service Pack 1 (SP1) oder Aktualisierung von Microsoft Exchange Server 2013 auf Microsoft Exchange Server 2013 Service Pack 1 (SP1) können sowohl Transport-Agents von Drittanbietern als auch benutzerdefinierte Transport-Agents nicht richtig installiert werden. Darüber hinaus kann der Microsoft Exchange-Transportdienst (MSExchangeTransport.exe) nicht automatisch gestartet werden. Insbesondere können Sie Produkte von Drittanbietern, die auf Transport-Agents basieren, nicht aktivieren. Sie können zum Beispiel keine Anti-Malware-Software oder keine benutzerdefinierte Transport-Agents aktivieren.

Wenn die Installation fehlschlägt, erhalten Sie auch eine Fehlermeldung angezeigt, die der folgenden ähnelt:

Der TransportAgentFactory-Typ muss Microsoft .NET Klassentyp der Transport-Agent-Factory.

Ursache


Dieses Problem tritt auf, weil die global Assembly Cache (GAC) Richtlinie Konfigurationsdateien ungültigen XML-Code enthalten.

Problemlösung


Microsoft hat ein PowerShell-Skript entwickelt, die einen Formatierungsfehler in den Konfigurationsdateien korrigiert, die die Transport-Erweiterbarkeit steuern, die in Exchange Server 2013 integriert. Um uns dieses Skript für Sie anwenden, sodass Transport Erweiterbarkeit und Produkte, mit denen dies ordnungsgemäß funktioniert, lesen Sie den Abschnitt "Fix it für mich". Wenn Sie dieses Problem manuell beheben möchten, lesen Sie den Abschnitt "Problem manuell beheben lassen".



Automatisch mit Fix it beheben lassen

Zum Beheben dieses Problems automatisch auf einem Server, der die Symptome auftreten, die im Abschnitt "Symptome" aufgeführt sind, klicken Sie auf die Fix it -Schaltfläche oder den Link. Dann klicken Sie auf Ausführen im Dialogfeld Dateidownload, und befolgen Sie die Schritte im Fix it-Assistenten.

Hinweis Dieses Skript gilt nur für Server, die Exchange Server 2013 SP1 ausgeführt werden. Eine endgültige Lösung für diese Lösung wird in Exchange Server 2013 kumulative Update 5 (CU5) übermittelt.




Lassen Sie mich das Problem manuell beheben

Um das Skript manuell zu erhalten und auszuführen, gehen Sie auf die folgende Microsoft Download Center-Website:

Status


Microsoft hat bestätigt, dass es sich um ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt „Eigenschaften“ aufgeführt sind.

Weitere Informationen


Aktualisieren eine vorhandene Installation von Exchange Server 2013, die Drittanbieter-Agents in Exchange Server 2013 SP1 installiert können Sie Server seinen normalen Betrieb wiederherstellen, durch Ausführen des Skripts in der "Fix it"-Lösung.

Installieren Sie Exchange Server 2013 SP1 auf einem neuen Server und anschließend installieren Sie Drittanbieter-Agents vor dem Ausführen von anwenden "Fix it"-Lösung, befolgen Sie diese Schritte zum Wiederherstellen des Servers:
  1. Deinstallieren Sie Drittanbieter-Agents.
  2. Führen Sie das Skript.
  3. Installieren Sie die Agents neu.
Vermeiden Sie folgendermaßen sicherstellen Sie, dass die "Fix it"-Lösung auf einem Server mit Exchange Server 2013 SP1 unmittelbar nach der Installation anwenden. Dann können Sie Agenten von Drittanbietern installieren.

Weitere Informationen zu Exchange Server 2013 SP1 finden Sie auf folgender Microsoft-Website:
2926248 Beschreibung des Exchange Server 2013 Servicepack 1