Einführung
Portalfunktionen Version 8.4.2.21 für Microsoft Dynamics 365 ist jetzt für alle Portale verfügbar, die für ein frühes Upgrade gekennzeichnet sind. In diesem Artikel werden die in diesem Update enthaltenen Features und Verbesserungen sowie der Umfang der Version beschrieben. Eine vollständige Liste aller bisher veröffentlichten Portalupdates und der entsprechenden KB-Artikel finden Sie in diesem KB-Artikel.
Upgrade auf Portal Capabilities Version 8.4.2.21
Diese Version enthält nur einen aktualisierten Portalhost, und es sind keine Lösungspaketupdates erforderlich. Der Portalhost wird automatisch von Microsoft aktualisiert.
Neue Funktionen und behobene Probleme in den Portalfunktionen Version 8.4.2.21
Es gibt einige wichtige Änderungen in dieser Version. Stellen Sie bitte sicher, dass Sie die folgenden Schritte ausgeführt haben, um darauf vorbereitet zu sein:
- Sobald Ihr Portal aktualisiert ist, wird empfohlen, den Browser-Cache zu leeren, bevor Sie die Front-Side-Bearbeitungsfunktionen im Portal verwenden.
- Wenn Sie eine Suche in Entitätsformularen oder Web Forms anzeigen, müssen Sie sicherstellen, dass Benutzer, die diese Formulare verwenden, über Anfügeberechtigungen für die Entität verfügen, deren Nachschlagevorgänge im Portal angezeigt werden, sowie für die Entität, deren Formular angezeigt wird. Ohne Anfügeberechtigungen wird ein Fehler angezeigt, wenn ein Benutzer versucht, einen Datensatz zu erstellen/zu aktualisieren.
Darüber hinaus behebt Version 8.4.2.21 die folgenden Probleme:
- Eine unbehandelte Ausnahme würde ausgelöst, wenn der Metadatendatensatz des Entitätsformulars ein Nachschlagesteuerelement als Dropdownliste hätte und gleichzeitig die Entitätsberechtigung für die Nachschlagedatensatzentität vom übergeordneten Bereich und die übergeordnete Berechtigung vom Kontaktbereich unter Verwendung einer N:N-Beziehung ist.
- Das Unterraster im Entitätsformular wird nicht ordnungsgemäß gerendert, wenn Safari auf einem iPad im Querformat verwendet wird.
- Der Hinweis wurde in einem Entitätsformular in einem Portal hinzugefügt, wird manchmal nicht angezeigt, es sei denn, Sie laden die Seite neu oder fügen eine weitere Notiz hinzu.
- Die Fehlermeldung "Leider ist ein Fehler aufgetreten" wird manchmal angezeigt, wenn Sie zum ersten Mal auf das Portal zugreifen oder auf das Portal zugreifen, wenn Browsercookies gelöscht werden.
- Abfragezeichenfolgenparameter werden in der Rückgabe-URL von SAML-Anforderungen ignoriert, es sei denn, sie sind doppelt codiert.
- In der Entitätsliste für Berechtigungen werden keine Datensätze angezeigt.
- Es ist nicht möglich, mit der rechten Maustaste auf eine Tabelle im Rich-Text-Editor zu klicken, die auf der CMS-Frontoberfläche des Portals angezeigt wird.
- Das Hinzufügen eines benutzerdefinierten JavaScript über die Bearbeitung der CMS-Vorderseite löscht das Feld "adx_copy" der Seite.
- Eine potenzielle Sicherheitsanfälligkeit bezüglich XSS-Angriffen wurde behoben.