Einfügen einer Datumsauswahl

Gilt für
InfoPath 2010 InfoPath 2013

Wichtig

Der Support für Microsoft InfoPath 2013 endete am 14. Juli 2026. Es wird empfohlen, vorhandene InfoPath-Formulare und -Workflows zu unterstützten Microsoft 365-Lösungen zu migrieren. Erfahren Sie mehr über die Einstellung von InfoPath.

Eine Datumsauswahl ist ein Steuerelement, mit dem Benutzer schnell Datumsangaben in ein Microsoft Office InfoPath-Formular eingeben können, indem sie auf einen kleinen Popupkalender klicken. Sie können z. B. eine Datumsauswahl verwenden, um Geburtsdaten von Personen auf einem Versicherungsformular zu erfassen. Sie können auch eine Datumsauswahl verwenden, um voreingestellte Datumsangaben anzuzeigen, z. B. das aktuelle Datum.

Inhalt dieses Artikels

Wann sollte eine Datumsauswahl verwendet werden?

Verwenden Sie eine Datumsauswahl, wenn Sie Folgendes ausführen möchten:

  • Ermöglichen Sie es Benutzern, Datumsangaben ihrer Wahl in ein Formular einzugeben, z. B. Start- und Enddaten für ein bestimmtes Projekt.
  • Verwenden Sie die Funktionen "Heute " und "Jetzt ", um das heutige Datum und die heutige Uhrzeit in einem Formular anzuzeigen.
  • Zeigen Sie Datumsangaben aus einer externen Datenquelle an, z. B. Rechnungs- und Versanddaten aus einer Datenbank mit Kundenbestellungen.

In der folgenden Abbildung wird eine Datumsauswahl in einer Vorlage für ein Reiseanforderungsformular verwendet, um das Abflugdatum für einen Flug zu erfassen.

Feld

Sie können die Datumsauswahl entsprechend Ihren Anforderungen anpassen, indem Sie auf das Steuerelement in der Formularvorlage doppelklicken und dann dessen Eigenschaften ändern. Sie können beispielsweise ein Standarddatum angeben oder die Art und Weise ändern, wie das Datum im Formular angezeigt wird.

Seitenanfang

Die Benutzerfreundlichkeit

Datumsauswahlen sehen aus wie Textfelder, mit der Ausnahme, dass auf der rechten Seite ein kleines Kalendersymbol angezeigt wird. Um den Popupkalender zu öffnen, müssen Benutzer auf das Kalendersymbol klicken. Wenn der Kalender angezeigt wird, können Benutzer auf das gewünschte Datum im Kalender klicken oder mit den Pfeilschaltflächen nach rechts und links durch die Monate blättern. Wenn Benutzer das aktuelle Datum einfügen möchten, können sie unten im Kalender auf die Schaltfläche "Heute " klicken.

Öffnen eines Datumsauswahlkalenders mit Monatsnavigation und Schaltfläche

Seitenanfang

Überlegungen zur Kompatibilität

Wenn Sie eine Formularvorlage in InfoPath entwerfen, können Sie einen bestimmten Kompatibilitätsmodus auswählen, um eine browserkompatible Formularvorlage zu entwerfen. Wenn eine browserkompatible Formularvorlage auf einem Server veröffentlicht wird, auf dem InfoPath Forms Services ausgeführt wird, und dann browserfähig, können Formulare, die auf dieser Formularvorlage basieren, in einem Webbrowser angezeigt werden. Beim Entwerfen einer browserkompatiblen Formularvorlage stehen einige Steuerelemente im Aufgabenbereich Steuerelemente nicht zur Verfügung, da sie nicht in einem Webbrowser angezeigt werden können.

Obwohl Datumsauswahlen beim Entwerfen einer browserkompatiblen Formularvorlage verfügbar sind, beachten Sie die folgenden Einschränkungen:

  • Datumsauswahlen werden nur in Windows Internet Explorer-Browsern vollständig unterstützt. In anderen Webbrowsern wird die Datumsauswahl als Textfeld angezeigt, obwohl Datumsformatierungsoptionen im Textfeld unterstützt werden.
  • Platzhaltertext ist Text, der innerhalb eines Steuerelements auf einer Formularvorlage angezeigt wird. Ein Beispiel für Platzhaltertext ist "Klicken Sie hier, und geben Sie ein". Sie können zwar Platzhaltertexteinstellungen für browserkompatible Formularvorlagen beibehalten, aber dieser Text wird in Webbrowsern nicht angezeigt.

Seitenanfang

Einfügen einer Datumsauswahl

Das Verfahren zum Einfügen einer Datumsauswahl unterscheidet sich geringfügig, je nachdem, ob Sie eine neue, leere Formularvorlage entwerfen oder den Entwurf Ihrer Formularvorlage auf einer Datenbank oder einer anderen externen Datenquelle basieren.

Die folgende Abbildung zeigt, wie eine Datumsauswahl aussieht, wenn sie im Entwurfsmodus ausgewählt ist.

Datumsauswahl im InfoPath-Entwurfsmodus ausgewählt

Steuerelemente können gebunden oder ungebunden sein. Wenn ein Steuerelement gebunden ist, ist es mit einem Feld oder einer Gruppe in der Datenquelle verbunden, sodass in das Steuerelement eingegebene Daten in der zugrunde liegenden Formulardatei (XML) gespeichert werden. Wenn ein Steuerelement ungebunden ist, ist nicht mit einem Feld oder einer Gruppe verbunden, und in das Steuerelement eingegebene Daten werden nicht gespeichert. Wenn Sie ein Steuerelement auswählen oder mit dem Mauszeiger darauf zeigen, werden rechts oben in der Ecke des Steuerelements Text und eine Bindungssymbol angezeigt. Der Text weist auf die Gruppe oder das Feld hin, mit der/dem das Steuerelement in der Datenquelle verbunden ist. Das Symbol zeigt an, ob das Steuerelement korrekt an diese Gruppe oder das Feld gebunden ist. Wenn die Bindung korrekt ist, wird ein grünes Symbol angezeigt. Wenn etwas mit der Bindung nicht stimmt, wird stattdessen ein blaues oder rotes Symbol angezeigt.

Die Datenquelle für die Formularvorlage besteht aus Feldern und Gruppen, die im Aufgabenbereich Datenquelle in einer hierarchischen Ansicht angezeigt werden. Datumsauswahl-Steuerelemente sind immer an Felder gebunden. Im folgenden Beispiel ist die Datumsauswahl "Abreisedatum " in der Formularvorlage an das Feld "Abfahrtsdatum " im Aufgabenbereich "Datenquelle " gebunden.

Auswahl des Abfahrtsdatums, die an das Datenquellenfeld departureDate gebunden ist

Einfügen einer Datumsauswahl in eine neue, leere Formularvorlage

Wenn Sie eine neue, leere Formularvorlage entwerfen, ist das Kontrollkästchen Datenquelle automatisch erstellen im Aufgabenbereich Steuerelemente standardmäßig aktiviert. Hierdurch kann InfoPath Felder und Gruppen automatisch in der Datenquelle erstellen, wenn Sie der Formularvorlage Steuerelemente hinzufügen. Diese Felder und Gruppen werden im Aufgabenbereich Datenquelle durch Ordner- und Dateisymbole dargestellt.

  1. Platzieren Sie den Cursor in der Formularvorlage an der Stelle, wo Sie das Steuerelement einfügen möchten.

  2. Wenn der Aufgabenbereich Steuerelemente nicht angezeigt wird, klicken Sie im Menü Einfügen auf Weitere Steuerelemente, oder drücken Sie ALT+I, C.

  3. Klicken Sie unter "Steuerelemente einfügen" auf "Datumsauswahl".

  4. Um dem Steuerelement eine Beschriftung hinzuzufügen, geben Sie oberhalb oder links vom Steuerelement Text ein, gefolgt von einem Doppelpunkt (:).

  5. Wenn Sie festlegen möchten, wie das Datum im Formular angezeigt werden soll, doppelklicken Sie auf die Datumsauswahl, die in die Formularvorlage eingefügt wurde.

  6. Klicken Sie auf die Registerkarte "Daten" und anschließend auf "Format".

  7. Klicken Sie in der Liste Datum wie folgt anzeigen im Dialogfeld Datumsformat auf das gewünschte Anzeigeformat.

    Hinweis

    Sie können das Anzeigeformat des Datums nur ändern, wenn der Datentyp "Text", "Datum" oder "Datum und Uhrzeit" lautet.

Einfügen einer Datumsauswahl in eine Formularvorlage, die auf einer vorhandenen Datenquelle basiert

Wenn Sie den Entwurf Ihrer Formularvorlage auf einer vorhandenen XML-Datei (Extensible Markup Language), Datenbank oder einem Webdienst basieren lassen, leitet InfoPath die Felder und Gruppen im Aufgabenbereich Datenquelle von dieser vorhandenen Datenquelle ab. In diesem Szenario können Sie eine Datumsauswahl hinzufügen, indem Sie entweder ein Datumsauswahlfeld aus dem Aufgabenbereich "Datenquelle " auf die Formularvorlage ziehen oder die Datumsauswahl mithilfe des Aufgabenbereichs "Steuerelemente " einfügen, wie im folgenden Verfahren beschrieben:

  1. Platzieren Sie den Cursor in der Formularvorlage an der Stelle, wo Sie das Steuerelement einfügen möchten.

  2. Wenn der Aufgabenbereich Steuerelemente nicht angezeigt wird, klicken Sie im Menü Einfügen auf Weitere Steuerelemente, oder drücken Sie ALT+I, C.

  3. Klicken Sie unter "Steuerelemente einfügen" auf "Datumsauswahl".

  4. Wählen Sie im Dialogfeld Datumsauswahlbindung das Feld aus, in dem Sie die Datumsauswahldaten speichern möchten, und klicken Sie dann auf OK.

  5. InfoPath verwendet den Namen des Felds oder der Gruppe als Beschriftung des Steuerelements. Ändern Sie den Beschriftungstext bei Bedarf.

  6. Wenn Sie festlegen möchten, wie das Datum im Formular angezeigt werden soll, doppelklicken Sie auf die Datumsauswahl, die in die Formularvorlage eingefügt wurde.

  7. Klicken Sie auf der Registerkarte "Daten" auf "Format".

  8. Klicken Sie im Listenfeld Datum wie folgt anzeigen im Dialogfeld Datumsformat auf das gewünschte Anzeigeformat.

    Hinweis

    Sie können das Anzeigeformat des Datums nur ändern, wenn der Datentyp "Text", "Datum" oder "Datum und Uhrzeit" lautet.

Tipp

Sie können auch den Aufgabenbereich Datenquelle verwenden, um Steuerelemente einzufügen. Klicken Sie im Aufgabenbereich "Datenquelle " mit der rechten Maustaste auf das Feld, an das Sie die Datumsauswahl binden möchten, und klicken Sie dann im Kontextmenü auf "Datumsauswahl ".

Seitenanfang

Anzeigen des aktuellen Datums in einer Datumsauswahl

Um automatisch das aktuelle Datum in ein Formular einzufügen, wenn Benutzer es öffnen, können Sie die Funktion "Heute " mit einem Datumsauswahlsteuerelement verwenden.

  1. Einfügen einer Datumsauswahl in die Formularvorlage.

  2. Doppelklicken Sie auf die Datumsauswahl, die Sie in der Formularvorlage eingefügt haben.

  3. Klicken Sie auf die Registerkarte Daten.

  4. Klicken Sie unter Standardwert auf Formel einfügen .

  5. Klicken Sie im Dialogfeld "Formel einfügen " auf "Funktion einfügen".

  6. Klicken Sie im Dialogfeld "Funktion einfügen" in der Liste "Kategorien" auf "Datum und Uhrzeit".

  7. Klicken Sie in der Liste "Funktionen " auf "Heute", und klicken Sie dann zweimal auf OK , um zum Dialogfeld "Eigenschaften der Datumsauswahl" zurückzukehren.
    Beachten Sie, dass heute() im Feld "Wert " angezeigt wird.

  8. Deaktivieren Sie unter Standardwert das Kontrollkästchen Diesen Wert aktualisieren, wenn das Ergebnis der Formel neu berechnet wird .

    Hinweis

    Wenn Sie das Kontrollkästchen deaktivieren, wird das Datum nicht jedes Mal automatisch aktualisiert, wenn ein Benutzer ein Formular öffnet, das auf dieser Formularvorlage basiert. Dies ist ideal in Situationen, in denen Benutzer das Datum sehen sollen, an dem das Formular erstellt wurde. Sie können das Kontrollkästchen aktiviert lassen, wenn Sie ein Feld "Zuletzt aktualisiert am " oder " Zuletzt geöffnet am " haben, in dem sich das Datum bei jedem Öffnen des Formulars ändern soll.

  9. Klicken Sie auf OK , um zur Formularvorlage zurückzukehren.

  10. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

  11. Stellen Sie sicher, dass das in der Datumsauswahl angezeigte Datum wie gewünscht aussieht. Wenn dies nicht der Fall ist, können Sie die Anzeige des Datums oder der Uhrzeit ändern, indem Sie im Dialogfeld "Eigenschaften der Datumsauswahl" auf die Schaltfläche "Format" klicken.

Seitenanfang

Anzeigen des aktuellen Datums und der Uhrzeit in einer Datumsauswahl

Um automatisch das aktuelle Datum und die aktuelle Uhrzeit in ein Formular einzufügen, wenn Benutzer es öffnen, können Sie die JETZT-Funktion mit einem Datumsauswahl-Steuerelement verwenden.

  1. Einfügen einer Datumsauswahl in die Formularvorlage.

  2. Doppelklicken Sie auf die Datumsauswahl, die Sie in der Formularvorlage eingefügt haben.

  3. Klicken Sie auf die Registerkarte Daten.

  4. Klicken Sie im Feld "Datentyp" auf "Datum und Uhrzeit".

  5. Klicken Sie auf Format.

  6. Klicken Sie im Dialogfeld Datums- und Uhrzeitformat in der Liste Uhrzeit wie diese anzeigen auf die gewünschte Option, und klicken Sie dann auf OK.

  7. Klicken Sie im Dialogfeld Eigenschaften der Datumsauswahl unter Standardwert auf Formel einfügen .

  8. Klicken Sie im Dialogfeld "Formel einfügen " auf "Funktion einfügen".

  9. Klicken Sie im Dialogfeld "Funktion einfügen" in der Liste "Kategorien" auf "Datum und Uhrzeit".

  10. Klicken Sie in der Liste "Funktionen " auf "Jetzt", und klicken Sie dann zweimal auf "OK ", um zum Dialogfeld "Datumsauswahleigenschaften" zurückzukehren.
    Beachten Sie, dass now() im Feld "Wert " angezeigt wird.

  11. Deaktivieren Sie unter Standardwert das Kontrollkästchen Diesen Wert aktualisieren, wenn das Ergebnis der Formel neu berechnet wird .

    Hinweis

    Wenn Sie das Kontrollkästchen deaktivieren, wird das Datum nicht jedes Mal automatisch aktualisiert, wenn ein Benutzer ein Formular öffnet, das auf dieser Formularvorlage basiert. Dies ist ideal in Situationen, in denen Benutzer das Datum sehen sollen, an dem das Formular erstellt wurde. Sie können das Kontrollkästchen aktiviert lassen, wenn Sie ein Feld "Zuletzt aktualisiert am " oder " Zuletzt geöffnet am " haben, in dem sich das Datum bei jedem Öffnen des Formulars ändern soll.

  12. Klicken Sie auf OK , um zur Formularvorlage zurückzukehren.

  13. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

  14. Stellen Sie sicher, dass das in der Datumsauswahl angezeigte Datum wie gewünscht aussieht. Wenn dies nicht der Fall ist, können Sie die Anzeige des Datums oder der Uhrzeit ändern, indem Sie im Dialogfeld "Eigenschaften der Datumsauswahl" auf die Schaltfläche "Format" klicken.

Seitenanfang

Layouttipps

Verwenden Sie die folgenden Tipps, um das Aussehen, die Größe und andere Aspekte einer Datumsauswahl zu verfeinern:

  • Wenn Sie die Größe mehrerer Datumsauswahlfelder gleichzeitig ändern möchten, wählen Sie die Datumsauswahl aus, deren Größe Sie ändern möchten. Klicken Sie im Menü Format auf Eigenschaften, und nehmen Sie dann auf der Registerkarte Größe die erforderlichen Anpassungen vor.
  • Wenn Sie den Rahmen oder die Farbe einer Datumsauswahl ändern möchten, wählen Sie die Datumsauswahl aus, klicken Sie im Menü "Format " auf "Rahmen und Schattierung", und nehmen Sie dann die erforderlichen Anpassungen vor.
  • Verwenden Sie die Felder " Schriftart " und "Schriftgrad"auf der Formatsymbolleiste, um den Text anzupassen, der in einer Datumsauswahl angezeigt wird. Wenn Sie die Schriftart und den Schriftgrad für alle Datumsauswahlen in der Formularvorlage gleichzeitig ändern möchten, klicken Sie mit der rechten Maustaste auf die Datumsauswahl, die die gewünschte Formatierung enthält, und klicken Sie dann im Kontextmenü auf Schriftart für alle Datumsauswahlsteuerelemente anwenden .
  • Wenn Sie wissen möchten, wie die Datumsauswahl mit tatsächlichem Text aussieht, klicken Sie im Menü "Ansicht" auf "Beispieldaten". Dadurch können Sie sich ein Bild davon machen, wie das Formular aussehen wird, wenn Benutzer es ausfüllen.
  • Gelegentlich scheinen der Text in einer Datumsauswahl und die Beschriftung links neben der Datumsauswahl leicht falsch ausgerichtet zu sein. Um sie schnell neu auszurichten, doppelklicken Sie auf die Datumsauswahl, klicken Sie auf der Registerkarte Größe auf Ausrichten, und klicken Sie dann auf Übernehmen. Wenn sich die Beschriftung und die Datumsauswahl in unterschiedlichen Zellen einer Layouttabelle befinden, klicken Sie mit der rechten Maustaste auf die Zelle, die die Beschriftung enthält, klicken Sie im Kontextmenü auf Tabelleneigenschaften, und klicken Sie dann auf der Registerkarte Zelle unter Vertikale Ausrichtung auf Zentriert.
  • Wenn Sie die Darstellung des Datums ändern möchten, doppelklicken Sie auf die Datumsauswahl, klicken Sie auf die Registerkarte "Daten", und klicken Sie dann auf die Schaltfläche "Format ". Wählen Sie im Dialogfeld Datumsformat ein Anzeigeformat aus.

Seitenanfang