Wichtig
Der Support für Microsoft InfoPath 2013 endete am 14. Juli 2026. Es wird empfohlen, vorhandene InfoPath-Formulare und -Workflows zu unterstützten Microsoft 365-Lösungen zu migrieren. Erfahren Sie mehr über die Einstellung von InfoPath.
Sie können Ihrer Formularvorlage eine sekundäre Datenübermittlungsverbindung hinzufügen, die es Benutzern ermöglicht, ihre Formulardaten in einer E-Mail-Nachricht zu senden. Sie können statische Werte, Werte, die auf den Daten im Formular basieren, oder eine Formel verwenden, um die E-Mail-Adressen, an die das Formular gesendet wird, die Betreffzeile der E-Mail-Nachricht und den Namen des Formulars anzugeben. Sie können auch angeben, ob das Formular im Textkörper der E-Mail-Nachricht oder als Anlage der Nachricht angezeigt werden soll.
Wenn Sie die Formularvorlage so konfigurieren, dass das Formular als Anlage zur E-Mail-Nachricht hinzugefügt wird, können Sie die Formularvorlage auch an die E-Mail-Nachricht anfügen. Indem Sie das Formular und die Formularvorlage als Anlagen zur E-Mail-Nachricht hinzufügen, können Sie sicherstellen, dass die E-Mail-Empfänger das Formular in Microsoft Office InfoPath öffnen können, auch wenn sie die Formularvorlage nicht auf ihren Computern zwischengespeichert haben. Damit die Empfänger die Anlagen öffnen können, muss auf ihren Computern InfoPath installiert sein.
Wenn Benutzer ihre Formulardaten in einer E-Mail-Nachricht übermitteln, erstellt InfoPath eine E-Mail-Nachricht mit den Formulardaten und sendet die Nachricht an die E-Mail-Empfänger, die Sie beim Erstellen der Datenverbindung angegeben haben. Wenn die Personen, die die ausgefüllten Formulare erhalten, Microsoft Office Outlook 2007 verwenden, können sie ihrem Posteingang einen Ordner hinzufügen, der alle erhaltenen InfoPath-Formulare enthält, und diesen Ordner so konfigurieren, dass die Daten in den Formularen in Spalten in Outlook angezeigt werden.
Nachdem Sie die Datenübermittlungsverbindung hinzugefügt haben, konfigurieren Sie die Formularvorlage so, dass Benutzer ihre Formulardaten übermitteln können. Wenn Benutzer das Formular öffnen, fügt InfoPath der Symbolleiste Standard automatisch eine Schaltfläche "Senden" und dem Menü "Datei" einen Befehl "Senden" hinzu. Sie können die Übermittlungsoptionen für Ihre Formularvorlage auch auf folgende Weise anpassen:
- Ändern Sie den Text, der auf der Schaltfläche Senden auf der Standard-Symbolleiste und auf dem Befehl Senden im Menü Datei angezeigt wird.
- Ändern Sie die Tastenkombination für die Schaltfläche "Senden" auf der Symbolleiste "Standard" und für den Befehl "Senden" im Menü "Datei".
- Erstellen Sie benutzerdefinierte Nachrichten, die Ihren Benutzern angezeigt werden, wenn sie ihre Formulare übermitteln.
- Geben Sie an, ob das Formular geöffnet, geschlossen oder ein anderes leeres Formular geöffnet werden soll, nachdem der Benutzer das Formular gesendet hat.
Hinzufügen einer Datenübermittlungsverbindung
Klicken Sie im Menü "Extras " auf "Optionen senden".
Aktivieren Sie im Dialogfeld "Übermittlungsoptionen " das Kontrollkästchen Benutzern das Senden dieses Formulars gestatten .
Klicken Sie auf Formulardaten an ein einzelnes Ziel senden, und klicken Sie dann in der Liste auf E-Mail.
Klicken Sie auf Hinzufügen.
Geben Sie im Datenverbindungs-Assistenten in den entsprechenden Feldern die E-Mail-Adressen der Empfänger, den Betreff, der in der E-Mail-Nachricht angezeigt werden soll, und den gewünschten Einführungstext ein, und klicken Sie dann auf Weiter.
Tipp
Sie können auch ein Feld angeben oder eine Formel verwenden, um den Wert für jedes Feld mit Ausnahme des Felds "Einleitung " zu erstellen.
Wie?
Klicken Sie auf Formel einfügen
.Führen Sie im Dialogfeld "Formel einfügen " einen der folgenden Schritte aus:
Wenn Sie ein Feld in der Formel verwenden möchten, klicken Sie im Dialogfeld Feld oder Gruppe auswählen auf das gewünschte Feld, und klicken Sie dann auf OK.
Um eine Funktion in der Formel zu verwenden, klicken Sie auf Funktion einfügen, wählen Sie im Dialogfeld Funktion einfügen die gewünschte Funktion aus, und klicken Sie dann auf OK.
Tipp
Wenn die Funktion Parameter benötigt, markieren Sie die Funktion im Dialogfeld Funktion einfügen , klicken Sie auf OK, doppelklicken Sie dann im Dialogfeld Formel einfügen im Feld Formel einfügen auf die hinzugefügte Funktion, und klicken Sie auf ein Feld oder eine Gruppe. Links zu weiteren Informationen zu Funktionen finden Sie im Abschnitt Siehe auch .
Geben Sie den Wert oder das Symbol für die mathematische Operation in das Feld Formel ein, um einen Wert oder einen mathematischen Operator in die Formel einzufügen.
Bedienung Symbol Hinzufügen + Subtrahieren - Multiplizieren * Dividieren / -
Hinweis
Wenn die Formel den Divisionsoperator (/) verwendet, muss darauf geachtet werden, dass vor und nach dem Divisionsoperator ein Leerzeichen vorhanden ist. Wenn der Divisionsoperator kein Leerzeichen vor und nach ihm aufweist, interpretiert InfoPath "/" möglicherweise als Trennzeichen für XPath-Standortschritte und nicht als Divisionsoperator.
Um die Formel auf die richtige Syntax zu überprüfen, klicken Sie im Dialogfeld "Formel einfügen " auf "Formel überprüfen".
Links zu weiteren Informationen zu Formeln finden Sie im Abschnitt Siehe auch .
Führen Sie auf der nächsten Seite des Assistenten eine der folgenden Aktionen aus:
Wenn Sie das Formular im Textkörper der E-Mail-Nachricht anzeigen möchten, klicken Sie auf Nur die aktive Ansicht des Formulars und keine Anlage senden.
Wenn Sie die Formulardaten als Anlage an die E-Mail-Nachricht senden möchten, klicken Sie auf Formulardaten als Anlage senden, aktivieren Sie das Kontrollkästchen Formularvorlage anfügen, um sicherzustellen, dass Benutzer das Formular öffnen können , und geben Sie dann einen Namen für das Formular in das Feld Name der Anlage ein. Sie können auch ein Feld angeben oder eine Formel verwenden, um sicherzustellen, dass jeder Formularname eindeutig ist.
Wie?Klicken Sie auf Formel einfügen
.Führen Sie im Dialogfeld "Formel einfügen " einen der folgenden Schritte aus:
Wenn Sie ein Feld in der Formel verwenden möchten, klicken Sie im Dialogfeld Feld oder Gruppe auswählen auf das gewünschte Feld, und klicken Sie dann auf OK.
Um eine Funktion in der Formel zu verwenden, klicken Sie auf Funktion einfügen, wählen Sie im Dialogfeld Funktion einfügen die gewünschte Funktion aus, und klicken Sie dann auf OK.
Tipp
Wenn die Funktion Parameter benötigt, markieren Sie die Funktion im Dialogfeld Funktion einfügen , klicken Sie auf OK, doppelklicken Sie dann im Dialogfeld Formel einfügen im Feld Formel einfügen auf die hinzugefügte Funktion, und klicken Sie auf ein Feld oder eine Gruppe. Links zu weiteren Informationen zu Funktionen finden Sie im Abschnitt Siehe auch .
Geben Sie den Wert oder das Symbol für die mathematische Operation in das Feld Formel ein, um einen Wert oder einen mathematischen Operator in die Formel einzufügen.
Bedienung Symbol Hinzufügen + Subtrahieren - Multiplizieren * Dividieren / -
Hinweis
Wenn die Formel den Divisionsoperator (/) verwendet, muss darauf geachtet werden, dass vor und nach dem Divisionsoperator ein Leerzeichen vorhanden ist. Wenn der Divisionsoperator kein Leerzeichen vor und nach ihm aufweist, interpretiert InfoPath "/" möglicherweise als Trennzeichen für XPath-Standortschritte und nicht als Divisionsoperator.
Um die Formel auf die richtige Syntax zu überprüfen, klicken Sie im Dialogfeld "Formel einfügen " auf "Formel überprüfen".
Links zu weiteren Informationen zu Formeln finden Sie im Abschnitt Siehe auch .
Hinweis
Die Personen, die die Formulardaten als Anlage in einer E-Mail-Nachricht erhalten, müssen InfoPath auf ihren Computern installiert haben, um die Anlage zu öffnen.
Klicken Sie auf Weiter.
Geben Sie auf der nächsten Seite des Assistenten im Feld Geben Sie einen Namen für diese Datenverbindung ein und geben Sie einen beschreibenden Namen für diese Datenverbindung ein.
Stellen Sie sicher, dass die Informationen im Abschnitt Zusammenfassung korrekt sind, und klicken Sie dann auf Fertig stellen.
Wenn Sie den Namen der Schaltfläche "Senden", die auf der Symbolleiste "Standard" angezeigt wird, und des Befehls "Senden", der beim Ausfüllen des Formulars im Menü "Datei" angezeigt wird, ändern möchten, geben Sie den neuen Namen in das Feld "Beschriftung" im Dialogfeld "Übermittlungsoptionen" ein.
Tipp
Wenn Sie dieser Schaltfläche und diesem Befehl eine Tastenkombination zuweisen möchten, geben Sie vor dem Zeichen, das Sie als Tastenkombination verwenden möchten, ein kaufmännisches Und-Zeichen (&) ein. Um beispielsweise ALT+B als Tastenkombination für die Schaltfläche und den Befehl "Senden " zuzuweisen, geben Sie "Su"&"bmit" ein.
Wenn Sie nicht möchten, dass Personen beim Ausfüllen Ihres Formulars einen Absenden-Befehl oder die Schaltfläche "Senden" auf der Standard-Symbolleiste verwenden, deaktivieren Sie die Menüpunkte "Senden" und "Übermitteln" in der Symbolleiste.
Nachdem Benutzer ein Formular gesendet haben, lässt InfoPath das Formular standardmäßig geöffnet und zeigt eine Meldung an, um anzugeben, ob das Formular erfolgreich übermittelt wurde. Wenn Sie dieses Standardverhalten ändern möchten, klicken Sie auf "Erweitert", und führen Sie dann einen der folgenden Schritte aus:
Um das Formular zu schließen oder ein neues leeres Formular zu erstellen, nachdem der Benutzer ein ausgefülltes Formular gesendet hat, klicken Sie auf die gewünschte Option in der Liste Nach dem Senden .
Um eine benutzerdefinierte Nachricht zu erstellen, die anzeigt, ob das Formular erfolgreich gesendet wurde, aktivieren Sie das Kontrollkästchen Benutzerdefinierte Nachrichten verwenden , und geben Sie dann Ihre Nachrichten in die Felder Bei Erfolg und Bei Fehlern ein.
Tipp
Verwenden Sie eine Meldung im Feld "Bei Fehler", um Benutzern mitzuteilen, was sie tun sollen, wenn sie ihr Formular nicht senden können. Sie können Benutzern beispielsweise vorschlagen, ihr Formular zu speichern und sich an jemanden zu wenden, um weitere Anweisungen zu erhalten.
Wenn Sie keine Meldung anzeigen möchten, nachdem der Benutzer ein Formular gesendet hat, deaktivieren Sie das Kontrollkästchen Erfolgs- und Fehlermeldungen anzeigen .