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Oplock Break-Anforderungen werden von einem Windows 7-basierten oder Windows Server 2008 R2-basierten Client ignoriert.

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Problembeschreibung
Betrachten Sie das folgende Szenario:
  • Sie verwenden eine Anwendung für ausführbare Dateien über das Netzwerk von einem Clientcomputer zu öffnen, auf denen Windows 7 oder Windows Server 2008 R2 ausgeführt wird.
  • Diese Anwendung öffnet auch weitere Dateien, die opportunistic locking (Oplock) über das Netzwerk zu ermöglichen.
  • Ein anderer Prozess versucht, eine freigegebene Datei zuzugreifen, die die Anwendung bereits über das Netzwerk geöffnet.
  • Der Server fordert, dass der Clientcomputer die Oplock break.
In diesem Szenario brechen nicht der Oplock Client-Computer. Aus diesem Grund die freigegebene Datei bleibt auf dem Server geöffnet, und andere Clients können diese Datei nicht verwenden.
Ursache
Dieses Problem tritt auf, weil der Speicher-Manager auf dem Clientcomputer ausführbare Objekte enthält und nicht geschlossen. Allerdings wird der Server hält die ausführbare Objekte geschlossen werden, und verwendet die Datei-ID für eine weitere neue Datei erneut. Dies führt zu einem Datei-ID-Konflikt. Wenn die Clientantwort ausgegeben wird, verarbeitet der Client-Computer daher das vorherige ausführbare Objekt anstelle der neuen Datei.
Lösung

Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Dieser Hotfix behebt jedoch nur das Problem, welches in diesem Artikel beschrieben wird. Wenden Sie diesen Hotfix nur auf Systemen an, bei denen das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix wird möglicherweise weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, dass für das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, ist es ein Abschnitt "Hotfix Download Available" am oberen Rand dieser Knowledge Base-Artikel. Wenn dieser Abschnitt nicht angezeigt wird, wenden Sie sich an den Microsoft Customer Service und Support, um den Hotfix zu erhalten.

Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die üblichen Support-Kosten gelten für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der Microsoft-Kundendienst und Support-Telefonnummern bzw. Informationen zum Stellen einer separaten Serviceanfrage finden Sie auf der folgende Microsoft-Website: Hinweis Das Formular "Hotfix Download Available" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, liegt es daran, dass kein Hotfix für diese Sprache verfügbar ist.

Erforderliche Komponenten

Um diesen Hotfix anwenden zu können, müssen Sie Windows 7 Service Pack 1 (SP1) oder Windows Server 2008 R2 SP1 ausgeführt werden.

Weitere Informationen dazu, wie Sie eine Windows 7 oder Windows Server 2008 R2 Servicepack erhalten finden Sie im folgenden Artikel der Microsoft Knowledge Base:
976932 Informationen zum Servicepack 1 für Windows 7 und Windows Server 2008 R2

Registrierungsinformationen

Um diesen Hotfix zu installieren, müssen Sie keinen Änderungen an der Registrierung vornehmen.

Ist ein Neustart erforderlich?

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix anwenden.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine zuvor veröffentlichten Hotfix.

Dateiinformationen

Die internationale Version dieses Hotfixes installiert Dateien mit den Attributen, die in den folgenden Tabellen aufgeführt sind. Die Datumsangaben und Uhrzeiten für diese Dateien werden in Coordinated Universal Time (UTC) aufgeführt. Die Datums- und Uhrzeitangaben für diese Dateien auf dem lokalen Computer werden in Ihrer lokalen Zeit zusammen mit Berücksichtigung der aktuellen Daylight Saving Time (DST) angezeigt. Darüber hinaus können die Datums- und Uhrzeitangaben ändern, wenn Sie bestimmte Operationen auf die Dateien anwenden.
Hinweise zu den Dateiinformationen für Windows 7 und Windows Server 2008 R2
Wichtig: Windows 7-Updates und Windows Server 2008 R2-Hotfixes sind im selben Paket enthalten. Allerdings werden Updates auf der Seite Hotfix Anforderung unter beiden Betriebssystemen aufgelistet. Um das Hotfix-Paket anzufordern, das auf eine oder beide Betriebssysteme angewendet wird, wählen Sie den Hotfix, der auf der Seite unter "Windows 7/Windows Server 2008 R2" aufgelistet ist. Bezieht sich immer auf den Abschnitt "Beziehen sich auf" in Artikel, um das aktuelle Betriebssystem bestimmen, dem jeden Hotfix gilt.
  • Die Dateien für bestimmte Produkte, Meilensteine (RTM, SP geltenn), und Servicebereiche (LDR, GDR) identifiziert werden kann, indem Sie die Versionsnummern der Datei untersuchen, wie in der folgenden Tabelle dargestellt:
    VersionProduktMeilensteinServicebereich
    6.1.760 Version 1.22XxxWindows 7 und Windows Server 2008 R2SP1LDR
  • Die MANIFESTEN-Dateien (. manifest) und MUM-Dateien (.mum), die installiert werden für jede Umgebung sind separat aufgeführt im Abschnitt "Weitere Dateiinformationen für Windows 7 und Windows Server 2008 R2". MUM- und MANIFEST-Dateien sowie die zugehörigen Sicherheitskatalogdateien (.cat) Dateien sind entscheidend für den Status der aktualisierten Komponente beizubehalten. Die Sicherheitskatalogdateien, für die die Attribute nicht aufgelistet sind, sind mit einer digitalen Microsoft-Signatur signiert.
Für alle unterstützten X 86-basierten Versionen von Windows 7
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Rdbss.sys6.1.7601.22276246,78408-Mär-201310:35X 86
Für alle unterstützten X 64-basierten Versionen von Windows 7 und Windows Server 2008 R2
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Rdbss.sys6.1.7601.22276315,39208-Mär-201303:05x64
Für alle unterstützten IA-64-basierten Versionen von Windows Server 2008 R2
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Rdbss.sys6.1.7601.22276736,25608-Mär-201302:31IA-64
Status
Microsoft hat bestätigt, dass dieses Problem auf die im Abschnitt "Gilt für" aufgeführten Microsoft-Produkten zutrifft.
Weitere Informationen
Weitere Informationen zur Terminologie für Softwareupdates finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684 Beschreibung der Standardterminologie, die zum Beschreiben von Microsoft-Softwareupdates verwendet wird

Weitere Dateiinformationen

Weitere Dateiinformationen für Windows 7 und Windows Server 2008 R2

Weitere Dateien für alle unterstützten x 86-basierten Versionen von Windows 7
DateinameX86_d95041acda5dc58fe305467f9bee6a03_31bf3856ad364e35_6.1.7601.22276_none_07c74556a70c889f.Manifest
DateiversionNicht zutreffend
Dateigröße693
Datum (UTC)11-Mär-2013
Zeit (UTC)08:30 Uhr
PlattformNicht zutreffend
DateinameX86_microsoft-Windows-rdbss_31bf3856ad364e35_6.1.7601.22276_none_5c26e12ed8f827c2.manifest
DateiversionNicht zutreffend
Dateigröße21,803
Datum (UTC)08-Mär-2013
Zeit (UTC)13:28
PlattformNicht zutreffend
Weitere Dateien für alle unterstützten x 64-basierten Versionen von Windows 7 und Windows Server 2008 R2
DateinameAmd64_d50863e477941c16f977bf1c89696966_31bf3856ad364e35_6.1.7601.22276_none_38c1c4948e57a278.Manifest
DateiversionNicht zutreffend
Dateigröße697
Datum (UTC)11-Mär-2013
Zeit (UTC)08:30 Uhr
PlattformNicht zutreffend
DateinameAmd64_microsoft-Windows-rdbss_31bf3856ad364e35_6.1.7601.22276_none_b8457cb2915598f8.manifest
DateiversionNicht zutreffend
Dateigröße21,809
Datum (UTC)08-Mär-2013
Zeit (UTC)13:16
PlattformNicht zutreffend
Weitere Dateien für alle unterstützten IA-64-basierten Versionen von Windows Server 2008 R2
DateinameIa64_f14c1128638c6525958b8bdd8aa6e0a2_31bf3856ad364e35_6.1.7601.22276_none_7bb8fda7dee22245.Manifest
DateiversionNicht zutreffend
Dateigröße695
Datum (UTC)11-Mär-2013
Zeit (UTC)08:30 Uhr
PlattformNicht zutreffend
DateinameIa64_microsoft-Windows-rdbss_31bf3856ad364e35_6.1.7601.22276_none_5c288524d8f630be.manifest
DateiversionNicht zutreffend
Dateigröße21,806
Datum (UTC)08-Mär-2013
Zeit (UTC)13:19
PlattformNicht zutreffend

Warnung: Dieser Artikel wurde automatisch übersetzt

Eigenschaften

Artikelnummer: 2824408 – Letzte Überarbeitung: 04/09/2013 20:56:00 – Revision: 1.0

  • Windows 7 Service Pack 1
  • Windows Server 2008 R2 Service Pack 1
  • kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced kbmt KB2824408 KbMtde
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