Applies ToWindows 10

Symptoms

When upgrading to, or updating, Windows 10, you might encounter the error “We couldn’t update system reserved partition”, error code 0xc1900104, or error code 0x800f0922. 

Cause

The System Reserved Partition (SRP) may be full. The System Reserve Partition (SRP) is a small partition on your hard drive that stores boot information for Windows. Some third-party anti-virus and security apps write to the SRP, and can fill it up.

Resolution

Caution: these steps are complicated, and carry some risk. This is best done by advanced users with experience using the command line. If you make an error in entering these commands, you could put your device in a no-boot situation, and possibly lose data you have stored on the device. To upgrade your device, you'll need to free up 15MB of space on the SRP using the appropriate method below, and then try the upgrade again. If you're updating Windows 10, you need to free up 13MB. First, determine whether the SRP is GPT or MBR partition style:

  1. Press the Windows key + R. In the Run window that comes up, type diskmgmt.msc and press Enter.

  2. Press-and-hold or right-click on the Disk (such as Disk 0) that contains the SRP, and select Properties.Properties

  3. Choose the Volumes tab.

  4. The Partition Style: line will say either GUID Partition Table (GPT) or Master Boot Record (MBR).

Second, choose which method you need:

  1. Search for cmd. Press-and-hold or right-click on Command Prompt in the results, and select Run as administrator.

  2. At the command prompt, type mountvol y: /s and then hit Enter. This will add the Y: drive letter to access the System Partition.

  3. Switch to the Y drive by typing Y: and press Enter. Then, navigate to the Fonts folder by typing cd EFI\Microsoft\Boot\Fonts. Once there, type del *.* to delete font files. The system may ask you if you are sure to continue, press Y and then Enter to continue.

  1. Press the Windows key + R. In the Run window that comes up, type diskmgmt.msc and press Enter.

  2. Select the partition marked System Reserve. Press-and-hold or right-click on it.

  3. Select Change Drive Letter and Paths.

  4. Choose Add.

  5. Enter Y for the drive letter.

  6. Tap or click OK.

  7. From the Start menu, search for cmd. Right-click Command Prompt from the search results, and select Run as administrator.

  8. In the command prompt, type Y: and hit enter to switch to that drive. Then, navigate to the Fonts folder by typing cd Boot\Fonts.

  9. Type the following and press Enter:takeown /d y /r /f .

    Note: You must include the space and the period after the “f”, or the command will not work properly.

  10. Back up the permission to the drive by typing the following and press Enter:

    icacls Y:\* /save %systemdrive%\NTFSp.txt /c /t

    Note: Make sure that all files are showed as successful and none as failed.

  11. Type whoami and press Enter, and then record the user name. Type the following command and press Enter:icacls . /grant <username you got from whoami>:F /t

    Note: Do not put a space between the username and ":F", or the command won't work.

  12. Make sure you are still located in Fonts location (Y:\Boot\Fonts) as described in step 8. Then, Type del *.* to delete font files. The system may ask you if you are sure to continue, press Y and then enter to continue.

Restore permissions

  1. Type the following command and press Enter:

    icacls Y:\ /restore %systemdrive%\NTFSp.txt /c /t

  2. A message may display indicating some files failed while processing – this is normal as these files have been deleted subsequent to backing them up.

  3. If the amount of successful files is none, then the command was executed incorrectly; you must have some files successfully processed before continuing.

  4. Adjust the ACL back to System by typing the following and press Enter:

  5. icacls . /grant system:f /t

  6. Set the owner of the drive back to System by typing the following command and pressing Enter:

    icacls Y: /setowner “SYSTEM” /t /c

  7. Go back to Disk Management and Refresh the data to confirm if the SRP now has a greater percentage of free space. If so, the drive letter can be removed at this point.

  8. Right-click the System Reserved Partition.

  9. Select Change Drive Letter and Paths.

  10. Choose the Y: drive.

  11. Select Remove.

  12. Click OK.

  1. Search for cmd. Press-and-hold or right-click on Command Prompt in the results, and select Run as administrator.

  2. At the command prompt, type mountvol y: /s and then hit Enter. This will add the Y: drive letter in order to access the System Partition.

  3. Type taskkill /im explorer.exe /f and press Enter. Then type explorer.exe and press Enter to restart explorer in Admin mode.Note: While in this mode, some apps (such as OneNote) will not run.

  4. Open File Explorer and put Y:\EFI\Microsoft\Boot\ in the address bar and press enter.

  5. Select the language folders you want to remove and permanently delete them. They will be indicated by a set of four letters, split with hyphen. For example, en-US means U.S. English; de-DE means German.

  6. Optional: Remove unused font files at Y:\EFI\Microsoft\Boot\Fonts.

  7. After removing the files, reboot the device. This will remove the drive letter, and return explorer.exe to a normal mode.

This makes a permanent, but small, increase in the available space of the SRP.  

  1. Remove language folders

    1. Press the Windows key + R. In the Run window that comes up, type diskmgmt.msc and press Enter.

    2. Select the partition marked System Reserve. Press-and-hold or right-click on it.

    3. Select Change Drive Letter and Paths.

    4. Choose Add.

    5. Enter Y for the drive letter.

    6. Tap or click OK.

    7. From the Start menu, search for cmd. Right-click Command Prompt from the search results, and select Run as administrator.

    8. In the command prompt, type Y: and hit enter to switch to that drive.

    9. Type the following and press Enter:

      takeown /d y /r /f .

      Note: You must include the space and the period after the “f”, or the command will not work properly.

    10. Back up the permission to the drive by typing the following and press Enter:

      icacls Y:\* /save %systemdrive%\NTFSp.txt /c /t

      Note: Make sure that all files are showed as successful and none as failed.

    11. Type whoami and press Enter, and then record the user name. Type the following command and press Enter:icacls . /grant <username you got from whoami>:F /tNote: Do not put a space between the username and ":F", or the command won't work.

    12. Open the SRP drive in File Explorer and access the Boot folder, select the language folders you want to remove and permanently delete them. They will be indicated by a set of four letters, split with hyphen. For example, en-US means U.S. English; de-DE means German.

  2. Truncate the NTFS Log

    1. Check the size of the NTFS Log first. From the Command Prompt, type the following and press Enter:chkdsk /L Y:

      • If the size is less than 5000KB, you do not need to truncate the file.

    2. To truncate the file, type the following and press Enter:chkdsk /L:5000 /X /F

    3. Go back to the Disk Management window. Tap or click the Action menu, and select Refresh. Confirm if the SRP has now a greater percentage of free space. If so, press-and-hold or right-click the System Reserve Partition, and select Change Drive Letter and Paths. Select Y: and choose Remove.

  3. Resize the USN journal, if truncating the NTFS Log doesn’t increase the free space in the SRP.

    1. From the Command Prompt, type the following and press Enter:fsutil usn queryjournal Y:

      • This will display the size in hex value. Convert the value to decimal and divide by 1048576, the result will be in MB. (To convert Hex to Decimal: Open the Calculator in Windows, select the View menu, and then choose Programmer. Select Hex, enter the Hex value, and then select Dec)

      • If the journal is 30MB or more, continue with truncating it.

    2. Delete the journal by typing the following command and pressing Enter:fsutil usn deletejournal /D /N Y:

    3. Recreate the journal with a new log size value:fsutil usn createjournal m=1500 a=1 Y:

  4. Restore permissions

    1. Type the following command and press Enter:

      icacls Y:\ /restore %systemdrive%\NTFSp.txt /c /t

      • A message may display indicating some files failed while processing – this is normal as these files have been deleted subsequent to backing them up.

      • If the amount of successful files is none, then the command was executed incorrectly; you must have some files successfully processed before continuing.

    2. Adjust the ACL back to System by typing the following and press Enter:

      icacls . /grant system:f /t

    3. Set the owner of the drive back to System by typing the following command and pressing Enter:

      icacls Y: /setowner “SYSTEM” /t /c

    4. Go back to Disk Management and Refresh the data to confirm if the SRP now has a greater percentage of free space. If so, the drive letter can be removed at this point.

    5. Right-click the System Reserved Partition.

    6. Select Change Drive Letter and Paths.

    7. Choose the Y: drive.

    8. Select Remove.

    9. Click OK.

This creates a larger, but temporary, increase in the available space of the SRP.

  1. Make sure you have an external drive, formatted as NTFS, with at least 250MB of free space.

  2. Press the Windows key + R. In the Run window that comes up, type diskmgmt.msc and press Enter.

  3. Select the Recovery Partition. Press-and-hold or right-click on it.

  4. Select Change Drive Letter and Paths.

  5. Choose Add.

  6. Enter Y for the drive letter.

  7. Tap or click OK.

  8. From the Start screen, swipe in from the right and select the Search charm, or just start typing to search for cmd. Press-and-hold or right-click Command Prompt from the search results, and select Run as administrator.

  9. In the command prompt, type Y: and hit enter to switch to that drive.

  10. Type the following and press Enter: takeown /d y /r /f . Note You must include the space and the period after the “f”, or the command will not work properly.

  11. Type whoami and press Enter, and then record the user name. Type the following command and press Enter: icacls . /grant <username from whoami>:F /t Note: Do not put a space between the username and ":F", or the command won't work.

  12. When that command completes, type or paste the following and then press Enter:

    attrib -s -r -h Y:\Recovery\WindowsRE\winre.wim

  13. Open File Explorer, and note the drive letter of the external drive you are using (for the rest of these instructions, we will use the example F: - wherever you see F: in these steps, it really means the drive letter of the external drive).

  14. In the Command Prompt, type the following and press Enter:

    mkdir F:\Recovery\WindowsRE

  15. Next, type the following and press Enter:

    xcopy Y:\Recovery\WindowsRE\winre.wim F:\Recovery\WindowsRE\winre.wim /h

  16. Map the new path by inputting the following command and then pressing Enter:

    C:\Windows\System32\Reagentc /SetREImage /Path F:\Recovery\WindowsRE /Target C:\Windows

  17. Once verified the copy was made successfully, type the following and press Enter:

    del Y:\Recovery\WindowsRE\winre.wim /F

  18. Go back to the Disk Management window. Tap or click the Action menu, and select Refresh. Confirm if the SRP has now a greater percentage of free space. If so, continue with the upgrade.

  19. Once the upgrade has completed, move the wim file back to the Recovery Partition and re-map the location:

    1. From the Command Prompt, type the following and press Enter:

      xcopy F:\Recovery\WindowsRE\winre.wim Y:\Recovery\WindowsRE\winre.wim /h

    2. Re-map to the original path. Type the following and press Enter:

      C:\Windows\System32\Reagentc /SetREImage /Path Y:\Recovery\WindowsRE /Target C:\Windows

  20. Go back to the Disk Management window. Press-and-hold or right-click the Recovery Partition, and select Change Drive Letter and Paths. Select Y: and choose Remove.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.