Mit Microsoft anmelden
Melden Sie sich an, oder erstellen Sie ein Konto.
Hallo,
Wählen Sie ein anderes Konto aus.
Sie haben mehrere Konten.
Wählen Sie das Konto aus, mit dem Sie sich anmelden möchten.

Viele Unternehmen (z. B. Banken, Restaurants und Postdienstleister) wissen, welche Arbeitsanforderungen an unterschiedlichen Tagen der Woche gelten, und benötigen eine Methode, um ihre Mitarbeiter effizient zu planen. Sie können das Excel Solver-Add-In verwenden, um einen Zeitplan für die Mitarbeiter basierend auf diesen Anforderungen zu erstellen.

Planen der Mitarbeiter für die Erfüllung von Arbeitsanforderungen (Beispiel)

Das folgende Beispiel zeigt, wie Sie mithilfe von Solver den Personalbedarf berechnen können.

Die Contoso-Bank überprüft sieben Tage pro Woche. Die Anzahl der Mitarbeiter, die jeden Tag zum Verarbeiten von Prüfungen benötigt werden, wird in Zeile 14 des Excel unten dargestellt. Beispielsweise werden am Dienstag 13 Mitarbeiter benötigt, am Mittwoch 15 Mitarbeiter und so weiter. Alle Bankmitarbeiter arbeiten fünf aufeinanderfolgende Tage. Wie viele Mitarbeiter kann die Bank mindesten haben und erfüllt dennoch ihre Arbeitsanforderungen?

Im Beispiel verwendete Daten

  1. Beginnen Sie, indem Sie die Zielzelle identifizieren, Zellen ändern und Einschränkungen für Ihr Solver-Modell verwenden.

    Hinweis: Die Zielzelle wird in Excel 2007 als Zielzelle bezeichnet.

    • Zielzelle – Minimieren Sie die Gesamtzahl der Mitarbeiter.

    • Ändern von Zellen: Die Anzahl der Mitarbeiter, die an jedem Tag der Woche mit ihrer Arbeit beginnen (den ersten von fünf aufeinanderfolgenden Tagen). Jede sich ändernde Zelle muss eine nicht negative ganze Zahl sein.

    • Einschränkungen: Für jeden Tag der Woche muss die Anzahl der Mitarbeiter, die arbeiten, größer gleich der Anzahl der erforderlichen Mitarbeiter sein. (Anzahl der Mitarbeiter, die arbeiten)>=(Benötigte Mitarbeiter)

  2. Zum Einrichten des Modells müssen Sie die Anzahl der Mitarbeiter nachverfolgen, die jeden Tag arbeiten. Beginnen Sie mit der Eingabe von Testwerten für die Anzahl der Mitarbeiter, die täglich mit ihrer fünftägigen Schicht im Zellbereich A5:A11 beginnen. Geben Sie beispielsweise in A5 "1" ein, um anzugeben, dass ein Mitarbeiter mit der Arbeit am Montag beginnt und Montag bis Freitag arbeitet. Geben Sie die erforderlichen Arbeitskräfte für jeden Tag im Bereich C14:I14 ein.

  3. Um die Anzahl der Mitarbeiter zu verfolgen, die jeden Tag arbeiten, geben Sie eine 1 oder eine 0 in jede Zelle im Bereich C5:I11 ein. Der Wert 1 in einer Zelle gibt an, dass die Mitarbeiter, die an dem in der Zeile der Zelle festgelegten Tag mit der Arbeit begonnen haben, an dem Tag arbeiten, der der Spalte der Zelle zugeordnet ist. Beispielsweise gibt die 1 in Zelle G5 an, dass Mitarbeiter, die am Montag mit ihrer Arbeit begonnen haben, am Freitag arbeiten. Die 0 in Zelle H5 gibt an, dass die Mitarbeiter, die am Montag mit ihrer Arbeit begonnen haben, nicht am Samstag arbeiten.

  4. Um die Anzahl der Mitarbeiter zu berechnen, die jeden Tag arbeiten, kopieren Sie die Formel = SUMMENPRODUKT($A$5:$A$11;C5:C11) von C12 in D12:I12. In Zelle C12 beispielsweise wird mit dieser Formel =A5+A8+A9+A10 +A11ausgewertet, was gleich (Zahl beginnt am Montag)+ (Zahl beginnt am Donnerstag)+(Zahl beginnt am Freitag)+(Zahl beginnend am Samstag)+ (Zahl ab Sonntag). Diese Summe gibt die Anzahl der Personen an, die am Montag arbeiten.

  5. Nachdem Sie die Gesamtzahl der Mitarbeiter in Zelle A3 mit der Formel =SUMME(A5:A11)berechnet haben, können Sie das Modell wie unten dargestellt in Solver eingeben.

    Solver-Parameter (Dialogfeld)

  6. In der Zielzelle (A3) möchten Sie die Gesamtzahl der Mitarbeiter minimieren. Die Einschränkung C12:I12>=C14:I14 stellt sicher, dass die Anzahl der Mitarbeiter, die jeden Tag arbeiten, mindestens so groß ist wie die Anzahl, die für den jeweiligen Tag erforderlich ist. Mit der Einschränkung A5:A11=Integer wird sichergestellt, dass die Anzahl der Mitarbeiter, die jeden Tag mit ihrer Arbeit beginnen, eine ganze Zahl ist. Zum Hinzufügen dieser Einschränkung klicken Sie im Dialogfeld Solver-Parameter auf Hinzufügen, und geben Sie die Einschränkung im Dialogfeld Nebenbedingung hinzufügen ein (siehe unten).

    Dialogfeld 'Einschränkungen ändern'

  7. Sie können auch die Optionen Lineares Modell und Nicht negative Angenommen für die sich ändernden Zellen auswählen, indem Sie im Dialogfeld Solver-Parameter auf Optionen klicken und dann die Kontrollkästchen im Dialogfeld Solver-Optionen aktivieren.

  8. Klicken Sie auf Lösen. Sie sehen die optimale Anzahl von Mitarbeitern für jeden Tag.

    In diesem Beispiel sind insgesamt 20 Mitarbeiter erforderlich. Ein Mitarbeiter beginnt am Montag, drei am Dienstag, vier am Donnerstag, einer beginnt am Freitag, zwei am Samstag und neun am Sonntag.

    Beachten Sie, dass dieses Modell linear ist, da die Zielzelle durch Hinzufügen von sich ändernden Zellen erstellt wird, und die Einschränkung wird erstellt, indem das Ergebnis verglichen wird, das ermittelt wird, indem das Produkt jeder sich ändernden Zelle mit der erforderlichen Anzahl von Arbeitern eine Konstante (1 oder 0) addiert wird.

Seitenanfang

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen oder Unterstützung in der Answers Community erhalten.

Siehe auch

Herunterladen des Solver-Add-Ins in Excel

Microsoft-Zeitplanvorlagen erhalten

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Office Insidern beitreten

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Sprachqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×