Symptom
Nehmen Sie folgendes Szenario an:
Sie erstellen ein Dialogfeld für die Kontaktentität in Microsoft Dynamics CRM 2013 auf einem Computer, auf dem Windows Internet Explorer 8 installiert ist.
Hinweis Ein Teil der Dialoganforderungen besteht darin, dass CRM-Daten abgefragt und als Auswahlliste angezeigt werden.
Sie fügen beim Erstellen des Dialogfelds einen Schritt CRM-Daten abfragen hinzu.
Die Filter der Abfrage sind dynamisch (FirstName -> equals -> {FirstName(Contact)}).
Der nächste Schritt im Dialogfeld ist eine Seite , die eine Eingabeaufforderung und eine Antwort enthält, in der die Eingabeaufforderung auf {FirstName(Contact)} und die Antwort auf Option Set festgelegt ist, in der die verfügbaren Optionen aus der Abfrage aufgefüllt werden.
Sie führen das Dialogfeld für einen einzelnen Kontaktdatensatz aus.
In diesem Fall sind in den Optionen Eingabeaufforderung und Antwort keine Optionen verfügbar.
Ursache
Dieses Problem tritt auf, weil internet Explorer 8 bewirkt, dass ein Leerzeichen am Anfang der Werte hinzugefügt wird, die mithilfe von Dynamics Slugs in eine Abfrage eingefügt werden.
Lösung
Um dieses Problem zu beheben, können Sie Windows Internet Explorer 9 verwenden, um Dialogfelder zu erstellen und zu veröffentlichen, die CRM-Abfrageschritte enthalten.