Power Apps Portals Version 9.2.2.x Release

Gilt für
Dynamics CRM Online

Einführung

Portalfunktionen Version 9.2.2.x für Microsoft Dynamics 365 befindet sich in der allgemeinen Verfügbarkeit (GA-Phase). Informationen zum Veröffentlichungszeitplan finden Sie im Office 365-Nachrichtencenter für den Veröffentlichungszeitplan in Ihrer geografischen Region.

In diesem Artikel werden die in diesem Update enthaltenen Features und Verbesserungen sowie der Umfang der Version beschrieben. Eine vollständige Liste aller bisher veröffentlichten Portalupdates und der entsprechenden KB-Artikel finden Sie in diesem KB-Artikel.

Umfang der Veröffentlichung

Diese Version enthält nur einen aktualisierten Portalhost und keine Lösungspaketupdates. Der Portalhost wird von Microsoft automatisch auf Version 9.2.2.15 aktualisiert.

Power Apps Portals Version 9.2.2.x Release

Portalhost Version 9.2.2.x behebt die folgenden Probleme:

  • Das Steuerelement für die Portalzeitachse berücksichtigt nicht die Option "Mehrere Dateien zulassen" im Entitätsformular und lässt nur das Hochladen einer einzelnen Datei gleichzeitig zu. Nach dieser Änderung berücksichtigt die Steuerung der Portalzeitachse die Einstellung und ermöglicht das gleichzeitige Hochladen mehrerer Dateien.
  • Entitätsliste und Entitätsliste Odata-Endpunkt geben keinen Fehler aus, wenn die zugrunde liegende Entität/Entitätsansicht nicht mehr gültig ist. Nach dieser Änderung würde ein Fehler in der Diagnoseprotokollierung protokolliert, damit Portalentwickler das Problem mit dem nicht fliegenden Flug beheben können.
  • Die Schaltfläche "Suchindex neu erstellen" wird auf "/_services/about" angezeigt, auch wenn die Suche im Portal deaktiviert ist. Nach dieser Änderung wird die Schaltfläche nicht mehr angezeigt, wenn die Suche deaktiviert ist.
  • Bestimmte Rahmen im Portal verfügen nicht über ein Titelattribut.
  • Beim Paginieren in der Ideenliste im Communityportal werden zusätzliche Abfragezeichenfolgenparameter an die URL angehängt. Nach dieser Änderung werden zusätzliche Abfragezeichenfolgenparameter entfernt.
  • Das Portal zeigt weiterhin deaktivierte Sprachen in der Sprachauswahl an. Nach dieser Änderung werden nur noch die Sprachen angezeigt, die in CDS aktiv sind.
  • Beim Laden des SharePoint-Dokumentrasters wird ein Fehler ausgelöst, wenn das primäre Attribut des Datensatzes mit einem Leerzeichen beginnt. Nach dieser Änderung wird der Fehler nicht mehr ausgelöst, und das SharePoint-Raster wird automatisch geladen.
  • Schnellansichtsformulare berücksichtigen nicht die Spracheinstellung des Portals und rendern den Inhalt in der primären Sprache des Portals.  Nach dieser Änderung berücksichtigen Schnellansichtsformulare die Spracheinstellungen des Portals und rendern Inhalte in der ausgewählten Sprache.
  • Die Webformular-Fortschrittsanzeige ist nicht richtig ausgerichtet, wenn sie auf der linken Seite des Formulars positioniert wird.
  • Bestimmte Fehlermeldungen werden in Doppelbytesprachen wie Japanisch nicht richtig übersetzt
  • Die Sprachausgabe liest die Feldfehlermeldung zweimal.
  • Wenn dem Webformular eine Workflow-Schaltfläche hinzugefügt wird, werden alle anderen Schaltflächen (Zurück, Weiter, Senden) in der Benutzeroberfläche ausgeblendet.
  • Wenn ein Benutzer angemeldet ist, löst die Kennwortänderungsaktion einen Fehler aus, wenn mehrere Kontakte mit derselben E-Mail-Adresse vorhanden sind.
  • Für Portale, in denen Spanisch aktiviert ist, wird beim Senden eines Entitätsformulars ein Fehler ausgelöst, wenn das Entitätsformular eine Karte enthält, für die Geolocation aktiviert ist.
  • Wenn ein Benutzer versucht, eine Datei mit mehr als 50 MB zu löschen, wird ein Fehler auf der Seite angezeigt.
  • Der Text "Öffentlich" ist in den KB-Suchergebnissen hervorgehoben, wenn der Text "Öffentlich" in der Beschreibung des Artikels vorhanden ist.
  • Datumsangaben werden in Zeitreihendiagrammen nicht in der richtigen Reihenfolge angezeigt.
  • Beim Bearbeiten von Webseiten mit dem Portal-Frontseiten-Editor können Benutzer die Webseiten nur bearbeiten, wenn sie über die Berechtigung "Änderung gewähren" für die übergeordnete Seite der Seite verfügen, die bearbeitet wird.

Folgende Änderungen wurden in Build 9.2.2.13 hinzugefügt

  • Die Überprüfung der Entitätsberechtigung im Entitätsformular sollte nicht erforderlich sein, damit Dateianlagen in diesem Formular funktionieren, aber Sie müssen der Anmerkungsentität die Berechtigungen Erstellen, Anfügen und Anfügen an zuweisen. ->(Sowohl in 9.2.2.12- als auch in 9.2.2.13-Builds enthalten)

Folgende Änderungen wurden in Build 9.2.2.14 hinzugefügt

  • Diese Änderung wurde rückgängig gemacht und wird nicht Teil der Version 9.2.2.x sein

    "Im Portal-Frontseiten-Editor können Benutzer nicht auf untergeordnete Webdateien auf einer Webseite zugreifen, wenn der zugehörigen Zugriffssteuerungsregel für Webseiten keine Webrole zugeordnet ist

Folgende Änderungen wurden in Build 9.2.2.15 hinzugefügt

  • Forumantworten funktionieren nicht für Sprachen, die Doppelbyte-Zeichen wie Japanisch, Chinesisch usw. unterstützen.