Fehlermeldung "Sie können die Datei C:\Users[User]\AppData\Roaming\fin.zup nicht verwenden, da sie bereits verwendet wird" beim Drucken mehrerer klassischer Berichte vom RoleTailored-Client in Microsoft Dynamics NAV 2009 Service Pack 1

Gilt für
Dynamics NAV 2009

Dieser Artikel gilt für Microsoft Dynamics NAV für alle Länder und gebietsschemas aller Sprachen.

Symptome

Wenn Sie mehrere klassische Berichte über den RoleTailored-Client (RTC) in Microsoft Dynamics NAV 2009 Service Pack 1 (SP1) drucken, erhalten Sie die folgende Fehlermeldung:

Hinweis

Sie können die Datei C:\Users\User\AppData\Roaming\fin.zup nicht verwenden, da sie bereits verwendet wird.

Dieses Problem tritt auf, wenn folgende Bedingungen vorliegen:

  • Für die Berichte ist kein Layout definiert. Daher werden die Berichte unter der klassischen Berichts-Engine aus der RTC ausgeführt.
  • Mindestens zwei Berichte werden in kurzer Folge gedruckt.

Ursache

Dieses Problem tritt auf, weil die RTC die klassische Berichts-Engine startet, um einen Bericht auszuführen. Wenn ein Bericht gedruckt wird, versucht die klassische Engine, die ZUP-Datei zu speichern. Wenn mehrere Berichte in kurzer Folge gestartet werden, überschreiben mehrere klassische Engines die anderen ZUP-Dateien.

Lösung

Hotfixinformationen

Ein Hotfix zur Behebung des Problems ist von Microsoft erhältlich. Oben in diesem Knowledge Base-Artikel befindet sich der Abschnitt "Hotfixdownload verfügbar". Wenn beim Herunterladen oder Installieren dieses Hotfixes ein Problem auftritt, oder wenn Sie andere Fragen zum technischen Support haben, wenden Sie sich an Ihren Partner, oder wenn Sie direkt bei Microsoft in einem Supportplan registriert sind, können Sie sich an den technischen Support für Microsoft Dynamics wenden und eine neue Supportanfrage erstellen. Besuchen Sie dazu die folgende Microsoft-Website:

https://mbs.microsoft.com/support/newstart.aspx Sie können sich auch telefonisch an den technischen Support für Microsoft Dynamics wenden, indem Sie diese Links für länderspezifische Telefonnummern verwenden. Besuchen Sie dazu eine der folgenden Microsoft-Websites:

Partner

https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global+Support+Contacts Kunden

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htm In Besonderen Fällen können Gebühren, die normalerweise für Supportanrufe anfallen, storniert werden, wenn ein Technischer Supportmitarbeiter für Microsoft Dynamics und zugehörige Produkte feststellt, dass ihr Problem durch ein bestimmtes Update behoben wird. Die üblichen Supportkosten gelten für alle zusätzlichen Supportfragen und -probleme, die nicht für das jeweilige Update in Frage kommen.

            
          

Abrufen des Microsoft Dynamics NAV-Hotfixes oder der Updatedateien

Nachdem Sie einen Microsoft Dynamics NAV-Hotfix anfordern, wird Ihnen ein Link in einer E-Mail gesendet.

Die E-Mail enthält einen Link und ein Kennwort. Sie können den Link verwenden, um den Microsoft Dynamics NAV-Hotfix oder die Updatedateien herunterzuladen. Wenn Sie auf den Link klicken, wird das Dialogfeld Dateidownload – Sicherheitswarnung geöffnet. Anschließend werden Sie aufgefordert, den Download auszuführen, zu speichern oder den Download abzubrechen.

Wenn Sie auf Ausführen klicken, starten die Dateien den Download und den Extraktionsprozess. Sie müssen einen Ordner für die neuen Dateien angeben und dann das Kennwort angeben.

Wenn Sie auf Speichern klicken, müssen Sie einen Pfad zum Speichern der komprimierten Datei angeben. Wenn Sie die gespeicherte Datei öffnen, werden Sie aufgefordert, einen Pfad für die Dateien anzugeben. Anschließend müssen Sie das in der E-Mail angegebene Kennwort angeben.

Wenn Sie auf Abbrechen klicken, wird der Downloadvorgang beendet.

Installieren eines Microsoft Dynamics NAV-Hotfixes oder einer Updatedatei

Die Microsoft Dynamics NAV-Plattform-Hotfixes und -Updates werden als einzelne Dateien verfügbar gemacht. Um einen Microsoft Dynamics NAV-Hotfix oder ein Update zu installieren, müssen Sie die vorhandenen Microsoft Dynamics NAV-Installationsdateien durch den Hotfix oder die Updatedateien ersetzen. Führen Sie hierzu folgende Schritte aus.

Schritt 1: Ersetzen der Dateien in der Installation des klassischen Microsoft Dynamics NAV-Clients

Ersetzen Sie in der Installation des klassischen Microsoft Dynamics NAV-Clients die folgenden Dateien mithilfe des Hotfixes oder der Updatedatei.

Dateiname Dateiversion Dateigröße Datum Uhrzeit Plattform
Dbm.dll 6.0.31587.0 427,848 30.08.2010 1,628 x86
Fin.exe 6.0.31587.0 12,632,904 30.08.2010 1,628 x86
Finhlink.exe 6.0.31587.0 452,432 30.08.2010 1,628 x86
Finsql.exe 6.0.31587.0 12,754,768 30.08.2010 1,628 x86
Nc_netb.dll 6.0.31587.0 96,592 30.08.2010 1,628 x86
Nc_tcp.dll 6.0.31587.0 98,640 30.08.2010 1,628 x86
Nc_tcps.dll 6.0.31587.0 141,136 30.08.2010 1,628 x86
Ndbcs.dll 6.0.31587.0 1,350,480 30.08.2010 1,628 x86
Slave.exe 6.0.31587.0 152,400 30.08.2010 1,628 x86

Führen Sie die folgenden Schritte aus, um die vorhandenen Microsoft Dynamics NAV-Dateien zu ersetzen:

  1. Schließen Sie den klassischen Microsoft Dynamics NAV-Client.

  2. Suchen Sie das Installationsverzeichnis des klassischen Microsoft Dynamics NAV-Clients. Der klassische Microsoft Dynamics NAV-Client wird in der Regel im folgenden Verzeichnis installiert:

    C:\Program Files\Microsoft Dynamics NAV\60\Classic

  3. Kopieren Sie die heruntergeladenen Dateien.

  4. Fügen Sie die heruntergeladenen Dateien in das Installationsverzeichnis des klassischen Microsoft Dynamics NAV-Clients ein.

  5. Klicken Sie auf Ja , um die Dateien im Verzeichnis zu überschreiben.

Schritt 2: Ersetzen der Dateien in der Microsoft Dynamics NAV RoleTailored-Clientinstallation

Ersetzen Sie in der Installation des Microsoft Dynamics NAV RoleTailored-Clients die folgenden Dateien mithilfe des Hotfixes oder der Updatedatei.

Dateiname Dateiversion Dateigröße Datum Uhrzeit Plattform
Microsoft.dynamics.framework.patterns.dll 1.3.10803.301 71,656 23.08.2010 06:30 x86
Microsoft.dynamics.framework.ui.dll 1.3.10803.301 698,328 23.08.2010 06:30 x86
Microsoft.dynamics.framework.ui.mapping.dll 1.3.10803.301 104,424 23.08.2010 06:30 x86
Microsoft.dynamics.framework.ui.navigation.dll 1.3.10803.301 34,800 23.08.2010 06:30 x86
Microsoft.dynamics.framework.ui.ux2006.dll 1.3.10803.301 88,040 23.08.2010 06:30 x86
Microsoft.dynamics.framework.ui.ux2006.winforms.dll 1.3.10803.301 63,480 23.08.2010 06:30 x86
Microsoft.dynamics.framework.ui.windows.dll 1.3.10803.301 83,944 23.08.2010 06:30 x86
Microsoft.dynamics.framework.ui.winforms.controls.dll 1.3.10803.301 2,115,584 23.08.2010 06:30 x86
Microsoft.dynamics.framework.ui.winforms.dll 1.3.10803.301 694,248 23.08.2010 06:30 x86
Microsoft.dynamics.nav.client.builder.dll 6.0.31587.0 198,544 30.08.2010 16:10 x86
Microsoft.dynamics.nav.client.exe 6.0.31587.0 149,376 30.08.2010 16:10 x86
Microsoft.dynamics.nav.client.interop.communicator.dll 1.0.559.183 75,688 30.08.2010 16:10 x86
Microsoft.dynamics.nav.client.serviceconnection.dll 6.0.31587.0 104,352 30.08.2010 16:10 x86
Microsoft.dynamics.nav.client.ui.dll 6.0.31587.0 509,824 30.08.2010 16:10 x86
Microsoft.dynamics.nav.client.winforms.dll 6.0.31587.0 341,904 30.08.2010 16:10 x86
Microsoft.dynamics.nav.client.winforms.tlb Nicht anwendbar 2,680 30.08.2010 1,211 Nicht anwendbar
Microsoft.dynamics.nav.language.dll 6.0.31587.0 2,000,768 30.08.2010 16:10 x86
Microsoft.dynamics.nav.types.dll 6.0.31587.0 567,160 30.08.2010 16:10 x86
Microsoft.dynamics.nav.watson.dll 6.0.31587.0 42,880 30.08.2010 16:10 x86
Microsoft.office.interop.outlook.dll 10.0.4504.0 395,136 30.08.2010 1,628 x86

Führen Sie die folgenden Schritte aus, um diese Dateien zu ersetzen:

  1. Schließen Sie den Microsoft Dynamics NAV RoleTailored-Client.

  2. Suchen Sie das Installationsverzeichnis des Microsoft Dynamics NAV RoleTailored-Clients. Der Microsoft Dynamics NAV RoleTailored-Client wird in der Regel im folgenden Verzeichnis installiert:

    C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored Client

  3. Kopieren Sie die heruntergeladenen Dateien.

  4. Fügen Sie die heruntergeladenen Dateien in das Installationsverzeichnis des Microsoft Dynamics NAV RoleTailored-Clients ein.

  5. Klicken Sie auf Ja , um die Dateien im Verzeichnis zu überschreiben.

Schritt 3: Ersetzen der Dateien in der Microsoft Dynamics NAV Server-Installation

Ersetzen Sie in der Microsoft Dynamics NAV Server-Installation die folgenden Dateien mithilfe des Hotfixes oder der Updatedatei.

Dateiname Dateiversion Dateigröße Datum Uhrzeit Plattform
Httpcfg.exe 5.2.3790.0 22,352 30.08.2010 1,628 x86
Microsoft.dynamics.nav.language.dll 6.0.31587.0 2,000,768 30.08.2010 16:10 x86
Microsoft.dynamics.nav.ncl.dll 6.0.31587.0 608,120 30.08.2010 16:10 x86
Microsoft.dynamics.nav.server.exe 6.0.31587.0 141,184 30.08.2010 16:10 x86
Microsoft.dynamics.nav.service.dll 6.0.31587.0 145,280 30.08.2010 16:10 x86
Microsoft.dynamics.nav.service.runtime.dll 6.0.31587.0 75,664 30.08.2010 16:10 x86
Microsoft.dynamics.nav.service.webservices.dll 6.0.31587.0 145,304 30.08.2010 16:10 x86
Microsoft.dynamics.nav.types.dll 6.0.31587.0 567,160 30.08.2010 16:10 x86
Microsoft.dynamics.nav.watson.dll 6.0.31587.0 42,880 30.08.2010 16:10 x86
Nclcsrt.etx Nicht anwendbar 89,525 30.08.2010 08:31 Nicht anwendbar
Nclcsrt.stx Nicht anwendbar 91,724 30.08.2010 08:31 Nicht anwendbar
Nclcsrts.dll 6.0.31587.0 1,485,648 30.08.2010 16:27 x86
Ndbcs.dll 6.0.31587.0 1,350,480 30.08.2010 16:27 x86

Führen Sie die folgenden Schritte aus, um diese Dateien zu ersetzen:

  1. Beenden Sie den Microsoft Dynamics NAV-Server.

  2. Suchen Sie das Microsoft Dynamics NAV Server-Installationsverzeichnis. Der Microsoft Dynamics NAV-Server wird in der Regel im folgenden Verzeichnis installiert:

    C:\Program Files\Microsoft Dynamics NAV\60\Service

  3. Kopieren Sie die heruntergeladenen Dateien.

  4. Fügen Sie die heruntergeladenen Dateien in das Microsoft Dynamics NAV Server-Installationsverzeichnis ein.

  5. Klicken Sie auf Ja , um die Dateien im Verzeichnis zu überschreiben.

  6. Starten Sie den Microsoft Dynamics NAV-Server.

Schritt 4: Ersetzen der Dateien in der Installation des Microsoft Dynamics NAV-Anwendungsservers

Wenn Sie Microsoft Dynamics NAV-Anwendungsserver installiert haben, ersetzen Sie die folgenden Dateien in der Installation des Microsoft Dynamics NAV-Anwendungsservers mithilfe des Hotfixes oder der Updatedateien.

Dateiname Dateiversion Dateigröße Datum Uhrzeit Plattform
Dbm.dll 6.0.31587.0 427,848 30.08.2010 1,628 x86
Nas.exe 6.0.31587.0 2,271,560 30.08.2010 1,628 x86
Nassql.exe 6.0.31587.0 2,370,384 30.08.2010 1,628 x86
Ndbcs.dll 6.0.31587.0 1,350,480 30.08.2010 1,628 x86
Slave.exe 6.0.31587.0 152,400 30.08.2010 1,628 x86

Führen Sie die folgenden Schritte aus, um die Dateien zu ersetzen.

  1. Beenden Sie den Microsoft Dynamics NAV-Anwendungsserver.

  2. Suchen Sie das Installationsverzeichnis des Microsoft Dynamics NAV-Anwendungsservers. Der Microsoft Dynamics NAV-Anwendungsserver wird in der Regel im folgenden Verzeichnis installiert:

    C:\Program Files\Microsoft Dynamics NAV\60\Application Server

  3. Kopieren Sie die heruntergeladenen Dateien.

  4. Fügen Sie die heruntergeladenen Dateien in das Installationsverzeichnis des Microsoft Dynamics NAV-Anwendungsservers ein.

  5. Klicken Sie auf Ja , um die Dateien im Verzeichnis zu überschreiben.

  6. Starten Sie den Microsoft Dynamics NAV-Anwendungsserver.

Schritt 5: Ersetzen der Dateien in der Installation des Microsoft Dynamics NAV SDK

Wenn Sie das Microsoft Dynamics NAV SDK installiert haben, ersetzen Sie die folgenden Dateien.

Dateiname Dateiversion Dateigröße Datum Uhrzeit Plattform
Cf.h Nicht anwendbar 57,736 30.08.2010 1,211 Nicht anwendbar
Cfront.dll 6.0.31587.0 1,577,808 30.08.2010 1,628 x86
Cfront.ocx 6.0.31587.0 111,952 30.08.2010 1,628 x86
Cfrontsql.dll 6.0.31587.0 1,787,736 30.08.2010 1,628 x86
Libload.c Nicht anwendbar 31,718 30.08.2010 06:51 Nicht anwendbar
Microsoft.dynamics.nav.cfront.cfrontdotnet.dll 6.0.31587.0 182,168 30.08.2010 16:10 x86
Microsoft.dynamics.nav.cfront.cfrontdotnet.xml Nicht anwendbar 442,447 30.08.2010 07:12 Nicht anwendbar
Sample.c Nicht anwendbar 28,718 30.08.2010 06:51 Nicht anwendbar
Sample.exe 6.0.31587.0 152,400 30.08.2010 1,628 x86

Führen Sie die folgenden Schritte aus, um die Dateien zu ersetzen.

  1. Suchen Sie die Installationsverzeichnisse des Microsoft Dynamics NAV SDK. Das Microsoft Dynamics NAV SDK wird in der Regel in den folgenden Verzeichnissen installiert:

    C:\Program Files\Microsoft Dynamics NAV\60\SDK\CFRONT
    C:\Program Files\Microsoft Dynamics NAV\60\SDK\Communication Components
    C:\Program Files\Common Files\Microsoft Dynamics NAV\Communication Component

  2. Wählen Sie das zu aktualisierende SDK aus, entweder C/Front- oder Kommunikationskomponenten.

  3. Kopieren Sie die heruntergeladenen Dateien.

  4. Fügen Sie die heruntergeladenen Dateien in das entsprechende Microsoft Dynamics NAV SDK-Installationsverzeichnis ein.

  5. Klicken Sie auf Ja , um die Dateien im Verzeichnis zu überschreiben.

Hinweis Wenn Sie einen Hotfix oder ein Update für die Kommunikationskomponenten heruntergeladen haben, müssen Sie die .dll Dateien einzeln registrieren.

Schritt 6: Ersetzen der Dateien in der Installation des Microsoft Dynamics NAV ODBC-Treibers

Wenn Sie den Microsoft Dynamics NAV ODBC-Treiber installiert haben, ersetzen Sie die folgenden Dateien in der Installation des Microsoft Dynamics NAV-ODBC-Treibers.

Dateiname Dateiversion Dateigröße Datum Uhrzeit Plattform
Cfront.dll 6.0.31587.0 1,577,808 30.08.2010 1,628 x86
Dbm.dll 6.0.31587.0 427,848 30.08.2010 1,628 x86
Nc_netb.dll 6.0.31587.0 96,592 30.08.2010 1,628 x86
Nc_tcp.dll 6.0.31587.0 98,640 30.08.2010 1,628 x86
Nc_tcps.dll 6.0.31587.0 141,136 30.08.2010 1,628 x86
Nodbc.dll 6.0.31587.0 2,141,008 30.08.2010 1,628 x86
Nodbc.xml Nicht anwendbar 1,209 25.08.2009 16:43 Nicht anwendbar
Nodbccfg.cfg 6.0.31587.0 724,480 30.08.2010 08:05 Nicht anwendbar
Nodbccfg.xml Nicht anwendbar 2,472 25.08.2009 16:43 Nicht anwendbar
Slave.exe 6.0.31587.0 152,400 30.08.2010 1,628 x86

Führen Sie die folgenden Schritte aus, um die Dateien zu ersetzen.

  1. Suchen Sie das Installationsverzeichnis des Microsoft Dynamics NAV ODBC-Treibers. Der Microsoft Dynamics NAV-ODBC-Treiber wird in der Regel im folgenden Verzeichnis installiert:

    C:\Program Files\Microsoft Dynamics NAV\60\ODBC

  2. Kopieren Sie die heruntergeladenen Dateien.

  3. Fügen Sie die heruntergeladenen Dateien in das Installationsverzeichnis des Microsoft Dynamics NAV ODBC-Treibers ein.

  4. Klicken Sie auf Ja , um die Dateien im Verzeichnis zu überschreiben.

Voraussetzungen

Sie müssen Microsoft Dynamics NAV 2009 Service Pack 1 installiert haben, um diesen Hotfix anwenden zu können.

Problemumgehung

Um dieses Problem zu umgehen, definieren Sie ein Layout für die Berichte, die in kurzer Folge von der RTC ausgeführt werden. Wenn das Berichtslayout definiert ist, führt die RTC den Bericht mithilfe einer eigenen Berichts-Engine aus. Daher startet die RTC nicht mehrere Sitzungen der klassischen Berichts-Engine.

Status

Microsoft hat bestätigt, dass dies ein Fehler in den Microsoft-Produkten ist, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:

824684 Erläuterung von Standardbegriffen bei Microsoft-Softwareupdates

Hinweis: Dies ist ein Artikel vom Typ "SCHNELL VERÖFFENTLICHEN", der direkt in der Microsoft-Supportorganisation erstellt wurde. Die Informationen in diesem Artikel werden ohne Gewähr als Reaktion auf auftretende Probleme bereitgestellt. Aufgrund ihrer schnellen Bereitstellung können sie typografische Fehler enthalten und jederzeit ohne vorherige Ankündigung geändert werden. Andere Überlegungen finden Sie unter Nutzungsbedingungen.