Sie können keine Lagerauswahlen aus einer internen Auswahl für Artikel erstellen, für die die Artikelnachverfolgung in Microsoft Dynamics NAV aktiviert ist

Gilt für
Microsoft Dynamics NAV 5.0 Microsoft Dynamics NAV 5.0 Service Pack 1 Dynamics NAV 2009 Service Pack 1 Dynamics NAV

ARTIKEL DER SCHNELLEN VERÖFFENTLICHUNG ENTHALTEN INFORMATIONEN DIREKT VON DER MICROSOFT SUPPORT ORGANIZATION. DIE INFORMATIONEN, DIE HIERIN ENTHALTEN SIND, WERDEN ALS REAKTION AUF NEU AUFTRETENDE ODER EINZIGARTIGE THEMEN ERSTELLT ODER SOLLEN ANDERE INFORMATIONEN ZUR WISSENSDATENBANK ERGÄNZEN.

Dieser Artikel gilt für Microsoft Dynamics NAV für alle Länder und gebietsschemas aller Sprachen.

Symptome

Wenn Sie Lagerauswahlen aus einer internen Auswahl für Artikel erstellen, für die die Artikelnachverfolgung in Microsoft Dynamics NAV aktiviert ist, erhalten Sie die folgende Fehlermeldung:

Hinweis

Die für die Quellposition definierte Artikelverfolgung erfasst mehr als die von Ihnen eingegebene Menge. Sie müssen die vorhandene Artikelverfolgung anpassen und dann die neue Menge erneut eingeben.

Dieses Problem tritt in den folgenden Produkten auf:

  • Microsoft Dynamics NAV 5.0
  • Microsoft Dynamics NAV 5.0 SP1
  • Microsoft Dynamics NAV 2009
  • Microsoft Dynamics NAV 2009 SP1

Ursache

Dieses Problem tritt auf, weil der Wert des QtyAvailToInsertBase-Objekts in der CheckWhseItemTrkgLine-Funktion der Codeeinheit "Whse.-Activity-Register" (7307) pro Dokument, aber nicht pro Losnummer oder Seriennummer in Lageraktivitätszeilen berechnet wird.

Lösung

Hotfixinformationen

Ein unterstützter Hotfix ist jetzt bei Microsoft verfügbar. Es dient jedoch nur zur Behebung des problems, das in diesem Artikel beschrieben wird. Wenden Sie sie nur auf Systeme an, bei denen dieses spezifische Problem auftritt. Dieser Hotfix erhält möglicherweise zusätzliche Tests. Wenn Sie von diesem Problem nicht stark betroffen sind, empfiehlt es sich daher, auf das nächste Microsoft Dynamics NAV Service Pack oder die nächste Version zu warten, die diesen Hotfix enthält.

Hinweis In besonderen Fällen können Gebühren, die normalerweise für Supportanrufe anfallen, storniert werden, wenn ein Technischer Supportmitarbeiter für Microsoft Dynamics und zugehörige Produkte feststellt, dass ihr Problem durch ein bestimmtes Update behoben wird. PLEASE DO NOT TRANSLATE. DOES NOT APPLY TO GERMAN.

            
          

Informationen zur Installation

Microsoft stellt Programmierbeispiele nur zur Veranschaulichung zur Verfügung, ohne ausdrückliche oder stillschweigende Garantie. Dies schließt die stillschweigende Gewährleistung der Marktgängigkeit oder der Eignung für einen bestimmten Zweck ein, ist aber nicht darauf beschränkt. In diesem Artikel wird davon ausgegangen, dass Sie mit der vorgestellten Programmiersprache und den Werkzeugen zum Erstellen und Debuggen von Prozeduren vertraut sind. Die Microsoft Support-Spezialisten können bei der Erläuterung der Funktionalität bestimmter Prozeduren helfen, jedoch werden sie diese Beispiele nicht in Bezug auf eine erweiterte Funktionalität verändern, noch werden sie Prozeduren entwickeln, die auf Ihre besonderen Bedürfnisse zugeschnitten sind.

Hinweis Überprüfen Sie vor der Installation dieses Hotfixs, ob alle Microsoft Navision-Clientbenutzer vom System abgemeldet sind. Dies schließt Microsoft Navision Application Services (NAS)-Clientbenutzer ein. Sie sollten der einzige Clientbenutzer sein, der angemeldet ist, wenn Sie diesen Hotfix implementieren.

Um diesen Hotfix implementieren zu können, benötigen Sie eine Entwicklerlizenz.

Es wird empfohlen, dem Benutzerkonto im Fenster Windows-Anmeldungen oder im Fenster Datenbankanmeldungen die Rollen-ID "SUPER" zuzuweisen. Wenn dem Benutzerkonto die Rollen-ID "SUPER" nicht zugewiesen werden kann, müssen Sie überprüfen, ob das Benutzerkonto über die folgenden Berechtigungen verfügt:

  • Die Berechtigung Ändern für das Objekt, das Sie ändern.
  • Die Execute-Berechtigung für das Systemobjekt-ID 5210-Objekt und für das Systemobjekt-ID 9015-Objekt.

                
Hinweis Sie benötigen keine Rechte für die Datenspeicher, es sei denn, Sie müssen eine Datenreparatur durchführen.

Codeänderungen

Hinweis Testen Sie Codekorrekturen immer in einer kontrollierten Umgebung, bevor Sie die Korrekturen auf Ihre Produktionscomputer anwenden.
Um diesen Hotfix zu installieren, ändern Sie den Code in der CheckWhseItemTrkgLine-Funktion der Codeunit "Whse.-Activity-Register" (7307) wie folgt.

Vorhandener Code

 TempWhseActivLine.SETRANGE("Source No.",TempWhseActivLine."Source No.");
            TempWhseActivLine.SETRANGE("Source Line No.",TempWhseActivLine."Source Line No.");
            TempWhseActivLine.SETRANGE("Source Subline No.",TempWhseActivLine."Source Subline No.");
            // Delete the following lines. 
            QtyAvailToInsertBase := CalcQtyAvailToInsertBase(TempWhseActivLine);
            REPEAT 
            // The end of the lines. 
              TempWhseActivLine.SETRANGE("Serial No.",TempWhseActivLine."Serial No.");
              TempWhseActivLine.SETRANGE("Lot No.",TempWhseActivLine."Lot No.");
              QtyToRegisterBase := 0;

Ersetzungscode

 TempWhseActivLine.SETRANGE("Source No.",TempWhseActivLine."Source No.");
            TempWhseActivLine.SETRANGE("Source Line No.",TempWhseActivLine."Source Line No.");
            TempWhseActivLine.SETRANGE("Source Subline No.",TempWhseActivLine."Source Subline No.");
            // Add the following lines. 
            REPEAT 
              QtyAvailToInsertBase := CalcQtyAvailToInsertBase(TempWhseActivLine);
            // The end of the new lines. 
              TempWhseActivLine.SETRANGE("Serial No.",TempWhseActivLine."Serial No.");
              TempWhseActivLine.SETRANGE("Lot No.",TempWhseActivLine."Lot No.");
              QtyToRegisterBase := 0;

Voraussetzungen

Sie müssen eines der folgenden Produkte installiert haben, um diesen Hotfix anwenden zu können:

  • Microsoft Dynamics NAV 5.0
  • Microsoft Dynamics NAV 5.0 SP1
  • Microsoft Dynamics NAV 2009
  • Microsoft Dynamics NAV 2009 SP1

Informationen zur Deinstallation

Sie können diesen Hotfix nicht entfernen.

Status

Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.

MICROSOFT UND/ODER SEINE LIEFERANTEN GEBEN KEINE ZUSICHERUNGEN ODER GEWÄHRLEISTUNGEN HINSICHTLICH DER EIGNUNG, DER ZUVERLÄSSIGKEIT ODER DER GENAUIGKEIT DER INFORMATIONEN, DIE IN DEN DOKUMENTEN UND DEN ZUGEHÖRIGEN GRAFIKEN ENTHALTEN SIND, DIE AUF DIESER WEBSITE VERÖFFENTLICHT WERDEN (DIE "MATERIALIEN") FÜR IRGENDEINEN ZWECK.

DIE MATERIALIEN ENTHALTEN MÖGLICHERWEISE UNGENAUE ANGABEN ODER TYPOGRAFISCHE FEHLER UND KÖNNEN JEDERZEIT OHNE ANKÜNDIGUNG GEÄNDERT WERDEN. MICROSOFT UND/ODER SEINE LIEFERANTEN LEHNEN ALLE AUSDRÜCKLICHEN, STILLSCHWEIGENDEN ODER GESETZLICHEN ZUSICHERUNGEN, GEWÄHRLEISTUNGEN UND BEDINGUNGEN AB, EINSCHLIEßLICH, ABER NICHT BESCHRÄNKT AUF ZUSICHERUNGEN, GEWÄHRLEISTUNGEN ODER EIGENTUMSBEDINGUNGEN, NICHTVERLETZUNG, ZUFRIEDENSTELLENDER ZUSTAND ODER QUALITÄT, HANDELSÜBLICHKEIT UND EIGNUNG FÜR EINEN BESTIMMTEN ZWECK IN BEZUG AUF DIE MATERIALIEN.