FEHLERBEHEBUNG: Die Microsoft OLE DB-Anbieter für DB2 kann keine Daten lesen, die in DB2 für Windows V10.5 LONG VARCHAR gespeichert sind, wenn die SELECT-Anweisung des DQP-Verbindungsservers verarbeitet wird.

Gilt für
Host Integration Server 2016

Symptome

Nehmen Sie folgendes Szenario an:

  • Sie führen eine SQL SERVER 2008 R2 Distributed Query Processor-SELECT-Anweisung für vierteilige Verbindungsserverabfragen für eine Datenbank von DB2 für Windows V10.5 aus.
  • Die Daten werden in DB2 für Windows V10.5 als LONG VARCHAR gespeichert.

In diesem Szenario wird die folgende Fehlermeldung angezeigt:

Hinweis

Der Verbindungsserver hat inkonsistente Metadaten für eine Spalte bereitgestellt.
Die Spalte weist zur Kompilierzeit einen DBTYPE von 128 und 129 zur Laufzeit auf.

Ursache

Die Microsoft OLE DB-Anbieter für DB2 und der Microsoft DRDA Application Requester Client for DB2 konvertieren DB2 für Windows V10.5 LONG VARCHAR-Datentyp nicht konsistent in den richtigen Microsoft OLE DB-Datentyp. Dieses Problem tritt auf, wenn beide der folgenden Elemente verarbeitet werden:

  • Das Spaltenschema
  • Die Abfrageresultsets

Lösung

Dieses Problem wurde im kumulativen Update 2 für Host Integration Server 2016 behoben.

Status

Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.

Referenzmaterial

Erfahren Sie mehr über die Terminologie , die Microsoft zum Beschreiben von Softwareupdates verwendet.