Zusammenfassung
Dieser Artikel (KB2223005) bietet eine Lösung für ein Netzwerkverbindungsproblem, bei dem die Verbindung auf Windows Server 2003- oder Windows XP-basierten virtuellen Computern (VMs) unterbrochen wird. Dieses Problem tritt auf, wenn der virtuelle Computer unter hoher Auslastung ausgeführt wird. Ausführliche Informationen finden Sie in den Abschnitten „Symptome“, „Ursache“ und „Lösung“ dieses Artikels.
Um den Fix für dieses Problem herunterzuladen, klicken Sie auf den Link Hotfix-Downloads anzeigen und anfordern, der sich oben links auf dem Bildschirm befindet.
Symptome
Nehmen Sie folgendes Szenario an:
- Sie installieren die Hyper-V-Rolle auf einem Computer, auf dem Windows Server 2008 R2 ausgeführt wird.
- Der Computer hostet einen virtuellen Computer, auf dem Windows Server 2003 oder Windows XP ausgeführt wird.
- Der virtuelle Computer wird unter hoher Last ausgeführt.
In diesem Szenario geht die Netzwerkverbindung für den virtuellen Computer verloren. Darüber hinaus müssen Sie den Netzwerkadapter reparieren oder den virtuellen Computer zurücksetzen, um dieses Problem zu beheben.
Ursache
Dieses Problem tritt auf, weil der NDIS 5.0-Miniporttreiber Netzwerkpakete nicht ordnungsgemäß verarbeitet, wenn der zugewiesene Arbeitsspeicher für einen Puffer fast erschöpft ist.
Lösung
Dieser Hotfix ist auch im Microsoft Update-Katalog verfügbar.
Nachdem Sie diesen Hotfix auf dem Hyper-V-Server installiert haben, müssen Sie die Integrationskomponenten auf dem virtuellen Computer aktualisieren, auf dem Windows Server 2003 ausgeführt wird. Führen Sie hierzu die folgenden Schritte aus:
- Verwenden Sie den Hyper-V-Manager, um eine Verbindung mit dem virtuellen Computer herzustellen.
- Das Vm-Verbindungstool wird gestartet.
- Klicken Sie im Menü Aktion auf Integration Services-Setupdatenträger einfügen.
Hotfixinformationen
Ein Hotfix zur Behebung des Problems ist von Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des in diesem Artikel beschriebenen Problems vorgesehen. Deshalb sollten Sie nur Systeme aktualisieren, bei denen das in diesem Artikel beschriebene Problem auftritt. Der Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.
Wenn der Hotfix zum Download zur Verfügung steht, finden Sie einen Abschnitt "Hotfix download available" (Hotfixdownload verfügbar) oben in diesem Knowledge Base-Artikel. Ist dies nicht der Fall, wenden Sie sich an die Kundenbetreuung bzw. den Support von Microsoft, um den Hotfix zu erhalten.
Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Für zusätzliche Supportanfragen und -belange, die sich nicht auf diesen speziellen Hotfix beziehen, fallen die üblichen Supportgebühren an. Eine vollständige Liste der Telefonnummern für Den Microsoft-Kundendienst und -Support oder zum Erstellen einer separaten Serviceanfrage finden Sie auf der folgenden Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support Hinweis Im Formular "Hotfixdownload verfügbar" werden die Sprachen angezeigt, für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, steht der betreffende Hotfix in Ihrer Sprache nicht zur Verfügung.
Voraussetzungen
Um diesen Hotfix anwenden zu können, müssen Sie Windows Server 2008 R2 ausführen. Darüber hinaus muss die Hyper-V-Rolle installiert sein.
Neustartanforderung
Sie müssen den virtuellen Computer neu starten, nachdem Sie diesen Hotfix angewendet haben.
Ersetzte Hotfixes
Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfix.
Dateiinformationen
Die englische Version (USA) dieses Hotfixes installiert Dateien mit den Attributen, die in den folgenden Tabellen aufgeführt sind. Datums- und Uhrzeitangaben für diese Dateien sind in der koordinierten Weltzeit (UTC) angegeben. Die Datums- und Uhrzeitangaben für diese Dateien werden auf Ihrem lokalen Computer in Ihrer Ortszeit und unter Berücksichtigung der Sommerzeit angegeben. Außerdem können sich die Datums- und Uhrzeitangaben ändern, wenn Sie bestimmte Operationen mit den Dateien ausführen.
Hinweise zu den Dateiinformationen für Windows 7 und Windows Server 2008 R2
Wichtig Windows 7- und Windows Server 2008 R2-Hotfixes sind in denselben Paketen enthalten. Auf der Seite "Hotfixanfrage" sind die Hotfixes jedoch unter beiden Betriebssystemen aufgeführt. Wählen Sie den auf der Seite unter "Windows 7/Windows Server 2008 R2" aufgeführten Hotfix aus, um das Hotfixpaket für eines oder beide Betriebssysteme zu erhalten. Lesen Sie in den Artikeln stets den Abschnitt "Die Informationen in diesem Artikel beziehen sich auf", um zu ermitteln, für welches Betriebssystem die einzelnen Hotfixes gelten.
- Die in den einzelnen Umgebungen installierten MANIFEST- (.manifest) und MUM-Dateien (.mum) sind im Abschnitt "Weitere Dateiinformationen für Windows Server 2008 R2 und Windows 7" separat aufgeführt. MUM- und MANIFEST-Dateien sowie die zugehörigen Sicherheitskatalogdateien (.cat) sind sehr wichtig, um den Status der aktualisierten Komponenten beizubehalten. Die Sicherheitskatalogdateien, deren Attribute nicht aufgelistet sind, verfügen über eine digitale Microsoft-Signatur.
Für alle unterstützten x64-basierten Versionen von Windows Server 2008 R2
| Dateiname | Dateiversion | Dateigröße | Datum | Uhrzeit | Plattform |
|---|---|---|---|---|---|
| Netvsc50.sys | 6.1.7600.20743 | 105,472 | 26-Jun-2010 | 03:11 | x64 |
| Netvsc60.sys | 6.1.7600.20743 | 172,544 | 26-Jun-2010 | 03:11 | x64 |
| Netvscres.dll | 6.1.7600.16385 | 42,496 | 14.07.2009 | 01:30 | x64 |
Status
Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.
Weitere Informationen
Weitere Informationen zur Terminologie für Softwareupdates von Microsoft finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684 Beschreibung der Standardterminologie, die zum Beschreiben von Microsoft-Softwareupdates verwendet wird
Weitere Dateiinformationen
Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
981836 Netzwerkkonnektivität für einen Windows Server 2003-basierten virtuellen Hyper-V-Computer geht in Windows Server 2008 R2 vorübergehend verloren
Zusätzliche Dateiinformationen zu Windows Server 2008 R2
Zusätzliche Dateien für alle unterstützten x64-basierten Versionen von Windows Server 2008 R2
| Dateiname | Amd64_wnetvsc.inf_31bf3856ad364e35_6.1.7600.20743_none_b3c5ff0a022bc813.manifest |
|---|---|
| Dateiversion | Nicht anwendbar |
| Dateigröße | 2,657 |
| Datum (UTC) | 28-Jun-2010 |
| melden | 2,157 |
| Plattform | Nicht anwendbar |
| Dateiname | Update.mum |
| Dateiversion | Nicht anwendbar |
| Dateigröße | 1,895 |
| Datum (UTC) | 28-Jun-2010 |
| melden | 2,157 |
| Plattform | Nicht anwendbar |