KB2504524 – FIX: Fehler "Ungültiger Variablentyp" oder "Typkonflikt" beim Ausführen einer UPDATE CUBE-Anweisung mit einer benutzerdefinierten gewichteten Zuordnungsformel in SSAS 2008 R2 oder in SSAS 2008

Microsoft verteilt Fixes für Microsoft SQL Server 2008 R2 oder Microsoft SQL Server 2008 als eine herunterladbare Datei. Da die Fixes kumulativ sind, enthält jede neue Version alle Hotfixes und Sicherheitsfixes, die in der vorherigen Fixversion von SQL Server 2008 R2 oder SQL Server 2008 enthalten waren.

Symptome

Wenn Sie eine UPDATE CUBE-Anweisung mit einer benutzerdefinierten gewichteten Zuordnungsformel in Microsoft SQL Server 2008 R2 Analysis Services (SSAS 2008 R2) oder in Microsoft SQL Server 2008 Analysis Services (SSAS 2008) erstellen, wird eine der folgenden Fehlermeldungen angezeigt:

  • Hinweis

    Folgender Systemfehler ist aufgetreten: Ungültiger Variablentyp.

  • Hinweis

    Folgender Systemfehler ist aufgetreten: Typkonflikt.

Ursache

Dieses Problem tritt auf, weil das SSAS 2008 R2- oder SSAS 2008-Modul versucht, den Datentyp von einem ungültigen Speicherort zu lesen, nachdem SSAS 2008 R2 oder SSAS 2008 Speicher freigegeben hat, der in der benutzerdefinierten Formel für die gewichtete Zuordnung verwendet wird.

Lösung

Informationen zum kumulativen Update

SQL Server 2008 Service Pack 3

Der Fix für dieses Problem wurde erstmals im kumulativen Update 5 für SQL Server 2008 Service Pack 3 veröffentlicht. Weitere Informationen zu diesem kumulativen Updatepaket finden Sie im folgenden Artikel der Microsoft Knowledge Base:

2696626 Kumulatives Updatepaket 5 für SQL Server 2008 Service Pack 3Hinweis Da die Builds kumulativ sind, enthält jede neue Fixversion alle Hotfixes und Sicherheitsfixes, die in der vorherigen Fixversion von SQL Server 2008 enthalten waren. Microsoft empfiehlt, die Anwendung des neuesten Fixrelease zu erwägen, das diesen Hotfix enthält. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:

2629969 Die SQL Server 2008-Builds, die nach der Freigabe von SQL Server 2008 Service Pack 3 veröffentlicht wurden, Microsoft SQL Server 2008 Hotfixes werden für bestimmte SQL Server Service Packs erstellt. Sie müssen einen SQL Server 2008 Service Pack 3-Hotfix auf eine Installation von SQL Server 2008 Service Pack 3 anwenden. Standardmäßig sind alle in einem Service Pack für SQL Server enthaltenen Hotfixes im nächsten Service Pack für SQL Server enthalten.

SQL Server 2008 R2

Die Korrektur für dieses Problem wurde erstmals im kumulativen Update 6 veröffentlicht. Weitere Informationen zum Bezug dieses kumulativen Updatepakets für SQL Server 2008 R2 finden Sie im folgenden Artikel der Microsoft Knowledge Base:

2489376 Kumulatives Updatepaket 6 für SQL Server 2008 R2 Hinweis Da die Builds kumulativ sind, enthält jede neue Fixversion alle Hotfixes und Sicherheitsfixes, die in der vorherigen SQL Server 2008 R2-Fixversion enthalten waren. Es wird empfohlen, die Anwendung des neuesten Fixrelease in Betracht zu ziehen, das diesen Hotfix enthält. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:

981356 SQL Server 2008 R2-Builds, die nach der Freigabe von SQL Server 2008 R2 veröffentlicht wurden

Status

Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.

Weitere Informationen

Weitere Informationen zur UPDATE CUBE-Anweisung für MDX finden Sie auf der folgenden MSDN-Website (MSDN):

Allgemeine Informationen zur UPDATE-CUBE-Anweisung für MDX
Weitere Informationen zur Verwendung eines Cuberückschreibens für MDX finden Sie auf der folgenden MSDN-Website:

Allgemeine Informationen zur Verwendung von Cuberückschreiben für MDX