Symptome
Wenn Remoteadministratorverbindungen aktiviert sind und IPv6 auf dem Host in Microsoft SQL Server 2019 oder 2017 unter Linux deaktiviert ist, stellen Sie fest, dass SQL Server versucht, IPV6 zu überwachen, aber nicht startet.
Datum/Uhrzeit Serverfehler: 26024, Schweregrad: 16, Status: 1.
Datum/Uhrzeit Der Serverserver konnte auf "jedem" <ipv6> 1434 nicht lauschen. Fehler: 0x2742. Um fortzufahren, benachrichtigen Sie Ihren Systemadministrator.
Datum/Uhrzeit Die Unterstützung für die Serververbindung mit dedizierten Administratoren wurde aufgrund des Fehlers 0x2742 nicht gestartet, status Code: 0x1. Dieser Fehler weist in der Regel auf einen Socket-basierten Fehler hin, z. B. auf einen bereits verwendeten Port.
Status
Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.
Lösung
Dieses Problem wurde in den folgenden kumulativen Updates für SQL Server behoben:
Informationen zu kumulativen Updates für SQL Server:
Jedes neue kumulative Update für SQL Server enthält alle Hotfixes und Sicherheitsfixes, die im vorherigen kumulativen Update enthalten waren. Sehen Sie sich die neuesten kumulativen Updates für SQL Server an:
Referenzmaterial
Informieren Sie sich über die Terminologie, die Microsoft zum Beschreiben von Softwareupdates verwendet.