KB3175883 – Leistungsabfall und "Non-yielding Scheduler"-Fehler durch unnötige Spinlocks in SQL Server

Gilt für
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

Symptome

Seit der Einführung eigenständiger Datenbanken in SQL Server führt das Datenbankmodul immer eine Containment-Prüfung durch, bevor gespeicherte Prozeduren ausgeführt werden. Auf High-End-Computern mit mehreren Kernen kann diese Überprüfung aufgrund interner Spinlockkonflikte zu Leistungseinbußen führen und gelegentlich Fehler vom Typ "Planer ohne Ergebnis" verursachen.

Lösung

Dieses Problem wurde erstmals im folgenden kumulativen Update für SQL Server behoben:

Informationen zu kumulativen Updates für SQL Server

Informationen zu kumulativen Updates für SQL Server

Jedes neue kumulative Update für SQL Server enthält alle Hotfixes und Sicherheitsfixes, die im vorherigen kumulativen Update enthalten waren. Sehen Sie sich die neuesten kumulativen Updates für SQL Server an:

Neuestes kumulatives Update für SQL Server 2014 (SP1/SP2)
        
         Neuestes kumulative Update für SQL Server 2016 

Status

Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.

Referenzmaterial

Erfahren Sie mehr über die Terminologie , die Microsoft zum Beschreiben von Softwareupdates verwendet.