KB3028322 – KORREKTUR: Das Rendern eines Berichts in SSRS 2012 oder SSRS 2014 dauert länger als üblich.

Symptome

Angenommen, Sie rendern einen Bericht in Microsoft SQL Server 2012 Reporting Services (SSRS 2012) oder SSRS 2014, und der Bericht weist einige kleine Fehler auf, z. B.:

Hinweis

Bibliothek! ReportServer_0-8!4798!16.12.2014-16:33:01:: i INFO: RenderForNewSession('/MyReport')
Verarbeitung! ReportServer_0-8!4798!12/16/2014-16:33:03:: e ERROR: Throwing Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: , Microsoft.ReportingServices.ReportProcessingException: Es gibt keine Daten für das Feld an Position 8.;
Verarbeitung! ReportServer_0-8!4798!12/16/2014-16:33:33:: e ERROR: Throwing Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: , Microsoft.ReportingServices.ReportProcessingException: Es gibt keine Daten für das Feld an Position 9.;

In diesem Fall wird der Bericht erfolgreich ausgeführt. Das Rendern des Berichts kann jedoch länger dauern als üblich. Jeder Fehler kann zu einer Verzögerung von 30 Sekunden führen.

Ursache

Dieses Problem tritt auf, weil Reporting Services am Laden des unnötigen Fehlerbehandlungsobjekts gehindert wird.

Lösung

Dieses Problem wurde zuerst im folgenden kumulativen Update von SQL Server behoben.

Kumulatives Update 1 für SQL Server 2014 SP1 /en-us/help/3067839

Kumulatives Update 5 für SQL Server 2012 SP2 /en-us/help/3037255

Kumulatives Update 6 für SQL Server 2014 /en-us/help/3031047

Kumulatives Update 14 für SQL Server 2012 SP1 /en-us/help/3023636

Informationen zu kumulativen Updates für SQL Server

Jedes neue kumulative Update für SQL Server enthält alle Hotfixes und alle Sicherheitsfixes, die im vorherigen kumulativen Update enthalten waren. Sehen Sie sich die neuesten kumulativen Updates für SQL Server an:

      

Status

Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.