KB5005689 – KORREKTUR: SQL Server kann nicht mit Fehlermeldungen gestartet werden, wenn ein falsches Zertifikat für SSL bereitgestellt wird

Gilt für
SQL Server 2016 SQL Server 2016 Service Pack 3 - duplicate (do not use)

Symptome

Angenommen, Sie stellen ein falsches Zertifikat für SSL bereit. Microsoft SQL Server 2016 wird nicht gestartet, und Setup protokolliert die folgenden Fehlereinträge im Fehlerprotokoll. Diese Meldungen geben jedoch nicht an, welche Eigenschaft fehlt.

Der Server konnte das Zertifikat, das er zum Initiieren einer SSL-Verbindung benötigt, nicht laden. Der folgende Fehler wurde zurückgegeben: 0x8009030e. Überprüfen Sie die Zertifikate, um sicherzustellen, dass sie gültig sind.

Fehler: 26014, Schweregrad: 16, Status: 1.

Benutzerdefiniertes Zertifikat kann nicht geladen werden [Cert Hash(sha1) "HashNumber"]. Der Server akzeptiert keine Verbindung. Vergewissern Sie sich, dass das Zertifikat ordnungsgemäß installiert ist. Siehe "Konfigurieren des Zertifikats für die Verwendung durch SSL" in

Fehler: 17182, Schweregrad: 16, Status: 1.

Fehler bei der TDSSNIClient-Initialisierung 0x80092004, status Code 0x80. Ursache: Ssl-Unterstützung kann nicht initialisiert werden. Objekt oder Eigenschaft kann nicht gefunden werden.

Fehler: 17182, Schweregrad: 16, Status: 1.

Fehler bei der TDSSNIClient-Initialisierung 0x80092004, status Code 0x1. Ursache: Fehler bei der Initialisierung mit einem Infrastrukturfehler. Überprüfen Sie, ob vorherige Fehler vorliegen. Objekt oder Eigenschaft kann nicht gefunden werden.

Fehler: 17826, Schweregrad: 18, Status: 3.

Die Netzwerkbibliothek konnte aufgrund eines internen Fehlers in der Netzwerkbibliothek nicht gestartet werden. Um die Ursache zu ermitteln, überprüfen Sie die Fehler, die unmittelbar diesem Fehler im Fehlerprotokoll vorangehen.

Fehler: 17120, Schweregrad: 16, Status: 1.

SQL Server konnte den FRunCommunicationsManager-Thread nicht erzeugen. Überprüfen Sie das SQL Server Fehlerprotokoll und die Windows-Ereignisprotokolle, um Informationen zu möglichen verwandten Problemen zu finden.

Lösung

Service Pack-Informationen für SQL Server 2016

Dieses Update ist im folgenden Service Pack für SQL Server enthalten:

Informationen zu Service Packs für SQL Server:

Service Packs sind kumulativ. Jedes neue Service Pack enthält neben neuen Updates alle Updates früherer Service Packs. Es wird empfohlen, das neueste Service Pack und das neueste kumulative Update für dieses Service Pack anzuwenden. Sie müssen also keine älteren Versionen eines Service Packs installieren, bevor Sie das neueste Service Pack installieren. Verwenden Sie Tabelle 1 im folgenden Artikel, um weitere Informationen zum neuesten Service Pack und zum neuesten kumulativen Update zu erhalten.

Ermitteln der Version, Edition und Updatestufe von SQL Server und seinen Komponenten

Referenzmaterial

Informieren Sie sich über die Terminologie, die Microsoft zum Beschreiben von Softwareupdates verwendet.