Problembeschreibung
Die folgende Fehlermeldung wird angezeigt, wenn Sie die Optionen für Urlaubsantrag in Outlook 2003 oder Outlook 2007 auf allen Arbeitsstationen einrichten, einschließlich des Servers:
Es kann keine Verbindung zum Unternehmensportal hergestellt werden. Sie sind aufgrund eines Protokollfehlers, der sich auf die Verzeichnissicherheitseinstellungen für das virtuelle Verzeichnis des Business Portals möglicherweise bezogen hat, nicht berechtigt, eine Verbindung herzustellen. Diese Einstellungen sollten die authentifizierungsbeschäd Windows zulassen. Wenden Sie sich an Ihren Business Portal-Administrator.
Dieser Fehler tritt auf, wenn Sie versuchen, das Tool Outlook Vacation Request Add-In in Outlook über das Business Portal mit Microsoft Dynamics GP mit HRM Self Service Suite zu verbinden.
Ursache
Überprüfen Sie die Einstellungen für den Authentifizierungszugriff. Häufig verwendete Standardauthentifizierung Microsoft-Internetinformationsdienste (IIS)-Manager ist aktiviert und sollte deaktiviert werden.
Fehlerbehebung
Methode 1: Einstellungen in IIS-Manager 1. Erteilen Sie der Gruppe "Domänenbenutzer" für Ihre BP-Website mithilfe von Microsoft-Internetinformationsdienste (IIS) Berechtigungen, indem Sie die folgenden Schritte ausführen:
a. Melden Sie sich beim Business Portal-Webserver (BP) an, auf dem IIS ausgeführt wird. b. Öffnen Sie in der Systemsteuerungdie Verwaltungstools, und klicken Sie dann auf IIS-Manager.
c. Erweitern Sie im Fenster IIS-Manager die Erweiterung Websites.
d. Klicken Sie mit der rechten Maustaste auf Ihre BP-Website, und klicken Sie dann auf Berechtigungen.
e. Im Sicherheitsfenster sollte eine Gruppe "Benutzer" ähnlich wie "(XXXXX\Benutzer)Hinweis XXXXX ist ein Platzhalter für den Domänennamen".Wenn diese Gruppe nicht vorhanden ist, fügen Sie die Domänengruppe hinzu. 2. Gewähren Sie integrierte Windows für Ihre BP-Website über IIS, indem Sie die folgenden Schritte ausführen:
a. Melden Sie sich bei dem BP-Webserver an, auf dem IIS ausgeführt wird. b. Öffnen Sie in der Systemsteuerungdie Verwaltungstools, und klicken Sie dann auf IIS-Manager.
c. Erweitern Sie im Fenster IIS-Manager die Erweiterung Websites.
d. Klicken Sie mit der rechten Maustaste auf Die BP-Website, und klicken Sie dann auf Eigenschaften.
e. Klicken Sie auf die Registerkarte Verzeichnissicherheit.
f. Klicken Sie im Bereich Authentifizierungs- und Zugriffssteuerung auf Bearbeiten.
g. Klicken Sie im Bereich Authentifizierter Zugriff auf das Kontrollkästchen Windows integrierte Authentifizierung.
h. Stellen Sie im Bereich Authentifizierter Zugriff sicher, dass das Kontrollkästchen Standardauthentifizierung nicht markiert ist. ---- Zum Überprüfen der Standardauthentifizierung für IIS 7.0 verwenden Sie die folgenden Schritte: a. Navigieren Sie auf der Arbeitsstation, auf der Business Portal (BP) installiert ist, zu IIS Manager. Klicken Sie dazu auf Start, klicken Sie auf Systemsteuerung, klicken Sie auf Verwaltungstools, und doppelklicken Sie dann auf Internetinformationsdienste (IIS)-Manager. b. Klicken Sie im Abschnitt Verbindungen auf der linken Seite auf , um die entsprechende Verbindungswebsite zu erweitern.c. Klicken Sie, um Websites zu erweitern.d. Klicken Sie mit der rechten Maustaste auf Das Geschäftsportal (möglicherweise unter der SharePoint-Website), und klicken Sie dann auf Zur Ansicht der Features wechseln.e. In der Ansicht Features werden Abschnitte mit der Bezeichnung ASP.NET IIS angezeigt. Doppelklicken Sie im Abschnitt IIS auf Authentifizierung. f. Klicken Sie, um Standardauthentifizierung auszuwählen.g. Klicken Sie am rechten Rand unter Aktionen auf Deaktivieren. (Hinweis: Wenn nur "Aktivieren" aufgeführt ist, ist es bereits deaktiviert.) h. Schließen Sie die Fenster. ----- 3. IiS zurücksetzen. Klicken Sie dazu auf Start, klicken Sie auf Ausführen, geben Sie IISRESET in das Feld Öffnen ein, und klicken Sie dann zum Verarbeiten auf OK. 4. Testen Sie es erneut. Wenn Sie immer noch das gleiche Problem haben, versuchen andere Benutzer, über ihr Outlook-Profil auf das Fenster "Optionen für Urlaubsanfrage" zu zugreifen und zu sehen, ob sie darauf zugreifen können.HINWEIS: Stellen Sie sicher, dass Microsoft Outlook als MAPI-kompatibles E-Mail-System installiert ist. Wenn diese Methode nicht funktioniert, fahren Sie mit Methode 2 fort.Methode 2: Einstellungen in Internet Explorer 1. Klicken Sie in Internet Explorer auf Extras, klicken Sie auf Internetoptionen, und klicken Sie dann, um die Registerkarte Erweitert auszuwählen. Vergewissern Sie sich, dass im Abschnitt Sicherheit die Option Integrierte Windows Authentifizierung aktivieren markiert ist. 2. Fügen Sie die BP-URL zu den vertrauenswürdigen Websites hinzu.Methode 3: Überprüfen/testen Sie, ob Sie zu der URL navigieren können, die unter Optionen für Urlaubsantrag in Outlook 1 angezeigt wird. Nachdem das Add-In installiert wurde, öffnen Sie Outlook. Klicken Sie auf Extras, klicken Sie auf Optionen für Urlaubsanfrage, und klicken Sie dann auf die Registerkarte Verbindung. Notieren Sie sich die URL, die unten im Fenster aufgeführt ist. Dies ist der Pfad, zu dem Sie mit den folgenden Schritten navigieren müssen. Es folgt ein Beispiel für die URL: http://localhost/BusinessPortal/Applications/HRM/VacationRequestWebService.asmx (Hinweis: Wenn Sie einen Hostnamen eingegeben haben, ersetzt er "localhost" in dieser URL.) 2. Wechseln Sie zu dem Server, auf dem BP installiert ist. Klicken Sie auf Start, klicken Sie auf Verwaltung, und klicken Sie Internetinformationsdienste (IIS)-Manager.3. Klicken Sie, um die Datenbankverbindung am linken Rand zu erweitern.4. Klicken Sie zum Erweitern von Websites auf , um das Geschäftsportal zu erweitern, klicken Sie erneut, um das Geschäftsportal zu erweitern, klicken Sie auf Anwendungen, und klicken Sie dann auf den Ordner HRM. (Navigieren Sie im Grunde zu derselben URL, die Sie im Fenster Urlaubsanfrageoptionen sehen. Die Schritte bzw. der Speicherort, zu der/dem Sie navigieren möchten, unterscheiden sich möglicherweise von den in diesem Beispiel aufgeführten Schritten.) 5. Klicken Sie unten im Fenster auf Inhaltsansicht, um die Dateien im Ordner "HRM" anzuzeigen.6. Scrollen Sie nach unten, um "VacationRequestWebService.asmx" zu finden. Klicken Sie mit der rechten Maustaste darauf, und klicken Sie dann auf Durchsuchen. Ein VacationRequestWebService-Fenster sollte geöffnet werden. Es ist wichtig, dass hier das Webdienstfenster geöffnet wird. 7. Wenn das Webdienstfenster geöffnet wird, notieren Sie sich die URL oben auf der Seite. Die URL, die im Fenster Optionen für Urlaubsanfrage aufgeführt wird, sollte genau mit dieser URL übereinstimmen.