Problembeschreibung
In einer Microsoft Exchange Server 2016-Umgebung erleben Benutzer das folgende Verhalten, wenn ein FindItems -Vorgang in Exchange Web Services (EWS)-aufrufen durchgeführt wird:
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Der EWS-Aufruf schlägt mit folgendem Fehler fehl:
Nicht behandelte Ausnahme: Microsoft. Exchange. Webservices. Data. ServiceResponseException: ein interner Serverfehler ist aufgetreten. Der Vorgang ist fehlgeschlagen., es können keine Zeilen in einer Tabelle abgefragt werden.
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Bei den EWS-Protokollen in c:\Programme\Microsoft\Exchange Server\V15\Logging\Ews auf dem Rollen Server für Postfächer wird der folgende Fehler angezeigt:
ExceptionHandler_Execute = Microsoft. Exchange. Data. Storage. StoragePermanentException: Zeilen in einer Tabelle können nicht abgefragt werden. ---> Microsoft. MAPI. MapiExceptionMaxObjsExceeded: MapiExceptionMaxObjsExceeded: Tabellenzeilen können nicht abgefragt werden.
Ursache
In Exchange Server 2016 wurde eine Änderung der Anzahl der materialisierten Einschränkungen eingeführt, die in einem Postfach vorhanden sein können. Diese Änderung kann eine Situation auslösen, in der ein FindItems-Anruf eine neue materialisierte Suche im Postfach erstellen muss, dies aber nicht möglich ist, weil das Postfach bereits am Limit liegt.
Fehlerbehebung
Um das Problem zu beheben, installieren Sie Exchange Server 2016 Kumulatives Update 3 oder höher. In dem Szenario, das im Abschnitt "Problembeschreibung" beschrieben wird, wird die älteste materialisierte Suche nach der Installation dieses Updates veraltet sein. Daher kann eine neue Suche erstellt werden, ohne dass eine Ausnahme generiert wird.