Bei Microsoft anmelden
Melden Sie sich an, oder erstellen Sie ein Konto.
Hallo,
Wählen Sie ein anderes Konto aus.
Sie haben mehrere Konten.
Wählen Sie das Konto aus, mit dem Sie sich anmelden möchten.

Problembeschreibung

Nachdem Sie einen Absender abgeschlossen oder storniert haben, wird der Wert im Feld Status nicht in der Auftragsverwaltung in Microsoft Dynamics SL in geschlossen aktualisiert.

Hinweis Das Feld Status wird auf der Registerkarte Weitere Informationen auf dem Bildschirm " Absender (40.110.00) " angezeigt.  Darüber hinaus enthält der Bildschirm der Verlader-Update Protokollanzeige (40.460.00) keinen Eintrag für die Absender-ID. 

Ursache

Ursache 1

Die Einstellung für die Aktualisierung des Verladers verzögern ist falsch. Siehe Lösung 1.

Ursache 2

Die Einstellung für die Sleep-Zeit für den Prozess Manager ist zu klein. Siehe Lösung 2

Ursache 3 

Der Schritt "Verlader aktualisieren" auf der Registerkarte " Schritte " im Bildschirm " Auftragsarten" (40.200.00) ist falsch eingerichtet. Siehe Entschließung 3.

Ursache 4 

Die Auftragsart wurde auf der Registerkarte " Schritte " im Bildschirm " Auftragsarten" (40.200.00) geändert, bevor die vorhandenen Absender geschlossen wurden. Siehe Lösung 4.

Ursache 5 

Anpassungen wurden dem Bildschirm " Verlader (40.110.00) " hinzugefügt, der die Verarbeitung der Absenderdaten Sätze unterbrach. Siehe Lösung 5.

Ursache 6 

Ursache: 1 bis 5.  In diesem Fall tritt dieses Problem ungeachtet des Auftragstyps auf. Siehe Lösung 6 oder Auflösung 7.

Fehlerbehebung

Lösung 1

Überprüfen Sie, ob die Einstellung zum verzögern des Updates für den Absender nicht zu groß ist. Gehen Sie dazu wie folgt vor:

  1. Klicken Sie im Menü Modul auf Auftragsverwaltung.

  2. Klicken Sie im Bereich Auftragsverwaltung unter Setupauf Auftrags Verwaltungseinrichtung .

  3. Stellen Sie auf der Registerkarte anderer sicher, dass der Wert im Feld Verzögerung des Verladers aktualisieren (Minuten) nicht zu groß ist. Hinweis Wenn der Wert für die Verzögerung des Verladers aktualisieren (Minuten) auf 30festgelegt ist, wird der Absender erst 30 Minuten nach Abschluss des Absender Eintrags geschlossen.

Lösung 2

Erhöhen Sie den Ruhezustand für den Prozess Manager-Prozess. Gehen Sie dazu wie folgt vor:

  1. Klicken Sie im Menü Modul auf Auftragsverwaltung.

  2. Klicken Sie im Bereich Auftragsverwaltung unter Setupauf Auftrags Verwaltungseinrichtung .

  3. Geben Sie auf der Registerkarte andere im Feld Prozess Manager-Sleep-Zeit (Sekunden)15 ein, wenn der Wert im Feld kleiner als 15 ist.

Lösung 3

Korrigieren Sie den Status für den Schritt im Auftragstyp. Gehen Sie dazu wie folgt vor:

  1. Klicken Sie in der Liste Module auf Auftragsverwaltung.

  2. Klicken Sie im Bereich Auftragsverwaltung unter Wartungauf Auftragstypen .

  3. Geben Sie im Feld Auftragstyp die zu ändernde Auftragstyp-ID ein.

  4. Klicken Sie auf der Registerkarte Schritte im Status für den Schritt "Verlader aktualisieren" auf erforderlich .

  5. Klicken Sie auf Speichern. Schließen Sie dann den Bildschirm Bestelltypen (40.200.00) .

Auflösung 4

Stornieren der Absender und der zugehörigen Verkaufsaufträge Gehen Sie dazu wie folgt vor:

  1. Klicken Sie in der Liste Module auf Auftragsverwaltung.

  2. Klicken Sie im Bereich Auftragsverwaltung unter Eingabe auf Versandbestätigung.

  3. Geben Sie im Feld Absender-ID die ID des Absenders ein, den Sie stornieren möchten.

  4. Klicken Sie, um die folgenden Kontrollkästchen zu aktivieren:

    • Absender stornieren 

    • Bestellung stornieren 

  5. Klicken Sie auf Fertig stellen. Schließen Sie dann das Bildschirm "Versandbestätigung" (40.117.00) .

Auflösung 5

Entfernen von Anpassungen für den Bildschirm " Absender" (40.110.00) . Gehen Sie dazu wie folgt vor:

  1. Schließen Sie alle Bildschirme mit Ausnahme des 40.110.00- Bildschirms.

  2. Klicken Sie im Menü Anpassen auf Modus anpassen.

  3. Klicken Sie im Menü Anpassen auf Änderungen für den Bildschirm entfernen.

  4. Klicken Sie auf Jaund dann auf OK.

  5. Schließen Sie den Bildschirm " Verlader (40.110.00) ". Öffnen Sie dann den Bildschirm.

Auflösung 6

Ändern Sie die Reihenfolge der Absender in eine Bestellung, die vom Prozess Manager erkannt wird. Gehen Sie hierzu wie folgt vor. Hinweis Bevor Sie die Anweisungen in diesem Verfahren befolgen, stellen Sie sicher, dass Sie über eine vollständige Sicherungskopie der Datenbank verfügen, die Sie wiederherstellen können, wenn ein Problem auftritt.

  1. Klicken Sie im Bildschirm Prozess-Manager (40.400.00) auf Beenden.

  2. Führen Sie mit Microsoft SQL Query Analyzer oder Microsoft SQL Server Management Studio die entsprechende Anweisung für die Anwendungsdatenbank aus.

    • Microsoft SQL Server 7,0

      Wählen Sie "execADG_Release_For_Update" + RTrim (CpnyID) + "", "", "+ RTrim (ShipperID) +" "" aus SOSHIPHEADER WHERE NextFunctionID = "4043000" und NextFunctionClass = "0200" aus.

    • Microsoft SQL Server 2000 oder Microsoft SQL Server 2005 oder Microsoft SQL Server 2008

      Legen Sie QUOTED_IDENTIFIEROFF Select "Exec ADG_Release_For_Update '" + RTrim (CpnyID) + "", "", "+ RTrim (ShipperID) +" "" aus SOSHIPHEADER whereNextFunctionID = "4043000" und NextFunctionClass = "0200"

  3. Kopieren Sie die Ergebnisse der Anweisung in ein neues Fenster. Schließen Sie Spaltenüberschriften oder Zeilenanzahl Zeilen aus. Führen Sie dann die neue Anweisung aus, um die aufgelisteten Absender erneut in die Warteschlange zu stellen.Hinweis Die folgende Anweisung zeigt ein Beispiel für die Ergebnisse, die Sie kopieren möchten.

    Exec ADG_Release_For_Update ' 0060 ', ' ', es 0009868 '

  4. Klicken Sie im Bildschirm Prozess-Manager (40.400.00) auf Start.

Auflösung 7

Kündigen Sie den Absender. Gehen Sie dazu wie folgt vor:

  1. Klicken Sie in der Liste Module auf Auftragsverwaltung.

  2. Klicken Sie im Bereich Auftragsverwaltung unter Eingabeauf Absender .

  3. Aktivieren Sie auf der Registerkarte Weitere Informationen das Kontrollkästchen storniert , und klicken Sie dann auf Fertig stellen.

Benötigen Sie weitere Hilfe?

Möchten Sie weitere Optionen?

Erkunden Sie die Abonnementvorteile, durchsuchen Sie Trainingskurse, erfahren Sie, wie Sie Ihr Gerät schützen und vieles mehr.

In den Communities können Sie Fragen stellen und beantworten, Feedback geben und von Experten mit umfassendem Wissen hören.

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Sprachqualität?
Was hat Ihre Erfahrung beeinflusst?
Wenn Sie auf "Absenden" klicken, wird Ihr Feedback zur Verbesserung von Produkten und Diensten von Microsoft verwendet. Ihr IT-Administrator kann diese Daten sammeln. Datenschutzbestimmungen.

Vielen Dank für Ihr Feedback!

×