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Problembeschreibung

Wenn Sie versuchen, neue Benutzer zum Business Portal hinzuzufügen, wird die Domäne möglicherweise nicht aufgeführt.

Ursache

Business Portal kann nicht auf den Domänencontroller zugreifen.

Fehlerbehebung

Stellen Sie sicher, dass Sie einen Ping an den Domänencontroller für die Domäne senden können, die nicht im Unternehmensportal aufgeführt ist. Verwenden Sie den Befehl ping auf dem Server, auf dem das Unternehmensportal ausgeführt wird. Stellen Sie sicher, dass Sie pingen können, indem Sie den Net Ganzzahl-Namen verwenden.

Führen Sie zum Verwenden des Befehls ping die folgenden Schritte auf dem Server aus, auf dem das Geschäftsportal ausgeführt wird:

  1. Klicken Sie auf Start, klicken Sie auf Ausführen,geben Sie cmd ein, und klicken Sie dann auf OK.

  2. Führen Sie die folgenden Schritte aus, um einen Ping nach Name zu senden:

    1. Geben Sie den folgenden Befehl ein:

      ping SERVERNAMENote ServerNAME durch den Namen des Domänencontrollers ersetzen.

    2. Drücken Sie die EINGABETASTE.

Problemumgehung 

Wenn Sie Microsoft Business Portal 2.0, Microsoft Business Portal 2.5 oder Microsoft Business Portal 2.5 Feature Pack (Business Portal 2.7) ausführen, verwenden Sie Methode 1. Wenn Sie Business Portal 3.0 ausführen, verwenden Sie Methode 2.

Methode 1: Verwenden Sie das Hilfsprogramm "Security Setup", um die Benutzer aus der Domäne hinzuzufügen, die nicht im Unternehmensportal aufgeführt ist.

Führen Sie die folgenden Schritte aus, um das Security Setup-Hilfsprogramm ausführen:

  1. Suchen Sie den Ordner "bin" der Website, auf der Business Portal installiert ist. Dieses Verzeichnis befindet sich standardmäßig unter "C:\Inetpub\wwwroot\bin".

  2. Doppelklicken Sie auf SecuritySetupUtility.exe.
    Hinweis Um dieses Hilfsprogramm ausführen zu können, müssen Sie sich beim Server als die Person anmelden, die Business Portal installiert hat.

Methode 2: Manuelles Hinzufügen eines Eintrags zur BusinessFramework.config Datei

  1. Suchen Windows im Explorer die Datei BusinessFramework.config Datei. Diese Datei befindet sich standardmäßig unter "C:\Inetpub\wwwroot\bin".

  2. Öffnen Sie die Datei mithilfe eines Texteditors wie Editor.

  3. Fügen Sie der Datei den folgenden Eintrag hinzu:

    <Microsoft.BusinessFramework.Portal.Administration.ActiveDirectoryReaderConfig>
    <useAlternativeDomainLookup type="Boolean" value="True”/>
    </Microsoft.BusinessFramework.Portal.Administration.ActiveDirectoryReaderConfig>


    Hier ist ein Abschnitt, wie die Datei nach dem Hinzufügen des Eintrags aussehen soll:

    <Microsoft.BusinessFramework.Security.SecureApplicationDirectoryList>
    <directoryList type="String" value="/sites/BusinessPortal/|/BusinessPortal/"/>
    </Microsoft.BusinessFramework.Security.SecureApplicationDirectoryList>

    <Microsoft.BusinessFramework.Portal.Administration.ActiveDirectoryReaderConfig>
    <useAlternativeDomainLookup type="Boolean" value="True"/>
    </Microsoft.BusinessFramework.Portal.Administration.ActiveDirectoryReaderConfig>

Weitere Informationen

Schritte zum Reproduzieren des Problems

  1. Start Business Portal.

  2. Klicken Sie auf Einstellungen, klicken Sie auf Benutzer und Berechtigungen , klicken Sie auf Unternehmensportalbenutzerverwalten , und klicken Sie dann auf Neue Benutzer hinzufügen.

  3. Klicken Sie im Fenster Benutzer hinzufügen auf Weiter.

In der Liste Domäne ist keine Domäne aufgeführt, oder einige Domänen sind nicht aufgeführt.

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