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Problembeschreibung

Stellen Sie sich folgendes Szenario vor:

  • In der Microsoft Visual Studio 2010 arbeiten Sie in einer Anwendung.

  • Sie installieren Visual Studio Erweiterung von Drittanbietern wie DevExpress Visual Studio Produktivitätstools in der.

  • Schließen Sie die Visual Studio 2010 Development Environment.

In diesem Szenario kann die Anwendung abstürzen, wenn Sie versuchen, die Anwendung zu schließen, schließen die Development Environment. Sie erhalten dann einen Dr. Watson-Fehler mit den folgenden Informationen:

Ereignisname: CLR20r3Application Name: devenv.exeApplication Version: < 10.0.30319.1 - 10.0.65535.9999 > Ausnahmecode: rxoejih3rskjez4xxwpxudkcppwjodng

Hinweis Gehen Sie folgendermaßen vor, um Dr. Watson Fehlerinformationen zu überprüfen:

  1. Klicken Sie auf Start, und geben Sie Problemberichte in das Suchfeld .

  2. Wenn der Computer Windows Vista ausgeführt wird, klicken Sie auf Problemverlauf anzeigen. Wenn der Computer Windows 7 ausgeführt wird, klicken Sie auf Alle Problemberichte anzeigen.

  3. Doppelklicken Sie im Fenster Problemberichte und Lösungen auf das Problem, das auftreten.

  4. Hier werden die Informationen im Abschnitt Problem Signatur .

Hinweis In diesem Artikel beschriebenen Methoden anwenden, Windows Vista und Windows 7. Online nach Methoden, mit denen andere Betriebssysteme suchen.

Ursache

Dieses Problem kann auftreten, wenn eine Fremdanbieter-Erweiterung installieren, die fälschlicherweise versucht, die Benutzeroberfläche der Development Environment zugreifen, nachdem die Visual Studio-Dienste veröffentlicht wurden. Ältere Versionen von DevExpress Visual Studio Produktivitätstools können dieses Problem verursachen.

Lösung

Ein unterstützter Hotfix ist von Microsoft erhältlich. Dieser Hotfix soll nur der Behebung des Problems dienen, das in diesem Artikel beschrieben wird. Verwenden Sie diesen Hotfix nur auf Systemen, bei denen dieses spezielle Problem auftritt. Dieser Hotfix sollte weiteren Tests unterzogen werden. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir sie, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält. Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten für zusätzliche Supportfragen und Probleme, die nicht diesem speziellen Hotfix zugeordnet werden können. Für eine vollständige Liste der Telefonnummern von Microsoft Customer Service and Support oder für Erstellung eine separate Serviceanfrage, fahren Sie auf der folgenden Microsoft-Website fort:

http://support.microsoft.com/contactus/?ws=support

Informationen zum Download

Um diesen Hotfix aus der MSDN Code Gallery herunterzuladen, besuchen Sie die folgende Microsoft-Website:

http://code.msdn.microsoft.com/KB2275326Hinweis Der MSDN Code Gallery zeigt die Sprachen an, für die der Hotfix verfügbar ist. Die aufgeführten Sprache nicht angezeigt wird, ist der Code Gallery-Ressourcenseite nicht für diese Sprache steht. Darüber hinaus können Sie diesen Hotfix-Rollup von Microsoft Connect-Website herunterladen:

Visual Studio und.NET Framework: KB2275326Nachdem Sie den Hotfix installieren, installieren Sie die neueste Version der Visual Studio-Erweiterung von Drittanbietern. Zum Installieren der neuesten Version der Erweiterung DevExpress finden Sie auf der folgenden Website:

Visual Studio ProduktivitätstoolsDie Kontaktinformationen zu den in diesem Artikel erwähnten Drittanbietern sollen Ihnen helfen, den benötigten technischen Support zu finden. Diese Kontaktinformationen können ohne vorherige Ankündigung geändert werden. Sie werden von Microsoft ohne jede Gewähr weitergegeben.

Voraussetzungen

Für die Installation dieses Hotfixpakets gibt es keine Voraussetzungen.

Neustartanforderung

Sie müssen keinen Neustart des Computers, nachdem Sie dieses Hotfixpaket anwenden.

Ersetzte Hotfixes

Dieses Hotfix-Paket ersetzt kein zuvor veröffentlichtes Hotfix-Paket.

Dateiinformationen

Englisch (USA) Version des Hotfix-Pakets verwendet ein Microsoft Windows Installer-Paket, das Hotfixpaket installieren. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) in der folgenden Tabelle aufgeführt. Wenn Sie die Dateiinformationen anzeigen, wird das Datum in Ortszeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu finden, verwenden Sie die Registerkarte Zeitzone unter Datum und Uhrzeit in der Systemsteuerung.

Dateiname

Dateiversion

Dateigröße

Datum

Uhrzeit

Plattform

Microsoft.visualstudio.shell.10.0.dll

10.0.30319.341

995,712

30-Jul-2010

06:17

x86

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.Die in diesem Artikel genannten Drittanbieterprodukte stammen von Herstellern, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.

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