Symptom
Die Zeitachse in UCI zeigt nicht den folgenden Fehler an: "Datensätze konnten aufgrund eines unerwarteten Fehlers nicht geladen werden". Dies sieht wie folgt aus:
Wenn Sie die Entwicklertools öffnen und die Seite aktualisieren, wird auf der Registerkarte Netzwerk eine "Batch"-Anforderung angezeigt, die einen GET-Aufruf von /api/data/v9.0/activitypointers/Microsoft.Dynamics.CRM.RetrieveTimelineWallRecordshas enthält, der mit 400 – Ungültige Anforderung fehlgeschlagen ist (die fehlgeschlagene Anforderung wird rot angezeigt) und diese Meldung:
{"error":{"code":"0x8004430d","message":"Number of link entities in query exceeded maximum limit.","innererror":{"message":"Number of link entities in query exceeded maximum limit."
Ursache
Dies ist eine Einschränkung der Zeitachsensteuerung, die unser Team gerade adressiert. Es gibt eine QueryLinkEntityLimit-Einstellung, und das Überschreiten dieses Grenzwerts führt zu dem Fehler. Linkentitäten stammen sowohl aus sofort einsatzbereiten Aktivitäten als auch aus benutzerdefinierten Aktivitäten.
Kunden können diesem Aufruf zusätzliche Linkentitäten hinzufügen, indem sie die folgende Anpassung der Zeitachse vornehmen: Verwenden von Kartenformularen für benutzerdefinierte Aktivitäten.
Risikominderung
Entschärfung 1
Sie können sich an den Kundensupport wenden, die Details zu diesem Fehler angeben und ihn bitten, die QueryLinkEntityLimit-Einstellung für Ihre Organisation zu erhöhen.
Hinweis: Diese Einstellung wirkt sich auf alle Aufrufe in der Organisation aus, die Über Linkentitäten verfügen, und kann die Leistung für Anrufe mit sehr hoher Anzahl von Linkentitäten beeinträchtigen. Der Leistungstreffer sollte jedoch nicht signifikant sein, wenn wir den Grenzwert um eine einzelne Ziffer erhöhen.
Entschärfung 2
Wenn der Kunde benutzerdefinierte Aktivitäten erstellt hat und dafür Kartenformulare verwendet, kann er die Kartenformulare deaktivieren, um die Anzahl der Linkentitäten in der Batchanforderung zu reduzieren. Dies kann erreicht werden, indem Sie die folgenden Schritte ausführen:
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Wechseln Sie zu den Zeitachseneinstellungen für UCI (doppelklicken Sie im Formular-Editor der Entität mit Issues auf den Zeitachsenabschnitt, und die Einstellungen sollten geöffnet werden).
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Suchen Sie auf der Registerkarte Aktivitäten im Abschnitt Zusätzliche Optionen nach allen benutzerdefinierten Aktivitäten, die über ein Kartenformular verfügen.
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Ändern Sie die Auswahl in "Kartenformular auswählen". Dadurch wird das Kartenformular deaktiviert.
Es ist auch möglich, keine benutzerdefinierte Aktivität in die Zeitachse einzuschließen, wenn dies nicht nützlich ist:
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Wechseln Sie zu den Zeitachseneinstellungen für UCI.
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Wählen Sie auf der Registerkarte Aktivitäten im Abschnitt Filtern nach anstelle von "Alle anzeigen" die Option "Ausgewählt anzeigen" aus.
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Heben Sie die Auswahl der benutzerdefinierten Aktivitäten auf, die aus der Zeitachse entfernt werden sollen.