Problembeschreibung
In einer Umgebung mit Microsoft Exchange Server 2013 versuchen Sie eDiscovery durch Exchange Administration Center (BK) alle Postfächer oder einige Verteilergruppen verwenden. Wenn Sie das Kontrollkästchen "Alle Postfächer durchsuchen" ausgewählt haben, schlägt die Suche fehl und die folgende Ausnahme:
InfoWorker.Common Suche MailboxSearchServer.Start Fehler System.ArgumentNullException: Wert darf nicht null sein.
----Parametername: Id
----am Microsoft.Exchange.EDiscovery.MailboxSearch.SourceMailbox... Ctor (String ID-Zeichenfolge Name String LegacyDN Uri ServiceEndpoint Zeichenfolge QueryFilter)
----am Microsoft.Exchange.EDiscovery.MailboxSearch.MailboxSearchConfigurationProvider.ValidateAndAddToFinalSourceMailboxes (Zeichenfolge einfach StorageMiniRecipient Empfänger IList'1 IList'1 VersionSkippedMailboxes IList'1 RbacDeniedMailboxes Dictionary'2 CrossPremiseMailboxes FinalSourceMailboxes)
----am Microsoft.Exchange.EDiscovery.MailboxSearch.MailboxSearchConfigurationProvider.ValidateAndGetFinalSourceMailboxes (Zeichenfolge einfach IList'1 SourceMailboxes IList'1 NotFoundMailboxes IList'1 VersionSkippedMailboxes IList'1 RbacDeniedMailboxes IList'1 CrossPremiseFailedMailboxes IDictionary'2 CrossPremiseUrls)
----am Microsoft.Exchange.EDiscovery.MailboxSearch.MailboxSearchWorkItem.PreStart (String, ExecutingUserId, IMailboxSearchTask, SearchTask)
----am Microsoft.Exchange.EDiscovery.MailboxSearch.MailboxSearchServer.AddSearchToWorkItemQueue (Such Such Zeichenfolge OwnerId) "
Ursache
Dieses Problem tritt auf, wenn Mailcontact oder Mailuser-Objekte in der Abfrage enthalten sind.
Problemlösung
Um dieses Problem zu beheben, installieren Sie kumulative Update 12 für Exchange Server 2013 oder einem späteren kumulativen Updates für Exchange Server 2013.
Status
Microsoft hat bestätigt, dass es sich um ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt „Eigenschaften“ aufgeführt sind.
Referenzen
Informationen Sie zur Terminologie , die Microsoft-Softwareupdates verwendet.