Symptome
Nachdem Sie den Hybridkonfigurations-Assistenten (HCW) über exchange Admin Center (EAC) installiert haben oder den Assistenten über https://aka.ms/HybridWizard heruntergeladen haben, werden Sie aufgefordert, die ClickOnce-Anwendungsdatei zu öffnen. Der Befehl Öffnen öffnet jedoch kein Fenster. Wenn dieses Problem auftritt, erhalten Sie keine Fehlermeldung.
Ursache
Die Anwendungsdateierweiterung .application , die von ClickOnce-Paketen verwendet wird, ist nicht mehr mit der ClickOnce Application Deployment Support Library verknüpft. Diese Änderung verursacht eine fehlende oder falsch konfigurierte Handlerbedingung, die verhindert, dass Windows das HCW-ClickOnce-Paket öffnet.
Lösung
Zuordnen Des Anwendungsdateityps zur Unterstützungsbibliothek für die ClickOnce-Anwendungsbereitstellung neu, und installieren Oder öffnen Sie den HCW erneut.
-
Schließen Sie alle geöffneten Browserfenster.
-
Erstellen Sie eine leere Textdatei auf dem Server, und nennen Sie sie Temp.application.
-
Klicken Sie mit der rechten Maustaste auf Temp.applicaton, und wählen Sie dann Mit öffnen > Wählen Sie eine andere App aus.
-
Wählen Sie Editor aus, aktivieren Sie das Kontrollkästchen Diese App immer verwenden , und wählen Sie dann OK aus.
-
Wiederholen Sie Schritt 3, wählen Sie ClickOnce Application Deployment Support Library aus, und verwenden Sie diese App immer, und legen Sie sie als Standardanwendung fest.
-
Löschen Sie Temp.application, öffnen Sie Ihren Browser erneut, und versuchen Sie dann erneut, den HCW über https://aka.ms/HybridWizard zu öffnen. Das HCW sollte nun wie erwartet installiert und geöffnet werden.