Export-ModernPublicFolderStatistics.ps1 funktioniert in Exchange Server 2019 nicht

Problembeschreibung

Das Skript Export-ModernPublicFolderStatistics.ps1 funktioniert in Microsoft Exchange Server 2019 nicht, und Es wird eine Fehlermeldung angezeigt, die der folgenden ähnelt:

2222.png

Problemumgehung

Um dieses Problem zu umgehen, aktualisieren Sie das Skript mit folgenden Änderungen:

$script:Exchange16MajorVersion = 15;

$script:Exchange16MinorVersion = 1;

$script:Exchange16CUBuild = 669;

$script:Exchange17MajorVersion = 15;

$script:Exchange17MinorVersion = 2;

$script:Exchange17CUBuild = 196;

Und

$hasMinE16Version = (($version. Major -eq $script:Exchange16MajorVersion) -und

($version. Minor -eq $script:Exchange16MinorVersion) -und

($version. Build -ge $script:Exchange16CUBuild));

$hasMinE17Version = (($version. Major -eq $script:Exchange17MajorVersion) -und

($version. Minor -eq $script:Exchange17MinorVersion) -und

($version. Build -ge $script:Exchange17CUBuild));

if (!$hasMinE15Version -und !$hasMinE16Version -und !$hasMinE17Version)

{

$failedServers += $server.Fqdn;}

Informationsquellen

Erfahren Sie mehr über die Terminologie, die Microsoft zum Beschreiben von Softwareupdates verwendet.

Weitere Informationen

Microsoft hat dieses Problem erkannt und wird weitere Informationen in diesem Artikel veröffentlichen, wenn es verfügbar wird.

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Insider beitreten

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×