Problembeschreibung
Wenn Sie versuchen, ein Postfach mithilfe von New-MailboxExportRequest oder New-MailboxImportRequest in Exchange Server 2010 mit Service Pack 1 oder einer höheren Version zu exportieren oder zu importieren, kann für die Anforderung ein Timeout auftreten, und Möglicherweise wird die folgende Fehlermeldung angezeigt:
[PS] New-MailboxExportRequest -Mailbox "<mailbox_name>" -FilePath \\<server_name>\<share>\<file_name>.pst
Beim Aufruf von "net.tcp://<server_name>/Microsoft.Exchange.MailboxReplicationService <server_name> (14.1.218.11 caps:07)" wurde ein Timeout ausgeführt. Fehlerdetails: Dieser an net.tcp://<server_name>/Microsoft.Exchange.MailboxReplicationService gesendete Anforderungsvorgang hat innerhalb des konfigurierten Timeouts (00:01:00) keine Antwort empfangen. Die diesem Vorgang zugeordnete Zeit war möglicherweise Teil eines längeren Timeouts. Dies kann daran zurückzuführen sein, dass der Dienst den Vorgang noch verarbeitet oder weil der Dienst keine Antwortnachricht senden konnte. Erwägen Sie, das Vorgangstimeout zu erhöhen (indem Sie den Kanal/Proxy in IContextChannel umwandeln und die OperationTimeout-Eigenschaft festlegen), und stellen Sie sicher, dass der Dienst eine Verbindung mit dem Client herstellen kann. + CategoryInfo : NotSpecified: (0:Int32) [New-MailboxExportRequest], TimeoutErrorTransientException + FullyQualifiedErrorId : 59EDFA88,Microsoft.Exchange.Management.RecipientTasks.NewMailboxExportRequest
Ursache
Dieses Problem kann auftreten, wenn ein Clientzugriffsarray eingerichtet wurde und ein Lastenausgleich verwendet wird. Wenn der Exchange-Server versucht, sich bei dem Postfach anzumelden, für das der Import/Export angefordert wurde, stellt der Server eine Verbindung mit dem MoMT-Endpunkt (RPC-Clientzugriffsserver) für die Datenbank her, bei der es sich in den meisten Fällen um den CAS-Arraynamen handelt. Wenn der Lastenausgleich fälschlicherweise so konfiguriert ist, dass Verbindungen von den Exchange-Servern mit der VIP aktiviert werden, in die das CAS-Array aufgelöst wird, führt dies dazu, dass vom Lastenausgleich zurückgesetzt wird, was zu den unter "Symptome" aufgeführten Timeoutfehlern führt.
Lösung
Stellen Sie sicher, dass die Exchange-Server als Clients eine Verbindung mit dem Lastenausgleich herstellen können.Darüber hinaus wurden die folgenden Problemumgehungen dokumentiert, um das Übermitteln der Verschiebungsanforderung zu ermöglichen. Diese Problemumgehungen können implementiert werden, wenn die Clientkonnektivität zwischen den Exchange-Servern und dem Lastenausgleich nicht aktiviert oder nicht möglich ist.
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Sie können den Wert von RPCClientAccessServer für die Datenbank ändern, die das Postfach enthält, das Sie importieren oder exportieren möchten, sodass er auf einen bestimmten CAS-Server verweist, anstatt auf das CAS-Array zu verweisen, das den Lastenausgleich verwendet. Dies ist eine dynamische Einstellung, die bei Bedarf geändert werden kann.
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Sie können den Schalter -MRSServer im Cmdlet New-MailboxExportRequest oder New-MailboxImportRequest verwenden und einen CAS-Server angeben, der nicht Teil des CAS-Arrays ist.
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Sie können der Datei Hosts auf mindestens einem CAS-Server einen Eintrag hinzufügen, der den CAS-Arraynamen in den localhost auflöst.
Weitere Informationen
Wenn eine Postfachimport- oder -exportanforderung übermittelt wird, gibt es mehrere Schritte für diesen Prozess. Insgesamt ist es dem Prozess der Verschiebungsanforderung sehr ähnlich. Der grundlegende Prozess umfasst die folgenden Schritte:
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Der Exchange-Server, mit dem Ihre Remote PowerShell-Sitzung verbunden ist, erstellt die Export-/Importanforderung. Im Rahmen der Überprüfung, die während der Erstellungsphase ausgeführt wird, stellt dieser Exchange-Server eine Verbindung mit dem MoMT-Endpunkt her und versucht, sich (über MAPI.Net) bei dem Postfach anzumelden, in das Sie exportieren oder importieren möchten. Wenn die Überprüfung erfolgreich ist, wird eine spezielle FAI-Nachricht in das Systempostfach der Datenbank eingefügt, die das zu exportierende oder zu importierende Postfach enthält. Die Anforderung wird in die Warteschlange status eingefügt.Hinweis Dies ist der Schritt, bei dem der Fehler wie oben beschrieben fehlschlägt, sodass die Anforderung nie erstellt und nie in das Systempostfach eingefügt wird.
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Alle MRS-Instanzen innerhalb desselben Active Directory-Standorts überprüfen dieses Postfach in regelmäßigen Abständen. Wenn im Befehl kein MRSServer angegeben ist, wird einer nach dem Zufallsprinzip ausgewählt. Wenn im Befehl ein bestimmter MRSServer angegeben ist, wird dieser MRS-instance verwendet.
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MRS beginnt mit dem Export (oder Import) und ändert die Anforderung nach Abschluss in status "Abgeschlossen".
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Optional kann die Export- oder Importanforderung dann von einem Administrator gelöscht werden.
Weitere Informationen zu Import- und Exportanforderungen finden Sie im folgenden TechNet-Artikel: