Problembeschreibung

Wenn Sie das Business Portal in Microsoft Dynamics GP oder in Microsoft Dynamics SL auf einer Arbeitsstation starten, erhalten Sie die folgende Fehlermeldung:

Fehler: Dienstprinzipalname (SPN) für benutzer 'domain\user' wird in Active Directory nicht gefunden

Ursache

Dieses Problem tritt auf, wenn die folgenden Bedingungen zutreffen:

  • Der virtuelle Server wird in der SharePoint erweitert.

  • Kerberos-Authentifizierung ist ausgewählt.

  • Der Active Directory-Verzeichnisdienst ist nicht für die Verwendung der Kerberos-Authentifizierung konfiguriert.

Fehlerbehebung

Um dieses Problem zu beheben, verwenden Sie ntLM-Authentifizierung anstelle der Kerberos-Authentifizierung.Hinweis Wenn Sie Kerberos-Authentifizierung verwenden müssen, besuchen Sie die folgende Microsoft-Website, um weitere Informationen zu erhalten:

http://www.microsoft.com/windowsserver2003/technologies/security/kerberos/default.mspx Führen Sie die folgenden Schritte aus, um die NTLM-Authentifizierung zu aktivieren:

  1. Klicken Sie auf dem Server, auf dem Microsoft-Internetinformationsdienste (IIS) ausgeführt wird, auf Start, klicken Sie auf Ausführen,geben Sie cmd ein, und klicken Sie dann auf OK.

  2. Geben Sie an der Eingabeaufforderung folgenden Befehl ein, und drücken Sie die EINGABETASTE:

    cd Drive:\inetpub\adminscriptsNote Ersetzen Sie das Laufwerk durch den Namen der Festplatte, auf der Windows Server 2003 installiert ist.

  3. Geben Sie an der Eingabeaufforderung folgenden Befehl ein, und drücken Sie die EINGABETASTE:

    cscript adsutil.vbs get w3svc/xx/NTAuthenticationProvidersNote Replace xx durch die virtuelle Server-ID-Nummer. Führen Sie die folgenden Schritte aus, um die Nummer der virtuellen Server-ID zu ermitteln:

    1. Klicken Sie auf dem Server, auf dem IIS ausgeführt wird, auf Start, zeigen Sie auf Alle Programme,zeigen Sie auf Verwaltungstools ,und klicken Sie dann auf Internetinformationsdienste (IIS)-Manager.

    2. Erweitern Sie den Computernamen, erweitern Sie Websites, klicken Sie mit der rechten Maustaste auf die Website, auf der Sie das Geschäftsportal installiert haben, und klicken Sie dann auf Eigenschaften.

    3. Klicken Sie auf die Registerkarte Website, und klicken Sie dann neben dem Feld Aktives Protokollformat auf Eigenschaften.

    4. Notieren Sie sich den Pfad und Dateinamen der LOG-Datei. Pfad und Dateiname ähneln folgendem:

      W3SVCxx\exyymmdd.logIn diesem Pfad stellt xx die virtuelle Server-ID dar.

  4. Zum Aktivieren der NTLM-Authentifizierung auf dem virtuellen Server geben Sie den folgenden Befehl an der Eingabeaufforderung ein, und drücken Sie dann die EINGABETASTE:

    cscript adsutil.vbs set w3svc/xx/NTAuthenticationProviders "NTLM"Note Replace xx durch die virtuelle Server-ID number, die Sie sich in Schritt 3 notiert haben.

  5. Starten Sie IIS neu. Führen Sie dazu die folgenden Schritte aus:

    1. Klicken Sie auf Start, klicken Sie auf Ausführen,geben Sie cmd ein, und klicken Sie dann auf OK.

    2. Geben Sie an der Eingabeaufforderung iisreset ein, und drücken Sie dann die EINGABETASTE.

    3. Geben Sie an der Eingabeaufforderung exit ein, und drücken Sie die EINGABETASTE.

  6. Starten Sie Microsoft Internet Explorer auf einer Arbeitsstation, und geben Sie dann die folgende URL in die Adressleiste ein:

    http://xx/sites/businessportalNote Replace xx durch den Namen des Servers.

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