Problembeschreibung
Wenn Sie versuchen, den Microsoft Dynamics AX 4.0-Client zu starten, wird die folgende Fehlermeldung angezeigt:
Verbindung konnte nicht herstellen
Ursache
Dieses Problem kann eine der folgenden Ursachen haben:
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Der AOS-Dienst (Application Object Server) wird nicht ausgeführt. Weitere Informationen finden Sie unter Auflösung 1 im Abschnitt "Auflösung".
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Der Microsoft Dynamics AX-Client ist nicht für die Verwendung des richtigen TCP/IP-Ports konfiguriert. Weitere Informationen finden Sie unter Auflösung 2 im Abschnitt "Auflösung".
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Die Version des AOS-Diensts passt nicht zur Version des Microsoft Dynamics AX-Clients. Weitere Informationen finden Sie unter Auflösung 3 im Abschnitt "Auflösung".
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Die Clientarbeitsstation hat keinen Netzwerkzugriff. Oder die Clientarbeitsstation kann keine Verbindung mit dem AOS-Server herstellen. Weitere Informationen finden Sie unter Auflösung 4 im Abschnitt "Auflösung".
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Der Microsoft Dynamics AX-Client ist mit einer Firewall oder mehreren Domänen verbunden. Weitere Informationen finden Sie unter Auflösung 5 im Abschnitt "Auflösung".
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Die lokale Richtlinie gewährt den AOS-Clients im gleichen Netzwerk nicht das Recht "Zugriff auf diesen Computer über das Netzwerk". Weitere Informationen finden Sie unter Auflösung 6 im Abschnitt "Auflösung".
Fehlerbehebung
Um dieses Problem zu beheben, verwenden Sie die entsprechende Lösung.
Lösung 1
Um dieses Problem zu beheben, starten Sie den AOS-Dienst. Gehen Sie zu diesem Zweck folgendermaßen vor:
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Klicken Sie auf Start, zeigen Sie auf Alle Programme,zeigen Sie auf Verwaltungstools, und klicken Sie dann auf Dienste.
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Suchen Sie den Microsoft Dynamics AOS-Dienst (Application Object Server).
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Wenn der Dienst nicht ausgeführt wird, klicken Sie mit der rechten Maustaste auf den Dienst, und klicken Sie dann auf Starten.Hinweis Der AOS-Dienstname verwendet das folgende Format:
Dynamics Server$ instance-number AOS-instance-name
Lösung 2
Um dieses Problem zu beheben, stellen Sie sicher, dass das Microsoft Dynamics AX Server Configuration-Hilfsprogramm den richtigen TCP/IP-Port verwendet. Überprüfen Sie dann, ob der richtige Port für den Microsoft Dynamics AX-Client verwendet wird. Gehen Sie zu diesem Zweck folgendermaßen vor:
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Klicken Sie auf Start, zeigen Sie auf Alle Programme,zeigen Sie auf Administrative Tools, und klicken Sie dann auf Microsoft Dynamics AX Server Configuration Utility.
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Klicken Sie auf die entsprechende Instanz des AOS-Servers und die entsprechende Konfiguration.
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Klicken Sie auf die Registerkarte Application Object Server.
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Überprüfen Sie, ob die Portnummer im Feld TCP/IP-Port korrekt ist, und klicken Sie dann auf OK.
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Klicken Sie auf Start, zeigen Sie auf Alle Programme,zeigen Sie auf Administrative Tools, und klicken Sie dann auf Microsoft Dynamics AX Configuration Utility.
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Klicken Sie auf die Registerkarte Verbindung.
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Notieren Sie sich die TCP/IP-Portnummer. Wenn der AOS-Servername und die Portnummer falsch sind, geben Sie den richtigen AOS-Servernamen ein. Geben Sie dann die Portnummer ein, die Sie in Schritt 4 überprüft haben.
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Klicken Sie auf OK.
Lösung 3
Um dieses Problem zu beheben, überprüfen Sie, ob die Version des AOS-Diensts der Version des Microsoft Dynamics AX-Clients entspricht. Führen Sie dazu die folgenden Schritte aus:
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Suchen Sie die Version des Microsoft Dynamics AX-Clients. Gehen Sie zu diesem Zweck folgendermaßen vor:
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Klicken Sie im Menü Hilfe auf Informationen zu Microsoft Dynamics AX.
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Beachten Sie die Kernelversion und die Anwendungsversion.
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Suchen Sie die Version des AOS-Diensts. Gehen Sie zu diesem Zweck folgendermaßen vor:
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Suchen Sie die Ax32Serv.exe auf dem AOS-Server.Hinweis Die Datei Ax32Serv.exe sich standardmäßig im folgenden Ordner:
C:\Microsoft Dynamics AX\40\Server\AX40SP1\Bin
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Klicken Sie mit der Ax32Serv.exe, und klicken Sie dann auf Eigenschaften.
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Klicken Sie im Dialogfeld Eigenschaften auf Details.
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Notieren Sie sich auf der Registerkarte Details im Feld Dateiversion die Version des AOS-Diensts.
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Auflösung 4
Gehen Sie wie folgt vor, um das Problem zu beheben:
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Klicken Sie auf Start und dann auf Ausführen, geben Sie cmd in das Feld Öffnen ein, und klicken Sie anschließend auf OK.
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Führen Sie an der Eingabeaufforderung den folgenden Befehl aus.
ping <computer name>
Wenn der Befehl nicht erfolgreich ist oder der Befehl nicht die richtigen Werte zurück gibt, verfügt die Clientarbeitsstation nicht über Netzwerkzugriff.
Auflösung 5
Führen Sie die folgenden Schritte aus, um dieses Problem zu beheben.Hinweis Sie müssen Ein Mitglied der Gruppe der Domänenadministratoren sein, um diese Schritte ausführen zu können.
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Klicken Sie auf Start, zeigen Sie auf Verwaltungstools, zeigen Sie auf Lokale Einstellungen, zeigen Sie auf Lokale Richtlinien ,und klicken Sie dann im AOS auf Benutzerrechtezuweisung.
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Klicken Sie im Netzwerk auf Auf diesen Computer zugreifen.
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Klicken Sie, um das Kontrollkästchen Diese Richtlinieneinstellungen definieren zu aktivieren.
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Fügen Sie die Benutzer hinzu, mit denen Sie eine Verbindung mit AOS herstellen möchten, und fügen Sie die Benutzergruppen hinzu, die Sie mit AOS verbinden möchten.