Gilt für
Microsoft Dynamics AX 4.0 Axapta Object Server

Problembeschreibung

Wenn Sie versuchen, den Microsoft Dynamics AX 4.0-Client zu starten, wird die folgende Fehlermeldung angezeigt:

Verbindung konnte nicht herstellen

Ursache

Dieses Problem kann eine der folgenden Ursachen haben:

  • Der AOS-Dienst (Application Object Server) wird nicht ausgeführt. Weitere Informationen finden Sie unter Auflösung 1 im Abschnitt "Auflösung".

  • Der Microsoft Dynamics AX-Client ist nicht für die Verwendung des richtigen TCP/IP-Ports konfiguriert. Weitere Informationen finden Sie unter Auflösung 2 im Abschnitt "Auflösung".

  • Die Version des AOS-Diensts passt nicht zur Version des Microsoft Dynamics AX-Clients. Weitere Informationen finden Sie unter Auflösung 3 im Abschnitt "Auflösung".

  • Die Clientarbeitsstation hat keinen Netzwerkzugriff. Oder die Clientarbeitsstation kann keine Verbindung mit dem AOS-Server herstellen. Weitere Informationen finden Sie unter Auflösung 4 im Abschnitt "Auflösung".

  • Der Microsoft Dynamics AX-Client ist mit einer Firewall oder mehreren Domänen verbunden. Weitere Informationen finden Sie unter Auflösung 5 im Abschnitt "Auflösung".

  • Die lokale Richtlinie gewährt den AOS-Clients im gleichen Netzwerk nicht das Recht "Zugriff auf diesen Computer über das Netzwerk". Weitere Informationen finden Sie unter Auflösung 6 im Abschnitt "Auflösung".

Fehlerbehebung

Um dieses Problem zu beheben, verwenden Sie die entsprechende Lösung.

Lösung 1

Um dieses Problem zu beheben, starten Sie den AOS-Dienst. Gehen Sie zu diesem Zweck folgendermaßen vor:

  1. Klicken Sie auf Start, zeigen Sie auf Alle Programme,zeigen Sie auf Verwaltungstools, und klicken Sie dann auf Dienste.

  2. Suchen Sie den Microsoft Dynamics AOS-Dienst (Application Object Server).

  3. Wenn der Dienst nicht ausgeführt wird, klicken Sie mit der rechten Maustaste auf den Dienst, und klicken Sie dann auf Starten.Hinweis Der AOS-Dienstname verwendet das folgende Format:

    Dynamics Server$ instance-number AOS-instance-name

Lösung 2

Um dieses Problem zu beheben, stellen Sie sicher, dass das Microsoft Dynamics AX Server Configuration-Hilfsprogramm den richtigen TCP/IP-Port verwendet. Überprüfen Sie dann, ob der richtige Port für den Microsoft Dynamics AX-Client verwendet wird. Gehen Sie zu diesem Zweck folgendermaßen vor:

  1. Klicken Sie auf Start, zeigen Sie auf Alle Programme,zeigen Sie auf Administrative Tools, und klicken Sie dann auf Microsoft Dynamics AX Server Configuration Utility.

  2. Klicken Sie auf die entsprechende Instanz des AOS-Servers und die entsprechende Konfiguration.

  3. Klicken Sie auf die Registerkarte Application Object Server.

  4. Überprüfen Sie, ob die Portnummer im Feld TCP/IP-Port korrekt ist, und klicken Sie dann auf OK.

  5. Klicken Sie auf Start, zeigen Sie auf Alle Programme,zeigen Sie auf Administrative Tools, und klicken Sie dann auf Microsoft Dynamics AX Configuration Utility.

  6. Klicken Sie auf die Registerkarte Verbindung.

  7. Notieren Sie sich die TCP/IP-Portnummer. Wenn der AOS-Servername und die Portnummer falsch sind, geben Sie den richtigen AOS-Servernamen ein. Geben Sie dann die Portnummer ein, die Sie in Schritt 4 überprüft haben.

  8. Klicken Sie auf OK.

Lösung 3

Um dieses Problem zu beheben, überprüfen Sie, ob die Version des AOS-Diensts der Version des Microsoft Dynamics AX-Clients entspricht. Führen Sie dazu die folgenden Schritte aus:

  1. Suchen Sie die Version des Microsoft Dynamics AX-Clients. Gehen Sie zu diesem Zweck folgendermaßen vor:

    1. Klicken Sie im Menü Hilfe auf Informationen zu Microsoft Dynamics AX.

    2. Beachten Sie die Kernelversion und die Anwendungsversion.

  2. Suchen Sie die Version des AOS-Diensts. Gehen Sie zu diesem Zweck folgendermaßen vor:

    1. Suchen Sie die Ax32Serv.exe auf dem AOS-Server.Hinweis Die Datei Ax32Serv.exe sich standardmäßig im folgenden Ordner:

      C:\Microsoft Dynamics AX\40\Server\AX40SP1\Bin

    2. Klicken Sie mit der Ax32Serv.exe, und klicken Sie dann auf Eigenschaften.

    3. Klicken Sie im Dialogfeld Eigenschaften auf Details.

    4. Notieren Sie sich auf der Registerkarte Details im Feld Dateiversion die Version des AOS-Diensts.

Auflösung 4

Gehen Sie wie folgt vor, um das Problem zu beheben:

  1. Klicken Sie auf Start und dann auf Ausführen, geben Sie cmd in das Feld Öffnen ein, und klicken Sie anschließend auf OK.

  2. Führen Sie an der Eingabeaufforderung den folgenden Befehl aus.

    ping <computer name>

    Wenn der Befehl nicht erfolgreich ist oder der Befehl nicht die richtigen Werte zurück gibt, verfügt die Clientarbeitsstation nicht über Netzwerkzugriff.

Auflösung 5

Führen Sie die folgenden Schritte aus, um dieses Problem zu beheben.Hinweis Sie müssen Ein Mitglied der Gruppe der Domänenadministratoren sein, um diese Schritte ausführen zu können.

  1. Klicken Sie auf Start, zeigen Sie auf Verwaltungstools, zeigen Sie auf Lokale Einstellungen, zeigen Sie auf Lokale Richtlinien ,und klicken Sie dann im AOS auf Benutzerrechtezuweisung.

  2. Klicken Sie im Netzwerk auf Auf diesen Computer zugreifen.

  3. Klicken Sie, um das Kontrollkästchen Diese Richtlinieneinstellungen definieren zu aktivieren.

  4. Fügen Sie die Benutzer hinzu, mit denen Sie eine Verbindung mit AOS herstellen möchten, und fügen Sie die Benutzergruppen hinzu, die Sie mit AOS verbinden möchten.

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