Gilt für
Dynamics CRM 4.0

Problembeschreibung

Wenn Sie versuchen, einen Bericht in Microsoft Dynamics CRM 4,0 zu drucken, wird die folgende Fehlermeldung angezeigt:

Client-Drucksteuerung konnte nicht geladen werden.

Dieses Problem tritt auf, wenn Sie das Update für SQL Server 2005 Service Pack 2 General Distribution Release (GDR) installieren. Wenn Sie weitere Informationen zum Update für SQL Server 2005 Service Pack 2 GDR erhalten möchten, klicken Sie auf die folgende Artikelnummer, um den Artikel in der Microsoft Knowledge Base anzuzeigen:

954606 MS08-052: Beschreibung des Sicherheitsupdates für GDI+ für SQL Server 2005 Service Pack 2 GDR: 9. September 2008

Ursache

Dieses Problem tritt auf, weil das Update für SQL Server 2005 Service Pack 2 GDR die Versionsnummer der RSClientPrint-Klasse aktualisiert. Daher muss das ReportViewer-Steuerelement ebenfalls aktualisiert werden.

Fehlerbehebung

Wenden Sie eine der folgenden Methoden an, um dieses Problem zu beheben:

  • Installieren Sie die Berichtsanzeige Redistributable 2005 Service Pack 1. Besuchen Sie die folgende Microsoft-Website, um die Redistributable 2005 Service Pack 1 von Report Viewer zu erhalten:

    http://www.microsoft.com/download/details.aspx?familyid=82833F27-081D-4B72-83EF-2836360A904D&displaylang=en

  • Installieren des kumulativen Updatepakets 9 für SQL Server 2005 Service Pack 2 Wenn Sie weitere Informationen zum kumulativen Updatepaket 9 für SQL Server 2005 Service Pack 2 erhalten möchten, klicken Sie auf die folgende Artikelnummer, um den Artikel in der Microsoft Knowledge Base anzuzeigen:

    953752 Kumulatives Updatepaket 9 für SQL Server 2005 Service Pack 2   Wenn Sie nach der Installation des kumulativen Updatepakets 9 weiterhin die Fehlermeldung erhalten, die im Abschnitt Problembeschreibung erwähnt wird, löschen Sie die RSClientPrint -Klasse. Gehen Sie dazu wie folgt vor:

    1. Starten Sie Windows Internet Explorer.

    2. Klicken Sie im Menü Extras auf Internetoptionen.

    3. Führen Sie die entsprechenden Schritte aus:

      • Klicken Sie in Windows Internet Explorer 7 im Bereich Browserverlauf auf Einstellungen , und klicken Sie dann auf Objekte anzeigen.

      • Klicken Sie in Microsoft Internet Explorer 6 im Bereich temporäre Internet Dateien auf Einstellungen , und klicken Sie dann auf Objekte anzeigen.

    4. Klicken Sie mit der rechten Maustaste auf RSClientPrint-Klasse, und klicken Sie dann auf Entfernen.

Informationsquellen

Weitere Informationen finden Sie auf der folgenden Microsoft-Website:

http://blogs.msdn.com/mariae/

Benötigen Sie weitere Hilfe?

Möchten Sie weitere Optionen?

Erkunden Sie die Abonnementvorteile, durchsuchen Sie Trainingskurse, erfahren Sie, wie Sie Ihr Gerät schützen und vieles mehr.